Bug 830153 - libpwquality.i686 file conflicts with libpwquality.x86_64
libpwquality.i686 file conflicts with libpwquality.x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libpwquality (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 08:01 EDT by Michal Schmidt
Modified: 2012-06-27 23:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:54:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-06-08 08:01:01 EDT
Description of problem:

libpwquality.{i686,x86_64} cannot be both installed. The problem seems to be caused by not having proper RPM colors on ELF binaries:

$ rpm -q --filecolor libpwquality | grep bin
/usr/bin/pwmake	(none)
/usr/bin/pwscore	(none)

Version-Release number of selected component (if applicable):
libpwquality-1.1.0-1.fc17

How reproducible:
always

Steps to Reproduce:
1. On an x86_64 Fedora system: yum install libpwquality.i686
  
Actual results:
Transaction Check Error:
  file /usr/bin/pwmake from install of libpwquality-1.1.0-1.fc17.i686 conflicts with file from package libpwquality-1.1.0-1.fc17.x86_64
  file /usr/bin/pwscore from install of libpwquality-1.1.0-1.fc17.i686 conflicts with file from package libpwquality-1.1.0-1.fc17.x86_64


Expected results:
The package installs.

Additional info:
The loss of file color is caused by the use of %filter_setup in the spec. The guidelines say (http://fedoraproject.org/wiki/Packaging:AutoProvidesAndRequiresFiltering#Usage):

These filtering macros MUST only be used with packages which meet one of the following criteria:
- Noarch packages
- Architecture specific packages with no binaries in $PATH (e.g. /bin,
  /usr/bin, /sbin, /sbin) or libexecdir and no system libs in libdir.
  This includes all of the subpackages generated from the spec file. 
They are not permitted in any other cases, because the macros interfere with the "coloring" of elf32/64 executables done internally by RPM to support multilib installs.
Comment 1 Michal Schmidt 2012-06-08 08:04:04 EDT
See also https://bugzilla.redhat.com/show_bug.cgi?id=729536#c4 where Panu Matilainen suggested using rpm's native support for filtering, http://rpm.org/wiki/PackagerDocs/DependencyGenerator
Comment 2 Fedora Update System 2012-06-08 08:33:39 EDT
libpwquality-1.1.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-8576/libpwquality-1.1.0-2.fc17
Comment 3 Fedora Update System 2012-06-11 20:25:51 EDT
Package libpwquality-1.1.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpwquality-1.1.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8576/libpwquality-1.1.0-2.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-06-14 20:28:32 EDT
Package libpwquality-1.1.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpwquality-1.1.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8576/libpwquality-1.1.1-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-27 23:54:40 EDT
libpwquality-1.1.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.