Bug 729536 - %filter_setup kills color
Summary: %filter_setup kills color
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jeff Law
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 729620 730008 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 05:52 UTC by dominique
Modified: 2016-11-24 15:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-10 03:43:31 UTC


Attachments (Terms of Use)

Description dominique 2011-08-10 05:52:07 UTC
Description of problem

Today there is an update for glibc : glibc-2.14.90

But there is an error when I want update :

07:43:13 : YUM: Test de la transaction en cours

07:43:22 : ERROR: Erreur dans la transaction de yum : Erreurs de la transaction de test :   file /sbin/ldconfig conflicts between attempted installs of glibc-2.14.90-4.1.i686 and glibc-2.14.90-4.1.x86_64
07:43:22 : YUM:   file /sbin/sln conflicts between attempted installs of glibc-2.14.90-4.1.i686 and glibc-2.14.90-4.1.x86_64

07:43:22 : YUM:   file /usr/sbin/iconvconfig conflicts between attempted installs of glibc-2.14.90-4.1.i686 and glibc-2.14.90-4.1.x86_64

I don't know if it's a bug, but I rapport it...

Comment 1 Andreas Schwab 2011-08-10 09:14:24 UTC
Looks like multilib handling is broken.

Comment 2 Andreas Schwab 2011-08-10 12:18:38 UTC
*** Bug 729620 has been marked as a duplicate of this bug. ***

Comment 3 Andreas Schwab 2011-08-11 14:30:34 UTC
*** Bug 730008 has been marked as a duplicate of this bug. ***

Comment 4 Panu Matilainen 2011-08-15 06:54:44 UTC
The Fedora-specific filtering macros are incompatible with multilib packages, see http://fedoraproject.org/wiki/Packaging:AutoProvidesAndRequiresFiltering#Usage

In other words, you cannot use %filter_setup & friends with glibc. In Fedora >= 15 rpm has native support for dependency filtering which is multilib-safe, see "Tweaking Dependency Generators" section in http://rpm.org/wiki/PackagerDocs/DependencyGenerator.

Comment 5 Fedora Admin XMLRPC Client 2011-11-14 19:45:13 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Jeff Law 2012-02-10 03:43:31 UTC
This was fixed in the 2.14.90-5 release.


Note You need to log in before you can comment on or make changes to this bug.