Bug 830219 - Improve yum plugin output across RHN and Subscription Management
Improve yum plugin output across RHN and Subscription Management
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.4
Assigned To: Stephen Herr
Pavel Studeník
:
Depends On: 830193 830194 842396
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-06-08 10:55 EDT by Clifford Perry
Modified: 2013-02-21 05:07 EST (History)
4 users (show)

See Also:
Fixed In Version: yum-rhn-plugin-0.9.1-41-el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 830194
Environment:
Last Closed: 2013-02-21 05:07:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2012-06-08 10:55:41 EDT
+++ This bug was initially created as a clone of Bug #830194 +++

+++ This bug was initially created as a clone of Bug #830193 +++

The following are output which is desired from the RHN and Subscription Managment yum plugins. This bug is for the RHN side of the changes:

Registered to Neither
----------------------------
RHN: This system is not registered to RHN classic. You can can use rhn_reg_ks to register.
SM: This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Registered to RHN Classic (Or Satellite)
----------------------------------------------------
RHN: This system is receiving updates from RHN Classic
SM: This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Registered to Customer Portal (Or SAM or CFSE)
---------------------------------------------------------------
RHN: This system is not registered to RHN classic. You can can use rhn_reg_ks to register.
SM: This system is receiving updates from Red Hat Subscription Management.
-- OR --
SM: This system is registered to Red Hat Subscription Management, but not recieving updates. You can use subscription-manager to assign subscriptions.

Registered to both
------------------------
RHN: This system is receiving updates from RHN Classic
SM: This system is receiving updates from Red Hat Subscription Management.
-- OR --
SM: This system is registered to Red Hat Subscription Management, but not recieving updates. You can use subscription-manager to assign subscriptions.

--- Additional comment from cperry@redhat.com on 2012-06-08 10:52:51 EDT ---

(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #830193 +++
> 

Based on an email thread I have, there is a desire for each plugin to always print something, every time it runs - so that someone knows where they are potentially getting their RHEL content from. 

NOTE: If the yum-rhn-plugin is disabled, we will not print any messages. If it is enabled though, then we will print messages as requested below. *BUT* with small modification.

> The following are output which is desired from the RHN and Subscription
> Managment yum plugins. This bug is for the RHN side of the changes:
> 
> Registered to Neither
> ----------------------------
> RHN: This system is not registered to RHN classic. You can can use
> rhn_reg_ks to register.

Registered to Neither:
RHN: This system is not registered to RHN Classic. You can use rhn_register to register. 

> SM: This system is not registered to Red Hat Subscription Management. You
> can use subscription-manager to register.
> 
> Registered to RHN Classic (Or Satellite)
> ----------------------------------------------------
> RHN: This system is receiving updates from RHN Classic

Registered to RHN Classic (or Satellite)
RHN: This system is receiving updates from RHN Classic.

> SM: This system is not registered to Red Hat Subscription Management. You
> can use subscription-manager to register.
> 
> Registered to Customer Portal (Or SAM or CFSE)
> ---------------------------------------------------------------
> RHN: This system is not registered to RHN classic. You can can use
> rhn_reg_ks to register.

Registered to Certificate based technologies:
RHN: This system is not registered to RHN Classic. You can use rhn_register to register. 

> SM: This system is receiving updates from Red Hat Subscription Management.
> -- OR --
> SM: This system is registered to Red Hat Subscription Management, but not
> recieving updates. You can use subscription-manager to assign subscriptions.
> 
> Registered to both
> ------------------------
> RHN: This system is receiving updates from RHN Classic

Registered to both:
RHN: This system is receiving updates from RHN Classic.

> SM: This system is receiving updates from Red Hat Subscription Management.
> -- OR --
> SM: This system is registered to Red Hat Subscription Management, but not
> recieving updates. You can use subscription-manager to assign subscriptions.


This bug is tracking for RHEL 5.9. I will clone to track for RHEL 6.4.
Comment 2 RHEL Product and Program Management 2012-07-10 04:18:01 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 22:11:58 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 11 errata-xmlrpc 2013-02-21 05:07:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0389.html

Note You need to log in before you can comment on or make changes to this bug.