Bug 842396 - Improve yum plugin output across RHN and Subscription Management
Improve yum plugin output across RHN and Subscription Management
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On: 830193 830194
Blocks: 771748 830219 space18
  Show dependency treegraph
 
Reported: 2012-07-23 14:19 EDT by Stephen Herr
Modified: 2012-11-01 12:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: yum-rhn-plugin-1.8.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 830194
Environment:
Last Closed: 2012-11-01 12:20:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2012-07-23 14:19:36 EDT
+++ This bug was initially created as a clone of Bug #830194 +++

+++ This bug was initially created as a clone of Bug #830193 +++

The following are output which is desired from the RHN and Subscription Managment yum plugins. This bug is for the RHN side of the changes:

Registered to Neither
----------------------------
RHN: This system is not registered to RHN classic. You can can use rhn_reg_ks to register.
SM: This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Registered to RHN Classic (Or Satellite)
----------------------------------------------------
RHN: This system is receiving updates from RHN Classic
SM: This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Registered to Customer Portal (Or SAM or CFSE)
---------------------------------------------------------------
RHN: This system is not registered to RHN classic. You can can use rhn_reg_ks to register.
SM: This system is receiving updates from Red Hat Subscription Management.
-- OR --
SM: This system is registered to Red Hat Subscription Management, but not recieving updates. You can use subscription-manager to assign subscriptions.

Registered to both
------------------------
RHN: This system is receiving updates from RHN Classic
SM: This system is receiving updates from Red Hat Subscription Management.
-- OR --
SM: This system is registered to Red Hat Subscription Management, but not recieving updates. You can use subscription-manager to assign subscriptions.

--- Additional comment from cperry@redhat.com on 2012-06-08 10:52:51 EDT ---

(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #830193 +++
> 

Based on an email thread I have, there is a desire for each plugin to always print something, every time it runs - so that someone knows where they are potentially getting their RHEL content from. 

NOTE: If the yum-rhn-plugin is disabled, we will not print any messages. If it is enabled though, then we will print messages as requested below. *BUT* with small modification.

> The following are output which is desired from the RHN and Subscription
> Managment yum plugins. This bug is for the RHN side of the changes:
> 
> Registered to Neither
> ----------------------------
> RHN: This system is not registered to RHN classic. You can can use
> rhn_reg_ks to register.

Registered to Neither:
RHN: This system is not registered to RHN Classic. You can use rhn_register to register. 

> SM: This system is not registered to Red Hat Subscription Management. You
> can use subscription-manager to register.
> 
> Registered to RHN Classic (Or Satellite)
> ----------------------------------------------------
> RHN: This system is receiving updates from RHN Classic

Registered to RHN Classic (or Satellite)
RHN: This system is receiving updates from RHN Classic.

> SM: This system is not registered to Red Hat Subscription Management. You
> can use subscription-manager to register.
> 
> Registered to Customer Portal (Or SAM or CFSE)
> ---------------------------------------------------------------
> RHN: This system is not registered to RHN classic. You can can use
> rhn_reg_ks to register.

Registered to Certificate based technologies:
RHN: This system is not registered to RHN Classic. You can use rhn_register to register. 

> SM: This system is receiving updates from Red Hat Subscription Management.
> -- OR --
> SM: This system is registered to Red Hat Subscription Management, but not
> recieving updates. You can use subscription-manager to assign subscriptions.
> 
> Registered to both
> ------------------------
> RHN: This system is receiving updates from RHN Classic

Registered to both:
RHN: This system is receiving updates from RHN Classic.

> SM: This system is receiving updates from Red Hat Subscription Management.
> -- OR --
> SM: This system is registered to Red Hat Subscription Management, but not
> recieving updates. You can use subscription-manager to assign subscriptions.


This bug is tracking for RHEL 5.9. I will clone to track for RHEL 6.4.

--- Additional comment from pm-rhel@redhat.com on 2012-06-08 11:08:41 EDT ---

This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

--- Additional comment from sherr@redhat.com on 2012-07-23 14:03:49 EDT ---

yum-rhn-plugin doesn't care about Subscription Management registration status or errors, so the above can be boiled down to:

If registered to RHN Classic or Satellite display this message:
"This system is receiving updates from RHN Classic."

else display this message:
"This system is not registered to RHN classic. You can can use rhn_reg_ks to register."


The error messages as written above are misleading because they only mention RHN Classic when the user could in fact be registered (or not) to a Satellite. Furthermore, there's actually a couple of ways we could decide that we aren't really registered to Satellite or RHN Classic, so we need to display slightly different error messages in those cases. Also, yum-rhn-plugin has a standard string that it always displays in a variety of error situations that reads "RHN Satellite or RHN classic support will be disabled." I would like to keep that in as-is just in case customers have scripts to parse logs for that string to look for errors. I will implement the fix for this bug so that the messages read as follows:

If never registered to RHN Classic or Satellite:
"This system is not registered to RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN classic support will be disabled."

If previously registered but lost systemid file for whatever reason:
"This system may not be registered to RHN Classic or RHN Satellite. SystemId could not be acquired.
You can use rhn_register to register.
RHN Satellite or RHN classic support will be disabled."

If you are registered and everything goes smoothly:
"This system is receiving updates from RHN Classic or RHN Satellite."

If someone disagrees with my changes to the messages let me know, but I think it still fulfils the actual requirement.
Comment 1 Stephen Herr 2012-07-23 14:50:28 EDT
Committed to spacewalk master: 9e5a8514c9262f004245b3b0a51cb8bae286c56b
Comment 2 Stephen Herr 2012-07-23 15:02:09 EDT
and ae7a155825e96d0da87c6b569fc37d3c5dc799a8
Comment 3 Jan Pazdziora 2012-10-30 15:24:46 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 4 Jan Pazdziora 2012-11-01 12:20:11 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.