Bug 830466 - f17 virt-manager deleting a volume from a storage pool sometimes results in Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
f17 virt-manager deleting a volume from a storage pool sometimes results in P...
Status: CLOSED DUPLICATE of bug 805950
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 18:29 EDT by Reartes Guillermo
Modified: 2012-06-26 10:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 10:58:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
retrace server output (285.29 KB, text/plain)
2012-06-09 20:53 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-06-09 18:29:39 EDT
I was deleting a volume from a storage pool resulted in a crashed virt-manager.
The volume was indeed delted.

I was able to reproduce it by deleting volumes, at one point it happened again.
I reproduced it with the default storage pool.

dmesg:

python[2211]: segfault at e8000001f0 ip 00007f88feb0b783 sp 00007fff051d2040 error 4 in libgtk-x11-2.0.so.0.2400.10[7f88fe970000+467000]


messages:

Jun  9 19:10:25 ulquiorra libvirtd[1065]: 2012-06-09 22:10:25.357+0000: 1065: error : virNetSocketReadWire:999 : End of file while reading data: Input/output error
Jun  9 19:10:30 ulquiorra systemd-logind[1113]: Removed session 7.
Jun  9 19:10:38 ulquiorra systemd-logind[1113]: New session 8 of user root.
Jun  9 19:13:10 ulquiorra kernel: [ 2350.126496] python[2211]: segfault at e8000001f0 ip 00007f88feb0b783 sp 00007fff051d2040 error 4 in libgtk-x11-2.0.so.0.2400.10[7f88fe970000+467000]
Jun  9 19:13:10 ulquiorra abrtd: Directory 'ccpp-2012-06-09-19:13:10-2211' creation detected
Jun  9 19:13:10 ulquiorra abrt[2394]: Saved core dump of pid 2211 (/usr/bin/python2.7) to /var/spool/abrt/ccpp-2012-06-09-19:13:10-2211 (46092288 bytes)
Jun  9 19:13:10 ulquiorra libvirtd[1065]: 2012-06-09 22:13:10.898+0000: 1065: error : virNetSocketReadWire:991 : Cannot recv data: Connection reset by peer
Jun  9 19:13:11 ulquiorra abrtd: New problem directory /var/spool/abrt/ccpp-2012-06-09-19:13:10-2211, processing

abrt:

# cat component 
python

# cat reason 
Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)

# cat kernel 
3.4.0-1.fc17.x86_64

# cat package 
python-2.7.3-6.fc17

# cat cmdline 
/usr/bin/python /usr/share/virt-manager/virt-manager.py
Comment 1 Reartes Guillermo 2012-06-09 20:53:18 EDT
Created attachment 590678 [details]
retrace server output

I just tried the new retrace server. It looks good.
Comment 2 Cole Robinson 2012-06-26 10:58:40 EDT

*** This bug has been marked as a duplicate of bug 805950 ***

Note You need to log in before you can comment on or make changes to this bug.