Bug 830475 - trailing whitespace not stripped from SSH key descriptions
trailing whitespace not stripped from SSH key descriptions
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.1
: ---
Assigned To: Dan Callaghan
:
: 835798 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 20:43 EDT by Dan Callaghan
Modified: 2012-07-19 20:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 20:39:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-06-09 20:43:21 EDT
Version-Release number of selected component (if applicable):

Beaker 0.8.2


Steps to Reproduce:
1. Paste your SSH public key on the prefs page, including a trailing newline
2. Run a job


Actual results:

SSH key description contains the trailing newline. As a result, the kickstart will have something like this:

echo ssh-rsa AAAA... dcallagh@galangal
 >> /root/.ssh/authorized_keys

which doesn't work.


Expected results:

Trailing whitespace is stripped from the key description. In fact, the entire SSH key should probably only be allowed to be one line (containing no newlines).

Also the kickstart snippet should wrap the public key in '' and/or escape all shell metacharacters.
Comment 1 Steven Lawrance 2012-06-27 03:28:05 EDT
*** Bug 835798 has been marked as a duplicate of this bug. ***
Comment 2 Dan Callaghan 2012-07-05 02:32:33 EDT
On Gerrit: http://gerrit.beaker-project.org/1178
Comment 6 Raymond Mancy 2012-07-18 00:19:26 EDT
Verified warning on newline in pubkey; whitespace tripped in DB; and quoted in ks
Comment 7 Dan Callaghan 2012-07-19 20:39:16 EDT
Beaker 0.9.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.