Bug 835798 - missing escaping of SSH key
missing escaping of SSH key
Status: CLOSED DUPLICATE of bug 830475
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.6
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 03:12 EDT by Jan Hutař
Modified: 2014-08-12 00:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 03:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-06-27 03:12:14 EDT
Description of problem:
I have this public SSH key configured in preferences: "ssh-dss AAAAB3N...icWv/bgc= jhutar@redhat.com (Systems Management QA)". This causes syntax error in the scriptlet in KS file which saves the key in /root/.ssh/authorized_keys.


Version-Release number of selected component (if applicable):
Version - 0.9.0


How reproducible:
always


Steps to Reproduce:
1. set key like I have
2. schedule some reservation


Actual results:
[...]
Complete! 
/tmp/ks-script-AvL59M: line 213: syntax error near unexpected token `(' 
/tmp/ks-script-AvL59M: line 213: `echo ssh-dss AAAAB3Nz...icWv/bgc= jhutar@redhat.com (Systems Management QA) >> /root/.ssh/authorized_keys' 
 [1;24r (B )0 [1;24r [H [J [1;1HWelcome to Red Hat Enterprise Linux Server
[...]


Expected results:
should work
Comment 2 Steven Lawrance 2012-06-27 03:28:05 EDT

*** This bug has been marked as a duplicate of bug 830475 ***

Note You need to log in before you can comment on or make changes to this bug.