Bug 830812 - Review Request: paulstretch - an audio time stretching utility
Summary: Review Request: paulstretch - an audio time stretching utility
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alec Leamas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FedoraAudio
TreeView+ depends on / blocked
 
Reported: 2012-06-11 13:10 UTC by Brendan Jones
Modified: 2012-07-26 22:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 22:23:00 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
leamas.alec: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)
Script-generated fix for bad FSF address (15.64 KB, patch)
2012-06-13 12:30 UTC, Alec Leamas
no flags Details | Diff

Description Brendan Jones 2012-06-11 13:10:18 UTC
paulstretch is an audio stretching utility built using the fltk framework. It has been patched to remove dependencies on libmad MP3 library.

SRPM: http://bsjones.fedorapeople.org/paulstretch-2.2.2-1.fc17.src.rpm
SPEC: http://bsjones.fedorapeople.org/paulstretch.spec

Rpmlint outputs on missing man page and FSF address in the source headers.

Comment 1 Alec Leamas 2012-06-13 11:31:54 UTC
Assigning as well

Comment 2 Alec Leamas 2012-06-13 12:29:28 UTC
Package Review
==============

Key:
- = N/A
x = Pass
! = Fail
? = Not evaluated

==== C/C++ ====
[x]: MUST Header files in -devel subpackage, if present.
[x]: MUST Package does not contain any libtool archives (.la)
[x]: MUST Package does not contain kernel modules.
[x]: MUST Package contains no static executables.
[x]: MUST Rpath absent or only used for internal libs.
[x]: MUST Package is not relocatable.

==== Generic ====
[x]: EXTRA Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: EXTRA Spec file according to URL is the same as in SRPM.
[x]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: MUST Package successfully compiles and builds into binary rpms on at
     least one supported primary architecture.
[x]: MUST %build honors applicable compiler flags or justifies otherwise.
[x]: MUST All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: MUST Buildroot is not present
[x]: MUST Package contains no bundled libraries.
[x]: MUST Changelog in prescribed format.
[x]: MUST Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: MUST Sources contain only permissible code or content.
[x]: MUST Each %files section contains %defattr if rpm < 4.4
     Note: Note: defattr macros not found. They would be needed for EPEL5
[x]: MUST Macros in Summary, %description expandable at SRPM build time.
[x]: MUST Package contains desktop file if it is a GUI application.
[x]: MUST Package installs a %{name}.desktop using desktop-file-install if
     there is such a file.
[x]: MUST Package requires other packages for directories it uses.
[x]: MUST Package uses nothing in %doc for runtime.
[x]: MUST Package is not known to require ExcludeArch.
[x]: MUST Permissions on files are set properly.
[x]: MUST Package does not contain duplicates in %files.
[x]: MUST Spec file lacks Packager, Vendor, PreReq tags.
[x]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[-]: MUST Large documentation files are in a -doc subpackage, if required.
[-]: MUST If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %doc.
[!]: MUST License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "*No copyright* GENERATED FILE", "*No copyright* UNKNOWN", "BSD (2
     clause)", "GPL (v2) (with incorrect FSF address)", "GENERATED FILE" For
     detailed output of licensecheck see file:
     /home/leamas/FedoraReview.tmp/src/830812-paulstretch/licensecheck.txt
[x]: MUST Package consistently uses macros (instead of hard-coded directory
     names).
[x]: MUST Package is named using only allowed ascii characters.
[x]: MUST Package is named according to the Package Naming Guidelines.
[x]: MUST Package does not generate any conflict.
[x]: MUST Package obeys FHS, except libexecdir and /usr/target.
[x]: MUST Package must own all directories that it creates.
[x]: MUST Package does not own files or directories owned by other packages.
[x]: MUST Package installs properly.
[x]: MUST Requires correct, justified where necessary.
[x]: MUST Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: MUST Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: MUST Spec file is legible and written in American English.
[x]: MUST Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: MUST Package contains a SysV-style init script if in need of one.
[x]: MUST File names are valid UTF-8.
[x]: MUST Useful -debuginfo package or justification otherwise.
[x]: SHOULD Reviewer should test that the package builds in mock.
[!]: SHOULD If the source package does not include license text(s) as a
     separate file from upstream, the packager SHOULD query upstream to
     include it.
[x]: SHOULD Dist tag is present.
[x]: SHOULD No file requires outside of /etc, /bin, /sbin, /usr/bin,
     /usr/sbin.
[x]: SHOULD Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: SHOULD Package functions as described.
[x]: SHOULD Latest version is packaged.
[x]: SHOULD Package does not include license text files separate from
     upstream.
[x]: SHOULD Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[!]: SHOULD SourceX / PatchY prefixed with %{name}.
     Note: Patch0: paulstretch-nomp3.patch (paulstretch-nomp3.patch)
[x]: SHOULD SourceX is a working URL.
[-]: SHOULD Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: SHOULD Package should compile and build into binary rpms on all supported
     architectures.
[-]: SHOULD %check is present and all tests pass.
[x]: SHOULD Packages should try to preserve timestamps of original installed
     files.
[-]: SHOULD Spec use %global instead of %define.

Blocking issues:

 - There are some BSD files in the sources, the License: needs fixing.

Other issues:

 - Please inform upstream about the missing license file, 
   bringing bug tracker URL or similar into the spec.
 - Likewise, inform upstream about the bad FSF address 
   and bring URL into spec. You might want to apply 
   and/or submit the patch I attach (yes, I have a script...)
 - Update patch comments on "submitted upstream" to 
   include bug tracker URl or similar.
   

Rpmlint
-------
Checking: paulstretch-2.2.2-1.fc16.src.rpm
          paulstretch-2.2.2-1.fc16.i686.rpm
          paulstretch-debuginfo-2.2.2-1.fc16.i686.rpm
paulstretch.i686: W: no-manual-page-for-binary paulstretch
paulstretch-debuginfo.i686: E: incorrect-fsf-address /usr/src/debug/paulstretch-2.2-2/globals.h
[another 31 FSF warnigs omitted]
3 packages and 0 specfiles checked; 32 errors, 1 warnings.


Rpmlint (installed packages)
----------------------------
# rpmlint paulstretch-debuginfo paulstretch
paulstretch-debuginfo.i686: I: enchant-dictionary-not-found en_US
paulstretch-debuginfo.i686: E: incorrect-fsf-address /usr/src/debug/paulstretch-2.2-2/globals.h
[another 31 FSF warnings omitted]
paulstretch.i686: W: no-manual-page-for-binary paulstretch
2 packages and 0 specfiles checked; 32 errors, 1 warnings.
# echo 'rpmlint-done:'

Requires
--------
paulstretch-2.2.2-1.fc16.i686.rpm (rpmlib, GLIBC filtered):
    
    libaudiofile.so.0  
    libc.so.6  
    libfftw3f.so.3  
    libfltk.so.1.3  
    libgcc_s.so.1  
    libgcc_s.so.1(GCC_3.0)  
    libjack.so.0  
    libm.so.6  
    libmxml.so.1  
    libogg.so.0  
    libportaudio.so.2  
    libpthread.so.0  
    libsamplerate.so.0  
    libsamplerate.so.0(libsamplerate.so.0.0)  
    libstdc++.so.6  
    libstdc++.so.6(CXXABI_1.3)  
    libvorbis.so.0  
    libvorbisenc.so.2  
    libvorbisfile.so.3  
    libz.so.1  
    libz.so.1(ZLIB_1.2.3.3)  
    rtld(GNU_HASH)  

paulstretch-debuginfo-2.2.2-1.fc16.i686.rpm (rpmlib, GLIBC filtered):
    

Provides
--------
paulstretch-2.2.2-1.fc16.i686.rpm:
    
    paulstretch = 2.2.2-1.fc16
    paulstretch(x86-32) = 2.2.2-1.fc16

paulstretch-debuginfo-2.2.2-1.fc16.i686.rpm:
    
    paulstretch-debuginfo = 2.2.2-1.fc16
    paulstretch-debuginfo(x86-32) = 2.2.2-1.fc16

MD5-sum check
-------------
/home/leamas/FedoraReview.tmp/src/830812-paulstretch/upstream/paulstretch-2.2-2.tar.bz2 :
  MD5SUM this package     : 172dec7ad316ea4df0fda6d97758c5f2
  MD5SUM upstream package : 172dec7ad316ea4df0fda6d97758c5f2


Generated by fedora-review 0.2.0git
External plugins:

Comment 3 Alec Leamas 2012-06-13 12:30:37 UTC
Created attachment 591469 [details]
Script-generated fix for bad FSF address

Comment 4 Brendan Jones 2012-07-04 05:47:37 UTC

 rpmlint /home/bsjones/rpmbuild/SRPMS/paulstretch-2.2.2-2.fc17.src.rpm /home/bsjones/rpmbuild/RPMS/x86_64/paulstretch-2.2.2-2.fc17.x86_64.rpm /home/bsjones/rpmbuild/RPMS/x86_64/paulstretch-debuginfo-2.2.2-2.fc17.x86_64.rpm
paulstretch.x86_64: W: no-manual-page-for-binary paulstretch
3 packages and 0 specfiles checked; 0 errors, 1 warnings.

Thanks for the patch! No upstream tracker I'm afraid


SRPM: http://bsjones.fedorapeople.org/paulstretch-2.2.2-1.fc17.src.rpm
SPEC: http://bsjones.fedorapeople.org/paulstretch.spec

Comment 5 Alec Leamas 2012-07-04 21:03:17 UTC
Yes there is:  https://github.com/paulnasca/paulstretch_cpp/issues. I think it's a good idea to file the issues mentioned there, and bring url:s into spec.

However, these issues are not blockers:

**Approved

Comment 6 Brendan Jones 2012-07-05 02:38:59 UTC
Will do. Thanks for the review!

New Package SCM Request
=======================
Package Name: paulstretch
Short Description: audio time stretching utility
Owners: bsjones
Branches: f16 f17
InitialCC:

Comment 7 Gwyn Ciesla 2012-07-05 12:25:40 UTC
Git done (by process-git-requests).

Comment 8 Fedora Update System 2012-07-09 18:00:32 UTC
paulstretch-2.2.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/paulstretch-2.2.2-2.fc17

Comment 9 Fedora Update System 2012-07-09 18:00:46 UTC
paulstretch-2.2.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/paulstretch-2.2.2-2.fc16

Comment 10 Fedora Update System 2012-07-10 16:30:55 UTC
paulstretch-2.2.2-2.fc17 has been pushed to the Fedora 17 testing repository.

Comment 11 Fedora Update System 2012-07-26 22:23:00 UTC
paulstretch-2.2.2-2.fc17 has been pushed to the Fedora 17 stable repository.

Comment 12 Fedora Update System 2012-07-26 22:38:28 UTC
paulstretch-2.2.2-2.fc16 has been pushed to the Fedora 16 stable repository.


Note You need to log in before you can comment on or make changes to this bug.