Bug 830858 - sanlock & wdmd initscripts set to start at same priority as libvirtd, giving bad startup ordering
sanlock & wdmd initscripts set to start at same priority as libvirtd, giving ...
Status: CLOSED DUPLICATE of bug 849184
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Teigland
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 10:17 EDT by Daniel Berrange
Modified: 2013-07-03 22:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 17:14:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-06-11 10:17:54 EDT
Description of problem:
The libvirtd initscript is set to start at priority 97. libvirtd requires that sanlock is already running. sanlock in turn requires that wdmd is already running. Unfortunately both sanlock & wdmd are set to the same priority as libvirtd, 97.

sanlock and wdmd need their priorities changed, so that correct startup ordering is applied. Moving them to sanlock=96,04 and wdmd=95=05 would be sufficient.

Version-Release number of selected component (if applicable):
sanlock-2.3-1.el6.x86_64

How reproducible:


Steps to Reproduce:
1. # grep chkconfig /etc/init.d/wdmd 
2. # grep chkconfig /etc/init.d/sanlock 
  
Actual results:
# chkconfig: 2345 97 03
# chkconfig: 2345 97 03

Expected results:
# chkconfig: 2345 95 05
# chkconfig: 2345 96 04


Additional info:
Comment 2 David Teigland 2012-06-11 11:10:56 EDT
What role does "Required-Start" play in this?  Does the init script just fail immediately if something listed as required is not started?

# Provides: sanlock
# Required-Start: $time $syslog wdmd
Comment 3 Daniel Berrange 2012-06-11 11:24:50 EDT
Those comments have little-to-no-effect on the init process itself. IIUC, those comments are only used by tools which configure init. eg if you ask for 'sanlock' to be enabled, the tool would also enable wdmd. It doesn't impact the actual startup ordering AFAIK. The init scripts simply wildcard glob  '/etc/rc?.d/S*' which relies on the numeric priority for sorting.
Comment 4 David Teigland 2012-06-11 12:05:02 EDT
OK.  I don't know how free we are to change init priorities in an update.  We may have to hack around this in rhel6.
Comment 5 David Teigland 2012-07-12 18:08:44 EDT
I'm trying to understand if this needs to be fixed for RHEV 3.1.  In a RHEV/VDSM environment, does libvirtd startup require sanlock and wdmd to be running?
Comment 6 David Teigland 2012-09-20 17:14:43 EDT
This was fixed by only connecting to wdmd when needed, not when started.

*** This bug has been marked as a duplicate of bug 849184 ***

Note You need to log in before you can comment on or make changes to this bug.