Bug 849184 - fix service restarts
fix service restarts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Teigland
Haim
:
: 830858 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 11:50 EDT by David Teigland
Modified: 2014-01-12 19:53 EST (History)
7 users (show)

See Also:
Fixed In Version: sanlock-2.3-4.el6_3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:15:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2012-08-17 11:50:24 EDT
Description of problem:

The sanlock and wdmd daemons maintained a constant connection even when it
was not needed.  This prevented them from each being restarted
independently for upgrade.

test: put into maintenance mode, so no sanlock lockspaces are in use, then
verify restarting each works:
service wdmd restart
Stopping wdmd:                                             [  OK  ]
Starting wdmd:                                             [  OK  ]
service sanlock restart
Sending stop signal sanlock:                               [  OK  ]
Waiting for sanlock to stop:                               [  OK  ]
Starting sanlock:                                          [  OK  ]

commit
sanlock/wdmd: remove global connection

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 David Teigland 2012-08-22 12:11:18 EDT
now two commits
sanlock/wdmd: remove global connection
init: use checkpid when stopping the services
Comment 4 David Teigland 2012-09-20 17:14:43 EDT
*** Bug 830858 has been marked as a duplicate of this bug. ***
Comment 5 Leonid Natapov 2012-11-28 05:18:00 EST
fixed.
[root@purple-vds3 ~]# rpm -qa | grep sanlock
sanlock-python-2.3-4.el6_3.x86_64
libvirt-lock-sanlock-0.9.10-21.el6_3.6.x86_64
sanlock-2.3-4.el6_3.x86_64
sanlock-lib-2.3-4.el6_3.x86_64

[root@purple-vds3 ~]# service wdmd restart
Sending stop signal wdmd (2039):                           [  OK  ]
Waiting for wdmd (2039) to stop:                           [  OK  ]
Starting wdmd:                                             [  OK  ]
[root@purple-vds3 ~]# service sanlock restart
Sending stop signal sanlock (2066):                        [  OK  ]
Waiting for sanlock (2066) to stop:                        [  OK  ]
Starting sanlock:                                          [  OK  ]
Comment 7 errata-xmlrpc 2012-12-04 13:15:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1507.html

Note You need to log in before you can comment on or make changes to this bug.