Bug 831414 - libogg-devel multilib conflict
libogg-devel multilib conflict
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libogg (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
: 831415 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 19:26 EDT by Philippe Troin
Modified: 2016-01-31 20:56 EST (History)
2 users (show)

See Also:
Fixed In Version: libogg-1.3.0-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-20 16:11:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2012-06-12 19:26:26 EDT
# yum -y install libogg-devel-2:1.3.0-1.fc17.i686
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package libogg-devel.i686 2:1.3.0-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch         Version                Repository       Size
================================================================================
Installing:
 libogg-devel         i686         2:1.3.0-1.fc17         updates          13 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 13 k
Installed size: 17 k
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/include/ogg/config_types.h from install of libogg-devel-2:1.3.0-1.fc17.i686 conflicts with file from package libogg-devel-2:1.3.0-1.fc17.x86_64

Error Summary
-------------

[2]    12466 exit 1     noglob yum -y install libogg-devel-2:1.3.0-1.fc17.i686
Comment 1 Philippe Troin 2012-06-12 19:42:12 EDT
*** Bug 831415 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Admin XMLRPC Client 2013-01-29 10:23:59 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jaromír Cápík 2013-04-09 09:18:13 EDT
Hello Philippe.

The issue seems to be caused by a wrong design of the integer size checks in libogg. I just reordered the checks so that a type common for 32bit and 64bit architectures is chosen during the configuration phase in both cases. That would prevent the devel packages from conflicts caused by differences in the config_types.h header file.

Thanks for the report.

Regards,
Jaromir.
Comment 4 Fedora Update System 2013-04-09 11:19:08 EDT
libogg-1.3.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libogg-1.3.0-5.fc18
Comment 5 Fedora Update System 2013-04-09 11:19:32 EDT
libogg-1.3.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libogg-1.3.0-5.fc19
Comment 6 Fedora Update System 2013-04-09 11:19:50 EDT
libogg-1.3.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libogg-1.3.0-5.fc17
Comment 7 Fedora Update System 2013-04-09 13:04:22 EDT
Package libogg-1.3.0-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libogg-1.3.0-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5232/libogg-1.3.0-5.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-04-20 16:11:38 EDT
libogg-1.3.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-05-23 08:33:19 EDT
libogg-1.3.0-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-05-23 08:38:53 EDT
libogg-1.3.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.