Bug 831547 - guake doesn't lose focus when hidden
guake doesn't lose focus when hidden
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: guake (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
: 834897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 05:29 EDT by Ozan Çağlayan
Modified: 2012-08-31 14:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-12 22:20:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ozan Çağlayan 2012-06-13 05:29:04 EDT
Description of problem:
When you hide the Guake window with F12, it doesn't lose focus. If you have an open Firefox on your workspace, this causes Firefox to badly render the address bar suggestion dropdown menu causing flicker.

Version-Release number of selected component (if applicable):


How reproducible:
Open Firefox
Bring guake by hitting F12
Hide it with F12
Press CTRL+L to go to the address bar and type something. You'll notice that the dropdown menu flickers and you can't see the suggestions.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Open issue in guake's trac:
  http://guake.org/ticket/436
Suggested oneline patch which fixes the problem:
  http://motorscript.com/guake-patch-to-fix-focus-on-gnome/
Comment 1 Pierre-YvesChibon 2012-06-26 03:19:54 EDT
*** Bug 834897 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2012-06-26 03:55:11 EDT
guake-0.4.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-9429/guake-0.4.3-3.fc17
Comment 3 Fedora Update System 2012-06-26 03:56:08 EDT
guake-0.4.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-9408/guake-0.4.3-3.fc16
Comment 4 Fedora Update System 2012-06-26 17:39:19 EDT
Package guake-0.4.3-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing guake-0.4.3-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9429/guake-0.4.3-3.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-07-27 05:38:28 EDT
guake-0.4.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/guake-0.4.4-2.fc16
Comment 6 Fedora Update System 2012-07-27 05:38:39 EDT
guake-0.4.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/guake-0.4.4-2.fc17
Comment 7 Fedora Update System 2012-08-01 16:53:19 EDT
guake-0.4.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/guake-0.4.4-3.fc16
Comment 8 Fedora Update System 2012-08-01 16:53:38 EDT
guake-0.4.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/guake-0.4.4-3.fc17
Comment 9 Fedora Update System 2012-08-01 16:53:53 EDT
guake-0.4.4-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/guake-0.4.4-3.el6
Comment 10 Fedora Update System 2012-08-12 22:20:57 EDT
guake-0.4.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-08-12 22:23:18 EDT
guake-0.4.4-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-08-31 14:31:56 EDT
guake-0.4.4-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.