Bug 831577 - user data are not passed when creating an instance
user data are not passed when creating an instance
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jan Provaznik
dgao
: ZStream
Depends On:
Blocks: 832515
  Show dependency treegraph
 
Reported: 2012-06-13 07:08 EDT by Jan Provaznik
Modified: 2012-12-04 10:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cloud Engine was not sending user data to the Audrey Config Server when creating an instance. This caused instances to fail upon launch. This bug fix sends the user data and provides successful instance launch.
Story Points: ---
Clone Of:
: 832515 (view as bug list)
Environment:
Last Closed: 2012-12-04 10:10:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Provaznik 2012-06-13 07:08:24 EDT
Conductor doesn't send userdata param when launching an instance, this causes that launch time params don't work then on launched instances.

This is a regression caused by a patch for 796528 (pushed to 1.0.1), original description can be found here: https://bugzilla.redhat.com/show_bug.cgi?id=796528#c26

Good news is that patch for this is really simple.
Comment 1 Jan Provaznik 2012-06-13 07:30:37 EDT
a patch sent: https://fedorahosted.org/pipermail/aeolus-devel/2012-June/010885.html
Comment 2 dgao 2012-06-13 11:11:06 EDT
The patch looks good:


[root@10-16-120-124 ~]# audrey
[root@10-16-120-124 ~]# cat /var/log/audrey.log 
2012-06-13 11:10:19,924 - INFO    : audrey:1293 Invoked audrey_script_main
2012-06-13 11:10:20,147 - INFO    : audrey:1321 
<Instance of: CSClient
	Version: 1
	Config Server Endpoint: https://deaddonkey.usersys.redhat.com
	Config Server oAuth Key: 4fb4417e-b567-11e1-9376-e83935c21f2c
	Config Server oAuth Secret: 4P6KpUbrtDezDpSb4oocDxyn3gTRi9FRUylmCFvN0DPao7pkZA
	Config Server Params: 
	Config Server Configs: 
	Temporary Directory: 
	Tarball Name: 
eot>
2012-06-13 11:10:20,149 - INFO    : audrey:944 Invoked CSClient.get_cs_tooling()
2012-06-13 11:10:20,359 - INFO    : audrey:682 Invoked unpack_tooling()
2012-06-13 11:10:20,360 - INFO    : audrey:901 Invoked CSClient.get_cs_configs()
2012-06-13 11:10:20,564 - INFO    : audrey:916 Invoked CSClient.get_cs_params()
2012-06-13 11:10:20,771 - INFO    : audrey:520 Invoked generate_provides()
2012-06-13 11:10:21,163 - INFO    : audrey:931 Invoked CSClient.put_cs_params_values()
Comment 3 Jan Provaznik 2012-06-15 11:07:32 EDT
pushed to master, commit: 93f39f25ac386dabcef3b86afb4ad8e808207c8f
Comment 5 dgao 2012-09-20 15:50:18 EDT
Deployable used:

<?xml version="1.0"?>
<deployable version="1.0" name="rhel62_test">
  <description/>
  <assemblies>
    <assembly name="test" hwp="small-x86_64">
      <image id="80f54e44-01b7-11e2-9261-00145e6d1d0c"/>
      <services>
        <service name="http">
          <executable url="https://zhongyong.usersys.redhat.com/redirect_script"/>
          <files>
            <file url="https://zhongyong.usersys.redhat.com/redirect_script"/>
          </files>
          <parameters>
            <parameter name="foo">
                <value>bar</value>
            </parameter>
          </parameters>
        </service>
      </services>
    </assembly>
  </assemblies>
</deployable>

Verified
Comment 7 errata-xmlrpc 2012-12-04 10:10:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.