Bug 831645 - Audrey Agent Fails to Access RHEVm User Data
Audrey Agent Fails to Access RHEVm User Data
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-audrey-agent (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Joe Vlcek
Rehana
: Reopened, ZStream
Depends On:
Blocks: 833590
  Show dependency treegraph
 
Reported: 2012-06-13 09:59 EDT by scollier
Modified: 2012-12-04 10:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Attempts to send user data to Red Hat Enterprise Virtualization instances sometimes failed. This bug fix adds an exponential retry mechanism. Cloud Engine retries failed attempts at sending user data with an exponential wait time after each retry.
Story Points: ---
Clone Of:
: 833590 (view as bug list)
Environment:
Last Closed: 2012-12-04 10:10:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scollier 2012-06-13 09:59:40 EDT
Description of problem:

When the audrey agent launches it gives this error message:

# cat /var/log/audrey.log 
2012-06-13 14:45:07,425 - ERROR   : audrey:93 Failed accessing RHEVm user data.


Version-Release number of selected component (if applicable):

# rpm -qa | grep audrey
aeolus-audrey-agent-0.4.5-1.el6.noarch

The hypervisor is:
RHEL - 6Server - 6.2.0.3.el6
VDSM Version - 3.0.112.1

How reproducible:

Sometimes.  Not always.  Sometimes it works.

Steps to Reproduce:
1. Launch a instance that has a <services> element in the app blueprint
2.
3.
  
Actual results:
 fails with above message

Expected results:
accesses user data, contacts config server and runs scripts.

Additional info:


I see it probably 10-20% of launches.
Comment 1 scollier 2012-06-13 21:20:18 EDT
I upgraded the RHEV environment to 3.0.3 today.  I just received the error again when launching to the RHEV environment:


# cat /var/log/audrey.log 
2012-06-14 02:21:47,611 - ERROR   : audrey:93 Failed accessing RHEVm user data.
Comment 2 dgao 2012-06-14 10:03:33 EDT
This bug is caused by:

https://bugzilla.redhat.com/show_bug.cgi?id=831577

which is introduced by applying a bad patch that fixes 

https://bugzilla.redhat.com/show_bug.cgi?id=796528.

Closing this bug because it's not an audrey agent issue.
Comment 3 Jan Provaznik 2012-06-19 09:00:32 EDT
I don't think this is caused by 831577 because:
1) a patch for 831577 was pushed only to 1.0.1 branch (fix of this regression - 796528 - is already in 1.0.1 too), but AFAIK Scott used 1.0.0
2) the problem occurs in 10%-20%, the regression introduced by 831577 caused failure in 100%

Re-opening this bug - a problem is somewhere else.
Comment 4 Joe Vlcek 2012-06-19 16:03:54 EDT
I have a patch in the works. Testing has been successful.
Comment 6 Joe Vlcek 2012-06-20 13:07:39 EDT
commit d66ec3793fab6ce58f48369289b03f378903a606
Comment 7 Joe Vlcek 2012-07-27 09:54:40 EDT
The fix for this bug has been pushed and confirmed by QA.

Why is it still open?
Comment 8 dgao 2012-08-06 11:29:15 EDT
Closing as this is no longer reproducible.
Comment 10 errata-xmlrpc 2012-12-04 10:10:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.