Bug 831675 - [abrt] kernel: [246885.924446] WARNING: at block/genhd.c:1570 disk_clear_events+0x106/0x110()
[abrt] kernel: [246885.924446] WARNING: at block/genhd.c:1570 disk_clear_even...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:c1664a90d2d0f51b367111d834b...
:
: 810677 812024 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:44 EDT by Juha Heljoranta
Modified: 2012-09-18 12:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 12:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Heljoranta 2012-06-13 10:44:08 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.7-1.fc16.x86_64 root=/dev/mapper/vg_foo-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_foo/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks.uuid=luks-59a86a02-47ef-45f5-85ec-f2fa5d7318d1 rd.lvm.lv=vg_foo/lv_root KEYTABLE=fi LANG=en_US.UTF-8
comment:        Occured when usb key was plugged in.
kernel:         3.3.7-1.fc16.x86_64
reason:         [246885.924446] WARNING: at block/genhd.c:1570 disk_clear_events+0x106/0x110()
time:           Wed 13 Jun 2012 05:40:18 PM EEST

backtrace:
:[246885.924446] WARNING: at block/genhd.c:1570 disk_clear_events+0x106/0x110()
:[246885.924448] Hardware name: HP EliteBook 8460p
:[246885.924449] Modules linked in: usb_storage fuse btrfs zlib_deflate libcrc32c ufs hfsplus hfs minix vfat msdos fat jfs xfs reiserfs tcp_lp ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc lockd rfcomm bnep coretemp ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack sunrpc tpm_infineon snd_hda_codec_hdmi snd_hda_codec_idt uvcvideo cdc_ncm usbnet videobuf2_core mii videodev media videobuf2_vmalloc videobuf2_memops cdc_wdm cdc_acm btusb bluetooth arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm iwlwifi mac80211 snd_timer e1000e cfg80211 iTCO_wdt snd iTCO_vendor_support soundcore serio_raw snd_page_alloc ppdev vhost_net macvtap macvlan tun tpm_tis kvm_intel tpm tpm_bios parport_pc parport hp_accel kvm hp_wmi lis3lv02d sparse_keymap input_polldev joydev rfkill microcode uinput xts gf128mul dm_crypt firewire_ohci sdhci_pci sdhci firewire_
:core crc_itu_t mmc_core wmi video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:[246885.924524] Pid: 30728, comm: blkid Not tainted 3.3.7-1.fc16.x86_64 #1
:[246885.924526] Call Trace:
:[246885.924532]  [<ffffffff81057adf>] warn_slowpath_common+0x7f/0xc0
:[246885.924536]  [<ffffffff81057b3a>] warn_slowpath_null+0x1a/0x20
:[246885.924539]  [<ffffffff812ae196>] disk_clear_events+0x106/0x110
:[246885.924543]  [<ffffffff811b6d87>] check_disk_change+0x37/0x80
:[246885.924547]  [<ffffffff813ce01d>] sd_open+0xad/0x1e0
:[246885.924550]  [<ffffffff811b7947>] __blkdev_get+0x317/0x480
:[246885.924553]  [<ffffffff811b7b03>] blkdev_get+0x53/0x300
:[246885.924555]  [<ffffffff811b7e0d>] blkdev_open+0x5d/0x80
:[246885.924560]  [<ffffffff8117f3b0>] __dentry_open+0x290/0x360
:[246885.924563]  [<ffffffff811b7db0>] ? blkdev_get+0x300/0x300
:[246885.924566]  [<ffffffff811807c1>] nameidata_to_filp+0x71/0x80
:[246885.924569]  [<ffffffff8119058c>] do_last+0x26c/0x8e0
:[246885.924572]  [<ffffffff81190d13>] path_openat+0xd3/0x3c0
:[246885.924575]  [<ffffffff81191122>] do_filp_open+0x42/0xa0
:[246885.924578]  [<ffffffff8119d0ff>] ? alloc_fd+0x4f/0x150
:[246885.924580]  [<ffffffff811808c8>] do_sys_open+0xf8/0x1d0
:[246885.924585]  [<ffffffff810d345c>] ? __audit_syscall_entry+0xcc/0x310
:[246885.924587]  [<ffffffff811809c1>] sys_open+0x21/0x30
:[246885.924591]  [<ffffffff815fc529>] system_call_fastpath+0x16/0x1b
Comment 1 Josh Boyer 2012-09-18 12:04:45 EDT
*** Bug 812024 has been marked as a duplicate of this bug. ***
Comment 2 Josh Boyer 2012-09-18 12:04:49 EDT
*** Bug 810677 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2012-09-18 12:05:38 EDT
There were numerous fixes that went into the 3.4 kernel for issues like this.  If you are still seeing this with 3.4 or 3.5, please reopen.

Note You need to log in before you can comment on or make changes to this bug.