Bug 831683 - [RFE] Need Support for Rhel 6.3 JEOS image
[RFE] Need Support for Rhel 6.3 JEOS image
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: 1.0.1
: ---
Assigned To: Ian McLeod
Rehana
: FutureFeature, Rebase, ZStream
Depends On: 822139
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:48 EDT by Chris Pelland
Modified: 2013-02-26 23:42 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Building and pushing Red Hat Enterprise Linux 6.3 to Amazon EC2 fails due to a lack of RHEL 6.3 JEOS support. This update adds support for RHEL 6.3 JEOS and provides successful building and pushing of RHEL 6.3 images.
Story Points: ---
Clone Of: 822139
Environment:
Last Closed: 2012-07-10 03:23:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhel6.3_ec2 (897 bytes, text/xml)
2012-06-25 06:19 EDT, Rehana
no flags Details

  None (edit)
Description Chris Pelland 2012-06-13 10:48:55 EDT
+++ This bug was initially created as a clone of Bug #822139 +++

Description of problem: 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Build and Push for Rhel 6.3 is not supported as of now 

this is what i get in imagefactory.log

2012-05-16 05:17:15,586 DEBUG imgfac.BuildJob.BuildJob thread(bd4e50bd) Message: Builder (bd4e50bd-eeb3-455d-b7be-e7d130a2c38c) changed status from PUSHING to FAILED
2012-05-16 05:17:15,586 DEBUG imgfac.BuildJob.BuildJob thread(bd4e50bd) Message: bd4e50bd-eeb3-455d-b7be-e7d130a2c38c for ec2 about to exit ec2 queue...
2012-05-16 05:17:15,586 DEBUG imgfac.ReservationManager.ReservationManager thread(bd4e50bd) Message: EXITING queue: (ec2)
2012-05-16 05:17:15,586 DEBUG imgfac.ReservationManager.ReservationManager thread(bd4e50bd) Message: SUCCESS EXITING queue: (ec2)
2012-05-16 05:17:15,586 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder thread(bd4e50bd) Message: Exception caught in ImageFactory
2012-05-16 05:17:15,587 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder thread(bd4e50bd) Message: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 458, in push_image
    credentials)
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 580, in push_image_snapshot_ec2
    raise ImageFactoryException("No available JEOS for desired OS, verison combination")
ImageFactoryException: No available JEOS for desired OS, verison combination

2012-05-16 05:17:15,587 DEBUG imgfac.BuildJob.BuildJob thread(bd4e50bd) Message: Builder (bd4e50bd-eeb3-455d-b7be-e7d130a2c38c) changed status from FAILED to FAILED

2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from imcleod@redhat.com on 2012-06-13 10:40:17 EDT ---

This is blocked pending availability of the "final" RHEL 6.3 AMIs.  We are doing some internal testing using limited-availability beta AMIs.

I will update this BZ when 6.3 AMIs are available publicly.
Comment 1 Ian McLeod 2012-06-21 15:42:16 EDT
Updated oz and imagefactory are now brewed and in QE.

Factory RPM is: imagefactory-1.0.1-2
Oz RPM is: oz 0.8.0-6
Comment 4 Dan Macpherson 2012-06-24 12:37:58 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Building and pushing Red Hat Enterprise Linux 6.3 to Amazon EC2 fails due to a lack of RHEL 6.3 JEOS support. This update adds support for RHEL 6.3 JEOS and provides successful building and pushing of RHEL 6.3 images.
Comment 5 Rehana 2012-06-25 06:18:21 EDT
Able to build,push rhel6.3 images to all the providers, (vsphere,rhevm,ec2)
attached rhel6.3_ec2.tpl also launched rhel6.3 instances on providers


verified on:

 rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.31-1.el6cf.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-0.8.31-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.31-1.el6cf.noarch
aeolus-configure-2.5.9-1.el6cf.noarch
aeolus-all-0.8.31-1.el6cf.noarch

rpm -qa | grep imagefactory
imagefactory-1.0.1-2.el6cf.noarch
imagefactory-jeosconf-ec2-rhel-1.0.1-2.el6cf.noarch
imagefactory-jeosconf-ec2-fedora-1.0.1-2.el6cf.noarch

Oz rpm :

oz-0.8.0-6.el6cf.noarch
Comment 6 Rehana 2012-06-25 06:19:20 EDT
Created attachment 594150 [details]
rhel6.3_ec2
Comment 8 errata-xmlrpc 2012-07-10 03:23:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.