Bug 83170 - oo-1.0.2-1 won't build
oo-1.0.2-1 won't build
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-30 18:21 EST by sean
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 14:43:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
start of errors in rpm build of 00-1.0.2-1 (6.47 KB, text/plain)
2003-01-30 18:23 EST, sean
no flags Details

  None (edit)
Description sean 2003-01-30 18:21:48 EST
Description of problem:
I'm trying to build oo from the rawhide src.rpm. The attachment shows the
problem. Looks like confusion the includes.

FWIW, having tried to build it a number of time directly, I'm amazed you guys
can get it to build at all!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 sean 2003-01-30 18:23:11 EST
Created attachment 89724 [details]
start of errors in rpm build of 00-1.0.2-1
Comment 2 Jakub Jelinek 2003-02-01 10:59:12 EST
Do you have latest mozilla-devel installed?
Comment 3 sean 2003-02-02 10:54:05 EST
Yes. 

 rpm -q mozilla-devel
mozilla-devel-1.2.1-17

All the includes are in various directories under /usr/include/mozilla-1.2.1.
For instance:

 locate nsDebug
/usr/include/mozilla-1.2.1/xpcom/nsDebug.h

I then changed line 303 of the SPEC file:


    %if %{build_mozab}
    zipped=`pwd`/moz/zipped
303 ( cd /usr/include/mozilla-1.2.1/; zip -r $zipped/LINUXGCCIinc.zip * )
    mkdir -p mozzipped/defaults/pref mozzipped/components
    ( cd mozzipped; tar xjf /usr/lib/mozilla-1.2*/mozilla-gcc-3.2-libs.tar.bz2 )  
    # Now modify default MOZILLA_FIVE_HOME setting in libxpcom.s o
    # to %{_sysconfdir}/etc/moz

That didn't work - same result.

Then I set the SPEc file not to build the mozilla address book:

# Define 1 if you want to build mozilla address book support
%define build_mozab 0

That gave the following result:

=============
Building project moz
=============
/usr/src/redhat/BUILD/oo_1.0.2_src/moz/zipped
mkout -- version: 1.3
dmake:  Error -- `LINUXGCCIinc.zip' not found, and can't be made
---* TG_SLO.MK *---
 
ERROR: Error 65280 occurred while making
/usr/src/redhat/BUILD/oo_1.0.2_src/moz/zipped
dmake:  Error code 1, while making 'build_all'
---* TG_SLO.MK *---
error: Bad exit status from /var/tmp/rpm-tmp.90044 (%build)


Comment 4 Jakub Jelinek 2003-02-03 06:45:07 EST
Only %define build_mozab 1 is tested.
For that, it would be interesting where your nsDebug.h is not packed or unpacked.
grep nsDebug.h openoffice-i386-sylvester.devel.redhat.com-213602.log
  adding: xpcom/nsDebug.h (deflated 75%)
  inflating: ../unxlngi4.pro/inc/xpcom/nsDebug.h
COPY: ../unxlngi4.pro/inc/xpcom/nsDebug.h -> /usr/src/build/213603-i386/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/xpcom/nsDebug.h
and after that there is nsDebug.h in:
oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/xpcom
Given that:
-I/usr/src/build/213603-i386/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/xpcom
is passed to gcc, it is found.
Comment 5 sean 2003-02-07 12:35:42 EST
Tried again. Saved the output, which I've attached.

The only reference to nsDebug.h is the error:

grep nsDebug.h openoffice.log
MNSInclude.hxx:92:21: nsDebug.h: No such file or directory

But it is where it's supposed to be:

 locate nsDebug.h
/usr/include/mozilla-1.2.1/xpcom/nsDebug.h

This is a phoebe2 system, FWIW.

Comment 6 sean 2003-02-07 13:57:34 EST
It won't let me attach the fuul log of the openoffice build - no wonder it's 9megs.

Here is the output from grep xpcom:

 grep xpcom openoffice.log
+ zip -r /usr/src/redhat/BUILD/oo_1.0.2_src/moz/zipped/LINUXGCCIinc.zip
absyncsvc accessibility addrbook appcomps appshell autoconfigbrowser caps
chardet chrome commandhandler composer content cookie dbm docshell dom
downloadmanager editor embed_base embedcomponentsexpat exthandler filepicker
find gfx gtkembedmoz gtkxtbin helperAppDlg htmlparser imglib2 impComm4xMail
import inspector intl jar java
 jpeg js jsconsole jsdebug jsurl layout ldap libreg liveconnect locale lwbrk
mailnews mime mimeemitter mimetype mng mork mozldap mpfilelocprovider msgbase
msgbaseutil msgcompose msgdb msgimap msglocal msgmdn msgnews msgsmime necko
necko2 nkcache nspr nss oji pipboot pipnss pippki plugin png pref prefetch
prefmigr profile progressDlg rdf rdfutil regviewer shistory sidebar string txmgr
txtsvc typeahea
dfind uconv ucvcn ucvibm ucvja ucvko ucvlatin ucvmath ucvtw ucvtw2 unicharutil
uriloader util view wallet walletviewers webbrowserpersist webbrwsr webshell
widget windowwatcher xml-rpc xmlextras xpcom xpconnect xpinstall xpnet
xremoteservice xul xuldoc xultmpl zlib  adding: xpcom/ (stored 0%)
+ gcc -o openoffice-fix-libxpcom /usr/src/redhat/SOURCES/openoffice-fix-libxpcom.c
+ ./openoffice-fix-libxpcom mozzipped/libxpcom.so
+ cp -a /usr/lib/mozilla-1.2.1/components/necko_dns.xpt
/usr/lib/mozilla-1.2.1/components/xpcom_base.xpt
/usr/lib/mozilla-1.2.1/components/xpcom_components.xpt
/usr/lib/mozilla-1.2.1/components/xpcom_ds.xpt
/usr/lib/mozilla-1.2.1/components/xpcom_io.xpt
/usr/lib/mozilla-1.2.1/components/xpcom_threads.xpt
/usr/lib/mozilla-1.2.1/components/xpcom_xpti.xpt mozzipped/components/
+ zip /usr/src/redhat/BUILD/oo_1.0.2_src/moz/zipped/LINUXGCCIlib.zip
libembed_base_s.a libmozreg_s.a libnspr4.so libxpcom.so
  adding: libxpcom.so (deflated 67%)
+ zip -r /usr/src/redhat/BUILD/oo_1.0.2_src/moz/zipped/LINUXGCCIruntime.zip
components defaults libldap50.so libmozjs.so libmsgbaseutil.so libnspr4.so
libplc4.so libplds4.so libprldap50.so libxpcom.so
  adding: components/xpcom_base.xpt (deflated 46%)
  adding: components/xpcom_components.xpt (deflated 55%)
  adding: components/xpcom_ds.xpt (deflated 56%)
  adding: components/xpcom_io.xpt (deflated 54%)
  adding: components/xpcom_threads.xpt (deflated 46%)
  adding: components/xpcom_xpti.xpt (deflated 46%)
  adding: libxpcom.so (deflated 67%)
   creating: ../unxlngi4.pro/inc/xpcom/
  inflating: ../unxlngi4.pro/lib/libxpcom.so
  inflating: ../unxlngi4.pro/lib/components/xpcom_base.xpt
  inflating: ../unxlngi4.pro/lib/components/xpcom_components.xpt
  inflating: ../unxlngi4.pro/lib/components/xpcom_ds.xpt
  inflating: ../unxlngi4.pro/lib/components/xpcom_io.xpt
  inflating: ../unxlngi4.pro/lib/components/xpcom_threads.xpt
  inflating: ../unxlngi4.pro/lib/components/xpcom_xpti.xpt
  inflating: ../unxlngi4.pro/lib/libxpcom.so
COPY: ../unxlngi4.pro/lib/libxpcom.so ->
/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/lib/libxpcom.so
g++ -fmessage-length=0 -c -I. -I. -I../inc -I../../../inc -I../../../../inc
-I../../../../unx/inc -I../../../../unxlngi4.pro/inc -I.
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/stl
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/external
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solenv/unxlngi4/inc
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solenv/inc
-I/usr/src/redhat/BUILD/oo_1.0.2_src/res
-I/usr/src/redhat/BUILD/oo_1.0.2_src/fakejdk/include
-I/usr/src/redhat/BUILD/oo_1.0.2_src/STLport-4.5.3/stlport
-I/usr/src/redhat/BUILD/oo_1.0.2_src/STLport-4.5.3/include/stlport
-I/usr/src/redhat/BUILD/oo_1.0.2_src/STLport-4.5.3/include/stlport
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solenv/inc/Xp31 -I/usr/X11R6/include    
-I. -I../../../../res -I. -I..
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla 
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/nspr
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/xpcom 
         
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/string
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/rdf
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/msgbase
       
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/addrbook
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/mork
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/locale
           
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/pref
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/mime
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/chrome
       
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/necko
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/intl
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/profile
     
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/embed_base
-I/usr/src/redhat/BUILD/oo_1.0.2_src/solver/641/unxlngi4.pro/inc/mozilla/mozldap
-march=athlon-xp -m3dnow -msse -mmmx -O2-fPIC -g -march=athlon-xp -m3dnow -msse
-mmmx -O2  -fno-for-scope -fpermissive -fno-use-cxa-atexit -pipe -fexceptions
-fno-enforce-eh-specs              -fno-rtti -Wall -Wconversion -Wpointer-arith
            -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth      
      -Wno-long-long -pthread  -fpic -DLINUX -DUNX -DVCL -DGCC -DC300 -DINTEL
-DCVER=C300 -D_USE_NAMESPACE -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT
-DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -D__DMAKE -DUNIX
-DCPPU_ENV=gcc3 -DSUPD=641 -DBUILD=7663-DPRODUCT -DNDEBUG -DPRODUCT_FULL
-DOPTIMIZE -DEXCEPTIONS_ON -DCUI -DSOLAR_JAVA -DSRC641  -DMOZILLA_CLIENT       
     -DOSTYPE=\"Linux2.2.14-5\" -DOJI             -DNEW_H="<new>" -DTRACING
-DSHAREDLIB -D_DLL_  -DMULTITHREAD  -w -o
../../../../unxlngi4.pro/slo/MDatabaseMetaDataHelper.o
/usr/src/redhat/BUILD/oo_1.0.2_src/connectivity/source/drivers/mozab/mozillasrc/MDatabaseMetaDataHelper.cxx
Comment 7 Dan Williams 2003-10-07 14:59:24 EDT
have you tried 1.0.2-4?
Comment 8 sean 2003-10-07 20:24:12 EDT
Ok - I've dl'd it and I'm now rebuilding it. 

I assume you're the lucky sucker who gets to build 1.1. I've messed around with
it a little. For a small rh user group I put together the following notes -
which I hope will be useful to you:

    I've just built OpenOffice 1.1 rc4 on a RedHat Severn machine, updated from
rawhide. The good news - it can be done and it's a **lot** easier than it used
to be. The last time I tried it - a year ago - I finally gave up.

    But...it is different from building most open source projects. This is a
result of OO being a massive project that's meant to run and build on almost any
operating system.

    This note is very informal. The best real guide is at tools.openoffice.org.

    Here's what to do - or at least what I did:

    0. You must be running a 2.4 kernel.  OpenOffice wil NOT build on 2.6.

    1. Install the Sun java SDK ( not JRE ) 1.4.1. I used j2sdk1.4.1_03. 1.4.2
will NOT work.

    2. Install ant from ant.apache.org. I used 1.5.4.

    3. Make an /opt/openoffice directory - "oo-dir".

    4. Put ftp://ftp.cs.man.ac.uk/pub/toby/gpc/gpc231.tar.Z in the oo-dir. Untar it.

    5. On September 1, the most recent rh rawhide bison was 1.875-3. That will
NOT work. You need 1.875a or later. 1.875a was supposed to be in alpha.gnu.org,
but I never found it. I got the most recent version of bison from CVS at
http://savannah.gnu.org/projects/bison. The CVS version calls itself 1.875c. I
couldn't find any tarballs. To build bison-1.875c you'll need gettext 0.12.1 -
which I found at ftp://ftp.gnu.org/pub/gnu/gettext.

    6. oo.ximian.org says to add to PATH the path to your final oo executable
and the java executable, and the library paths. This makes no sense to me - but
I did it!

    export    \
PATH="/usr/java/j2sdk1.4.1_03/bin:/opt/openoffice/rc4-1.1b/bin:$PATH"
    export      \
LD_LIBRARY_PATH="/opt/openoffice/rc4-1.1b/lib:/usr/java/j2sdk1.4.1_03/lib:/lib:/usr/lib:/lib/i686:/lib/tls"

    7. Get and untar the OO source. Assuming you untar it in oo-dir, the head
directory should be /opt/openoffice/oo_1.1rc4_src -"SRC_ROOT".

    8. Copy the gpc.c and gpc.h files from oo-dir/gpc231 to SRC_ROOT/external/gpc

    9. Now you actually start configuring and making oo. cd to
/opt/openoffice/oo_1.1rc4_src/config_office ( head-dir/config_office ). You're
going to run configure. Here's what I used:

./configure --with-ant-home=/usr/java/ant
--with-jdk-home=/usr/java/j2sdk1.4.1_03 --prefix=/opt/openoffice/rc4-1.1b
--with-dict=EN

Fix it up for your system. The last option tells it to build only the US-English
dictionary ( the default is to build all dictionaries)

    10. Now go back up to SRC_ROOT. The instruction at the end of configure
tells you to run bootstrap. However, all the advice says to do this first:

    source LinuxIntelEnv.Set.sh

Maybe it's no longer necessary but I did it. Then

    ./bootstrap

Assuming it all works, then

    dmake

    11. Go clean the garage. The build takes a looooong time - 6- 8 hours.

    12. If you get an error during the build, just run dmake again. If you get
the same error, post it on the OpenOffice releases mailing list. I got a lot of
"java stack too small - use java Xss" errors. I have no idea what's the problem,
but rerunning dmake made it go away.

    13. When the build finishes you'll see:

............
optimize summary: 0 kb
Replacing ${EVAL} with
Replacing ${LONG_PRODUCTEXTENSION} with
Replacing ${PRODUCTEXTENSION} with
Replacing ${PRODUCTNAME} with OpenOffice.org
Replacing ${PRODUCTVERSION} with 1.1.0

time needed: 0:1:4


WARNING! Project(s):
gtk

not found and couldn't be built. Correct build.lsts.

You're done. Why can't it build project gtk? Because it can't find the gtk2
library. Why can't it find the gtk2 library since it's installed on RedHat?
Great question. but it can't.

    14. Now you're in SRC_ROOT, so:

    cd instsetoo/unxlngi4.pro/01/normal

You'll see a bunch of f_**** files, some README's and two executables - install
and setup. install is a shell script and setup is a binary. I've not seen any
advice to run install - but I did ( hey, why's it there? ). It does allow you to
choose the prefix for OO , i.e. /usr/local (default), /opt/openoffice, etc.

Then ./setup -net. The -net tells it to do a network install. If you're ever
going to have another user, or you with another user name, use OO you'll need 
-net. The only downside is that every user who does setup up a "workstation"
install of OO gets 16megs in his home directory!

You should now be done. Congrats! 
Comment 9 sean 2003-10-07 20:33:37 EDT
I assumed this would take all night, but it died promptly:

 adding: zlib/ (stored 0%)
+ mkdir -p mozzipped/defaults/pref mozzipped/components
+ cd mozzipped
+ tar xjf '/usr/lib/mozilla-1.2*/mozilla-gcc-3.2-libs.tar.bz2'
tar (child): /usr/lib/mozilla-1.2*/mozilla-gcc-3.2-libs.tar.bz2: Cannot open: No
 such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
+ gcc -o openoffice-fix-libxpcom /usr/src/redhat/SOURCES/openoffice-fix-libxpcom .c
+ ./openoffice-fix-libxpcom mozzipped/libxpcom.so
error: Bad exit status from /var/tmp/rpm-tmp.70120 (%prep)


I guess the file used to be there, but it's not now - and no place else. I'm
running severn-2.

sean
Comment 10 Dan Williams 2003-12-05 14:43:34 EST
1.1.0-6 and higher fix mozilla building.

Note You need to log in before you can comment on or make changes to this bug.