Bug 831978 - d-m-multipath has explicit Requires:libudev
d-m-multipath has explicit Requires:libudev
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Marzinski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 831971
  Show dependency treegraph
 
Reported: 2012-06-14 04:34 EDT by Michal Schmidt
Modified: 2012-07-02 04:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-27.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 04:16:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-06-14 04:34:58 EDT
device-mapper-multipath has an explicit Requires on libudev. Please remove it.

udev has been merged into systemd and the libudev package will exist no more. See
http://lists.fedoraproject.org/pipermail/devel/2012-June/168227.html

Explicit Requires on libraries are always suspicous. See
http://fedoraproject.org/wiki/Packaging/Guidelines#Requires

device-mapper-multipath-0:0.4.9-26.fc18.i686
Comment 1 Kay Sievers 2012-06-20 05:39:10 EDT
Ping!

Please rebuild the package, libudev0 will go away soon and the package will
no longer work as expected.
Comment 2 Ben Marzinski 2012-06-28 19:40:05 EDT
Removed the libudev Requires and Buildrequires and replaced them with

Buildrequires: systemd-devel
Comment 3 Michal Schmidt 2012-07-02 04:16:37 EDT
The dependencies of the package in Rawhide look good now. Thanks.

Note You need to log in before you can comment on or make changes to this bug.