Bug 831971 - systemd-libs should Obsolete libudev
systemd-libs should Obsolete libudev
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 829950 (view as bug list)
Depends On: 831978 831981 831984 831986 831987 831991 831994
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 04:29 EDT by Michal Schmidt
Modified: 2012-09-17 11:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 11:09:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-06-14 04:29:33 EDT
As soon as nothing in Rawhide uses libudev.so.0 anymore, we should Obsolete libudev and remove the standalone udev source package.

I will file bugs against packages that still link to libudev.so.0 or require libudev explicitly. The bugs will block this one.

Reference:
"rawhide: libudev version bump, merged into systemd, libudev user need rebuild"
http://lists.fedoraproject.org/pipermail/devel/2012-June/168227.html
Comment 1 Michal Schmidt 2012-06-14 05:01:54 EDT
*** Bug 829950 has been marked as a duplicate of this bug. ***
Comment 2 Kay Sievers 2012-09-14 17:44:26 EDT
Michal, do we need to obsolete it, or can we leave it as it is?

Other distributions, which generally allow parallel installable old lib
packages, do not obsolete the older ones because they might be still in
use by other (third-party) software.

What's the best thing here? Any recommendation?
Comment 3 Bill Nottingham 2012-09-14 17:57:38 EDT
Either you obsolete it, forcing a hard upgrade, or you don't, and people have stale libraries on their machines after a few upgrades.

Fedora's generally done the first option, although in at least some respects, that's because of file conflicts that pop up when people try the second poorly.
Comment 4 Kay Sievers 2012-09-17 11:09:25 EDT
Seems it is already obsoleted:
"libudev < 183 is obsoleted by (installed) systemd-libs-188-3.fc18.x86_64"

Note You need to log in before you can comment on or make changes to this bug.