Bug 831984 - libvirt builds against libudev-devel, which is obsolete
libvirt builds against libudev-devel, which is obsolete
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 831971
  Show dependency treegraph
 
Reported: 2012-06-14 04:45 EDT by Michal Schmidt
Modified: 2012-07-02 14:45 EDT (History)
11 users (show)

See Also:
Fixed In Version: libvirt-0.9.13-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 14:45:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-06-14 04:45:51 EDT
libvirt-0.9.12-1.fc18.src.rpm

libvirt.spec has:
  BuildRequires: libudev-devel >= 145

libudev-devel is going away. Please use systemd-devel. For details see:
http://lists.fedoraproject.org/pipermail/devel/2012-June/168227.html
Comment 1 Daniel Berrange 2012-06-14 05:45:13 EDT
Already fixed upstream, and will be in rawhide after next release of libvirt

commit dd7bc51bc45051b708c1b47b80d1e8402fcbcc5a
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Jun 6 14:03:47 2012 -0400

    spec: Build against systemd for udev
    
    They have now merged. Fedora details here:
    
    https://lists.fedoraproject.org/pipermail/devel/2012-June/168227.html
Comment 2 Michal Schmidt 2012-07-02 04:24:57 EDT
When can we expect the next release to arrive?

It is strange to have fixes for packaging issues blocked on waiting for an upstream release. Why cannot this be fixed in the Fedora spec file right now?
Comment 3 Cole Robinson 2012-07-02 10:29:30 EDT
Because libvirt typically cuts a new release every month which seemed like a reasonable time frame. (and in fact a new release was made today)
Comment 4 Michal Schmidt 2012-07-02 14:45:18 EDT
Great, thanks!

Note You need to log in before you can comment on or make changes to this bug.