Bug 831994 - xorg-x11-drv-nouveau has explicit Requires:libudev
xorg-x11-drv-nouveau has explicit Requires:libudev
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 831971
  Show dependency treegraph
 
Reported: 2012-06-14 05:00 EDT by Michal Schmidt
Modified: 2012-06-14 07:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 07:29:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-06-14 05:00:10 EDT
xorg-x11-drv-nouveau has an explicit Requires on libudev. Please remove it.

udev has been merged into systemd and the libudev package will exist no more. See
http://lists.fedoraproject.org/pipermail/devel/2012-June/168227.html

Explicit Requires on libraries are always suspicous. See
http://fedoraproject.org/wiki/Packaging/Guidelines#Requires

xorg-x11-drv-nouveau-0.0.16-38.20120426git174f170.fc18.src.rpm
Comment 1 Ben Skeggs 2012-06-14 07:29:43 EDT
Fixed in http://koji.fedoraproject.org/koji/taskinfo?taskID=4161535

Note You need to log in before you can comment on or make changes to this bug.