Bug 832119 - Yum Plugin usability Improvements
Yum Plugin usability Improvements
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
urgent Severity unspecified
: rc
: ---
Assigned To: Chris Duryee
Entitlement Bugs
:
Depends On: 818383 837132
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-14 10:50 EDT by Alex Wood
Modified: 2014-07-11 10:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: 818383
Environment:
Last Closed: 2013-01-07 22:55:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0033 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-01-08 03:38:27 EST

  None (edit)
Comment 3 John Sefler 2012-08-24 15:39:01 EDT
Re-verifying for RHEL59 Version...

[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager yum-rhn-plugin
subscription-manager-1.0.14-1.el5
yum-rhn-plugin-0.5.4-28.el5


NOTE: Several of the actual strings verified on RHEL63 have since changed (see bug 847795 and maybe bug 846834).  Hence the messages re-verified below will not be exactly the same as RHEL63.




Testing Case MSG1.............................................
If not registered to either next gen or classic: MSG1

[root@rhsm-accept-rhel5 ~]# subscription-manager unregister
This system is currently not registered.
[root@rhsm-accept-rhel5 ~]# rm -f /etc/sysconfig/rhn/systemid
[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0
[root@rhsm-accept-rhel5 ~]# 

^^^^ VERIFIED, Revised MSG1 is displayed from subscription-manager plugin as well as the corresponding rhnplugin message for RHN Classic/Satellite.




Testing Case MSG2.............................................
If registered to nextgen, but no subscrptions have been consumed: MSG2

[root@rhsm-accept-rhel5 ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@rhsm-accept-rhel5 ~]# subscription-manager register --username stage_test_12
Password: 
The system has been registered with id: 6948eb76-6eab-4e26-aefc-6312af87f1ef 
[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions.
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0
[root@rhsm-accept-rhel5 ~]# 

^^^^ VERIFIED, Revised MSG2 is displayed from subscription-manager plugin while the rhnplugin message continues to state that the system is not registered with RHN Classic/Satellite.




Testing Case MSG3.............................................
If registered and subscriptions have expired, MSG3

[root@rhsm-accept-rhel5 ~]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@rhsm-accept-rhel5 ~]# subscription-manager list --installed | grep Ends
Ends:                 	12/31/2012
[root@rhsm-accept-rhel5 ~]# date 010100002013
Tue Jan  1 00:00:00 EST 2013
[root@rhsm-accept-rhel5 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.9 Beta
Arch:                 	x86_64
Status:               	Expired
Starts:               	
Ends:                 	

[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions.

*** WARNING ***
The subscription for following product(s) has expired:
  - Red Hat Beta
  - Red Hat Enterprise Linux Server
You no longer have access to the repositories that provide these products.  It is important that you apply an active subscription in order to resume access to security and other critical updates. If you don't have other active subscriptions, you can renew the expired subscription.  
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0
[root@rhsm-accept-rhel5 ~]# 

^^^^ VERIFIED, Revised MSG3 is displayed warning us of our expired subscriptions.  Revised MSG1 is also displayed and is true for this verification test.  Finally, the rhnplugin message continues to state that the system is not registered with RHN Classic/Satellite.



Testing Case MSG4.............................................
if there are subscirptions for next gen which are active: MSG4

[root@rhsm-accept-rhel5 ~]# date 082415132012
Fri Aug 24 15:13:00 EDT 2012
[root@rhsm-accept-rhel5 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.9 Beta
Arch:                 	x86_64
Status:               	Subscribed
Starts:               	12/31/2011
Ends:                 	12/31/2012

[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
repo id                       repo name                                         status
rhel-5-server-cf-tools-1-rpms Red Hat CloudForms Tools for RHEL 5 (RPMs)            30
rhel-5-server-rhev-agent-rpms Red Hat Enterprise Virtualization Agents for RHEL      2
rhel-5-server-rpms            Red Hat Enterprise Linux 5 Server (RPMs)          13,951
repolist: 13,983
[root@rhsm-accept-rhel5 ~]# 

^^^^ VERIFIED, Revised MSG4 is displayed from subscription-manager plugin as well as the corresponding rhnplugin message from rhnplugin while the rhnplugin message continues to state that the system is not registered with RHN Classic/Satellite.




Testing Case no-MSG.............................................
If registered to classic, log nothing.

[root@rhsm-accept-rhel5 ~]# rhnreg_ks --serverUrl=https://xmlrpc.rhn.code.stage.redhat.com/XMLRPC --username=qa@redhat.com --password=***** --force --norhnsd --nohardware --nopackages --novirtinfo
[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
rhel-5-server-cf-tools-1-rpms                                  | 2.8 kB     00:00     
rhel-5-server-rhev-agent-rpms                                  | 2.8 kB     00:00     
rhel-5-server-rpms                                             | 3.7 kB     00:00     
repo id                       repo name                                         status
rhel-5-server-cf-tools-1-rpms Red Hat CloudForms Tools for RHEL 5 (RPMs)            30
rhel-5-server-rhev-agent-rpms Red Hat Enterprise Virtualization Agents for RHEL      2
rhel-5-server-rpms            Red Hat Enterprise Linux 5 Server (RPMs)          13,951
rhel-x86_64-server-5          Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)  9,355
repolist: 23,338
[root@rhsm-accept-rhel5 ~]# subscription-manager list --installed | grep Ends
Ends:                 	12/31/2012
[root@rhsm-accept-rhel5 ~]# date 010100002013
Tue Jan  1 00:00:00 EST 2013
[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
rhel-x86_64-server-5                                           | 1.3 kB     00:00     
repo id                  repo name                                              status
rhel-x86_64-server-5     Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)      9,355
repolist: 9,355
[root@rhsm-accept-rhel5 ~]# date 082415212012
Fri Aug 24 15:21:00 EDT 2012
[root@rhsm-accept-rhel5 ~]# subscription-manager list --consumed | grep Serial
Serial Number:        	3054091803820411310
[root@rhsm-accept-rhel5 ~]# subscription-manager unsubscribe --serial=3054091803820411310
This machine has been unsubscribed from subscription with serial number 3054091803820411310
[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
repo id                  repo name                                              status
rhel-x86_64-server-5     Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)      9,355
repolist: 9,355
[root@rhsm-accept-rhel5 ~]# subscription-manager unregister
System has been un-registered.
[root@rhsm-accept-rhel5 ~]# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
repo id                  repo name                                              status
rhel-x86_64-server-5     Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)      9,355
repolist: 9,355
[root@rhsm-accept-rhel5 ~]# 

^^^^ VERIFIED, When registered with RHN classically, the subscription-manager yum plugin did not print revised MSG1 MSG2 MSG3 or MSG4.  

ALL TEST CASES VERIFIED FOR REVISED RHEL59 MSGs.

moving to VERIFIED.
Comment 5 errata-xmlrpc 2013-01-07 22:55:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html
Comment 6 John Sefler 2014-07-11 10:24:47 EDT
Update...
Bug 1058380 removes some of these "Yum Plugin usability Improvements" in subscription-manager-1.12.2+

Note You need to log in before you can comment on or make changes to this bug.