Bug 832166 - Error: no such table: packages
Error: no such table: packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 13:41 EDT by Neal Becker
Modified: 2014-01-21 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-18 21:22:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum output (11.83 KB, text/plain)
2012-11-12 05:49 EST, Andrew Travneff
no flags Details

  None (edit)
Description Neal Becker 2012-06-14 13:41:18 EDT
Description of problem:
$ sudo yum clean all
Loaded plugins: langpacks, presto, refresh-packagekit
Cleaning repos: adobe-linux-i386 fedora google-chrome rpmfusion-free
              : rpmfusion-free-updates rpmfusion-nonfree
              : rpmfusion-nonfree-updates updates
Cleaning up Everything
No delta-package files removed by presto

$ sudo yum update
...
Trying other mirror.
Error: failure: repodata/0b968f695d108474a17710d86d55e8f9ed1b507df8c170e1a27f2e9d11f53d96-primary.sqlite.bz2 from rpmfusion-free-updates: [Errno 256] No more mirrors to try.

$ sudo yum update

$ sudo yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Error: no such table: packages


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Travneff 2012-11-12 05:49:20 EST
Created attachment 643402 [details]
yum output

Have same. Log attached, three commands were executed:

# yum clean all

# yum update

# yum update

Yum version: yum-3.4.3-29.fc17.noarch
Comment 2 Fedora Update System 2012-11-12 09:48:21 EST
yum-3.4.3-30.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-3.4.3-30.fc17
Comment 3 Andrew Travneff 2012-11-12 12:02:18 EST
yum-3.4.3-30.fc17 fixed that for me.
A lot of "HTTP Error 404 - Not Found" and following at the end still remains, but it's an another issue, I think:

Error: Error reading from file /var/cache/yum/x86_64/17/rpmfusion-nonfree-updates/f56ebe3da6bce5ab8eb04f4be534d62b4a6736ee1ba6e0ffbedfe9fbb55b5408-primary.sqlite.bz2: compressed file ended before the logical end-of-stream was detected
Comment 4 dobs 2012-11-12 15:01:32 EST
+1 Can't update packages :(

kernel: 3.4.6-2.fc17.x86_64
Comment 5 Fedora Update System 2012-11-12 19:55:24 EST
Package yum-3.4.3-30.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-30.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18062/yum-3.4.3-30.fc17
then log in and leave karma (feedback).
Comment 6 Andrew Travneff 2012-11-13 05:01:57 EST
(In reply to comment #4)
> +1 Can't update packages :(

If you have same problem with me ("compressed file ended" and abort), you can try following: comment "mirrorlist" line in /etc/yum.repos.d/rpmfusion-nonfree-updates.repo (section rpmfusion-nonfree-updates), and uncomment "baseurl" line.
Then do update and revert that changes. Further updates should be ok because yum will keep good repomd.xml.

Seems like problem with repo metadata at rpmfusion mirrors.
Comment 7 Fedora Update System 2012-11-18 21:22:52 EST
yum-3.4.3-30.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.