Bug 832184 - Disable keepalive in libvirt by default
Disable keepalive in libvirt by default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
: Regression, ZStream
Depends On: 832081
Blocks: 836196 838924
  Show dependency treegraph
 
Reported: 2012-06-14 14:50 EDT by RHEL Product and Program Management
Modified: 2012-07-10 08:55 EDT (History)
13 users (show)

See Also:
Fixed In Version: libvirt-0.9.10-21.el6_3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 836196 (view as bug list)
Environment:
Last Closed: 2012-06-20 06:28:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-06-14 14:50:18 EDT
This bug has been copied from bug #832081 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 7 Daniel Veillard 2012-06-14 23:18:33 EDT
keepalive has been disabled by default in build libvirt-0.9.10-21.el6_3.1

Daniel
Comment 9 dyuan 2012-06-15 05:38:33 EDT
Verified PASS with libvirt-0.9.10-21.el6_3.1, only get the following respons msg in libvirtd.log when there is a client connection.

2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveCheckMessage:408 : ka=0x1062eb0, client=0x1063810, msg=0x10a69d0
2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveCheckMessage:424 : RPC_KEEPALIVE_RECEIVED: ka=0x1062eb0 client=0x1063810 prog=1801807216 vers=1 proc=1
2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveCheckMessage:428 : Got keepalive request from client 0x1063810
2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveScheduleResponse:143 : Scheduling keepalive response to client 0x1063810

2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveResponseTimer:213 : ka=0x1062eb0, client=0x1063810, response=0x1066960
2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveSend:119 : Sending keepalive response to client 0x1063810
2012-06-15 09:27:37.459+0000: 21251: debug : virKeepAliveSend:122 : RPC_KEEPALIVE_SEND: ka=0x1062eb0 client=0x1063810 prog=1801807216 vers=1 proc=2

2012-06-15 09:27:42.439+0000: 21251: debug : virKeepAliveCheckMessage:408 : ka=0x1062eb0, client=0x1063810, msg=0x10a69d0
2012-06-15 09:27:42.439+0000: 21251: debug : virKeepAliveCheckMessage:424 : RPC_KEEPALIVE_RECEIVED: ka=0x1062eb0 client=0x1063810 prog=1801807216 vers=1 proc=1
2012-06-15 09:27:42.439+0000: 21251: debug : virKeepAliveCheckMessage:428 : Got keepalive request from client 0x1063810
2012-06-15 09:27:42.439+0000: 21251: debug : virKeepAliveScheduleResponse:143 : Scheduling keepalive response to client 0x1063810

Also see "Disabled by default." in libvirtd.conf and qemu.conf.


Tested with libvirt-0.9.10-21.el6, can get the following keepalive msg in libvirtd.log.

2012-06-15 09:09:20.832+0000: 19217: debug : virKeepAliveNew:244 : client=0x7f7110, interval=5, count=5
2012-06-15 09:09:20.832+0000: 19217: debug : virEventPollInterruptLocked:702 : Skip interrupt, 1 -564144032
2012-06-15 09:09:20.832+0000: 19217: debug : virEventPollAddTimeout:248 : EVENT_POLL_ADD_TIMEOUT: timer=13 frequency=-1 cb=0x7f1ede738690 opaque=0x7f5a00 ff=0x7f1ede738a60
2012-06-15 09:09:20.832+0000: 19217: debug : virKeepAliveNew:277 : RPC_KEEPALIVE_NEW: ka=0x7f5a00 client=0x7f7110 refs=2

2012-06-15 09:09:20.835+0000: 19220: debug : virKeepAliveStart:353 : RPC_KEEPALIVE_START: ka=0x7f5a00 client=0x7f7110 interval=0 count=0

2012-06-15 09:09:40.883+0000: 19217: debug : virKeepAliveCheckMessage:408 : ka=0x7f5a00, client=0x7f7110, msg=0x7faa30
2012-06-15 09:09:40.883+0000: 19217: debug : virKeepAliveCheckMessage:424 : RPC_KEEPALIVE_RECEIVED: ka=0x7f5a00 client=0x7f7110 prog=1801807216 vers=1 proc=2
2012-06-15 09:09:40.883+0000: 19217: debug : virKeepAliveCheckMessage:433 : Got keepalive response from client 0x7f7110

2012-06-15 09:09:45.889+0000: 19217: debug : virKeepAliveTimer:166 : RPC_KEEPALIVE_TIMEOUT: ka=0x7f5a00 client=0x7f7110 countToDeath=5 idle=5
2012-06-15 09:09:45.889+0000: 19217: debug : virNetMessageNew:48 : msg=0x83aaa0 tracked=0
2012-06-15 09:09:45.889+0000: 19217: debug : virNetMessageEncodePayloadEmpty:441 : Encode length as 28
2012-06-15 09:09:45.889+0000: 19217: debug : virKeepAliveSend:119 : Sending keepalive request to client 0x7f7110
2012-06-15 09:09:45.889+0000: 19217: debug : virKeepAliveSend:122 : RPC_KEEPALIVE_SEND: ka=0x7f5a00 client=0x7f7110 prog=1801807216 vers=1 proc=1

2012-06-15 09:10:00.911+0000: 19217: debug : virKeepAliveCheckMessage:408 : ka=0x7f5a00, client=0x7f7110, msg=0x7faa30
2012-06-15 09:10:00.911+0000: 19217: debug : virKeepAliveCheckMessage:424 : RPC_KEEPALIVE_RECEIVED: ka=0x7f5a00 client=0x7f7110 prog=1801807216 vers=1 proc=2
2012-06-15 09:10:00.911+0000: 19217: debug : virKeepAliveCheckMessage:433 : Got keepalive response from client 0x7f7110
Comment 10 min zhan 2012-06-15 06:26:52 EDT
Move to VERIFIED per Comment 9
Comment 12 errata-xmlrpc 2012-06-20 06:28:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1000.html

Note You need to log in before you can comment on or make changes to this bug.