Bug 832197 - (PM-326, PRODMGT-326) RFE: consider adding Remote Java API samples -- DOCUMENTATION DELIVERABLE
RFE: consider adding Remote Java API samples -- DOCUMENTATION DELIVERABLE
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.1.1
Unspecified Unspecified
unspecified Severity low
: post-GA
: JON 3.2.0
Assigned To: Deon Ballard
Mike Foley
: Reopened
: 1029909 (view as bug list)
Depends On: 1029909 1036153
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2012-06-14 16:04 EDT by Viet Nguyen
Modified: 2014-10-23 08:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1036153 (view as bug list)
Environment:
Last Closed: 2014-03-05 15:47:55 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-326 Major Resolved Need various Java examples using the Remote API 2015-08-19 14:28:32 EDT
Red Hat Knowledge Base (Solution) 478463 None None None Never

  None (edit)
Description Viet Nguyen 2012-06-14 16:04:43 EDT
While working on a demo to show JON Bundles feature I found very little documentation on how to write simple Java CLI client (except for this http://rhq-project.org/display/JOPR2/Building+a+Remote+Java+Client).  It would be great to have a simple working bundle.zip and accompanying java code to showcase the feature.
Comment 2 Alan Santos 2012-11-14 12:09:40 EST
Viet is asking for java examples, not javascript.
Comment 5 Deon Ballard 2013-11-20 21:08:20 EST
*** Bug 1029909 has been marked as a duplicate of this bug. ***
Comment 6 Mike Foley 2013-11-29 10:18:06 EST
The current component here is "Documentation" ... but there is also a Development deliverable here as well.  

Discussed with Heiko ...and for better tracking of the 2 deliverables (doc and dev) we agree it makes sense to clone this PM-326 into another BZ for the development deliverable to package the java samples (location of the java samples is in comment #4)


To be clear ... THIS BZ is the documentation deliverable.,
Comment 7 Mike Foley 2013-11-29 10:26:50 EST
just edited the title to clarify this BZ is the DOCUMENTATION DELIVERABLE.

just for reference, this is the corressponding  DEVELOPMENT DELIVERABLE to PAckAGE the samples.  
https://bugzilla.redhat.com/show_bug.cgi?id=1036153
Comment 9 Deon Ballard 2014-03-05 15:47:55 EST
I missed updating the bug; the JDF has been updated and the JON quickstart is available here:
http://jboss.org/jdf/quickstarts/jboss-as-quickstart/on-quickstarts/rhq-client-ejb/

Note You need to log in before you can comment on or make changes to this bug.