Bug 8323 - dial on demand dosn't work
dial on demand dosn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-10 04:33 EST by winfried.altmann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-24 08:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description winfried.altmann 2000-01-10 04:33:54 EST
I have upgraded from 6.0 to RH 6.1, with all additional updates,
also updated diald-0.99 and ppp to 3.3.11!

After resolving the "char-major-108" and "noauth" problem, i have
still LCP: timeout sending Config-Requests, and later Hangup.

This is here not a problem with my serial port, mine is a 16550A
and it works with the manual dialer wvdial correctly, but the
demand dial won't work.

Sound like the same as your old bug 7335! And this one is not
solved.

This time i'm not knowing, whats wrong, so help is needed!

ThanX Winfried Altmann
Comment 1 winfried.altmann 2000-01-12 03:56:59 EST
Forgotten to tell: with wvdial (manual) everything works well,
that means the hardware is ok.

WinFried Altmann
Comment 2 winfried.altmann 2000-01-17 03:18:59 EST
Sounds like that my ISP don't talk ppp! Anyhow, i have to run a command
to start up the ppp link after login (ie. slirp -P). What is the correct
point to put that command line in?

ThanX WinFried Altmann
Comment 3 Nalin Dahyabhai 2000-01-17 10:08:59 EST
You are correct.  Your ISP does not appear to support PPP directly.  Slirp is a
PPP emulator.  It is not a normal PPP server, and rp3 will very likely not be
able to use it.  You should be able to configure this using our older netcfg
tool.  Essentially, these are the steps to follow:
Start up netcfg.
Select the "Interfaces" tab.
Press "Add".
Select "PPP" and hit "OK".
Enter the phone number, login name, and password.
Hit "Customize".
Select the "Communication" tab.
Select the bottom (probably the fourth) row in the Expect/Send list box.
Press "Insert", and add an entry to expect some part of your shell prompt and
send "slirp -P" to start slirp.

This is one of the few cases rp3 and wvdial don't deal with well.
Comment 4 winfried.altmann 2000-01-20 01:41:59 EST
Yes the problem is somehow located. But, keep in mind, rp3 and wvdial
are the ones who needs interaction! Thats not what i want.

My RH 6.1 has to serve WfW311 and 95 machines, as the internet gateway.
Therefor its not the solution to start the internet manualy.

What is the correct place, to put the expect / send information
maybe from within linuxconfig to run this on demand?

I have tried serveral things, and i get a connection, but after one
hlaf minute, the connection breaks down, like i told you in my personal
mail.

ThanX Winfried Altmann
Comment 5 winfried.altmann 2000-01-24 01:56:59 EST
On yesterday i download from rawhide:

initscripts
pppd

and i prepared a script at my login at my ISP called ppp which invokes
the slirp.

It works! I don't know, whats went wrong, but i think there have been
something within the initscripts.

Anyhow, thanX for support! Winfried Altmann

Note You need to log in before you can comment on or make changes to this bug.