Bug 832387 - Seam2.3 examples richfaces dependency pulls jsf-api compile dependency, causing "mojarra not defined" JS errors.
Seam2.3 examples richfaces dependency pulls jsf-api compile dependency, causi...
Status: CLOSED DEFERRED
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Seam (Show other bugs)
2.0.0.ER8
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 05:53 EDT by Marek Schmidt
Modified: 2012-06-19 04:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 04:18:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-06-15 05:53:55 EDT
Description of problem:

Sometimes a wrong jsf.js is served in the Seam2.3 richfaces examples (reproducible at least in booking and nestedbooking examples), which causes commandLinks not working with "mojarra not defined" javascript errors. The problem seems to be that both the jsf API (org.jboss.spec.javax.faces:jboss-jsf-api_2.1_spec:jar:2.0.2.Final-redhat-1) and the mojarra impl artifacts contains javax.faces/jsf.js, but the version in jsf api doesn't work. The behavior of which resource is served when the API artifact is contained in the .war seems to be platform-dependent.

Steps to reproduce:

1. build and deploy Seam2.3 nestedbooking example
2. attempt to book a room
3. Notice the "select" link on Room Preference page doesn't work.

also notice the /seam-nestedbooking/javax.faces.resource/jsf.js.seam?ln=javax.faces  returns the jsf.js version from jsf API.

The solution seems to be to include

        <dependency>
            <groupId>org.jboss.spec.javax.faces</groupId>
            <artifactId>jboss-jsf-api_2.1_spec</artifactId>
            <scope>provided</scope>
        </dependency>

in foo-web/pom.xml in the richfaces examples to override the default compile scope.
Comment 1 Marek Novotny 2012-06-15 06:21:38 EDT
This is known issue in productized redhat version of jsf-impl artifact.
https://issues.jboss.org/browse/JBEE-114

This issue affects Richfaces component build and we have to worked around it in https://bugzilla.redhat.com/show_bug.cgi?id=820579

Note You need to log in before you can comment on or make changes to this bug.