Bug 832393 - VIP users no longer allowed to launch medium/large gear sizes
VIP users no longer allowed to launch medium/large gear sizes
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 06:10 EDT by Xiaoli Tian
Modified: 2012-06-25 14:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jenkins server log (65.74 KB, text/plain)
2012-06-15 06:10 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Xiaoli Tian 2012-06-15 06:10:26 EDT
Created attachment 592097 [details]
jenkins server log

Description of problem:
Jenkins client which were added to old jboss app use medium gear size for slave builder, it could be built successfully with jenkins before if there are medium size profile.(Change profile to medium if in single node). but now even if the profile has been changed to medium, it will always fail, log in jenkins server is:
"Caused by: com.openshift.express.internal.client.httpclient.BadRequestException: {"exit_code":134,"data":"","api":"1.1.3","debug":"","result":"Invalid Size: medium.  Must be: small.  Please contact support for access to additional sizes.","messages":"","api_c":["placeholder"],"broker_c":["namespace","rhlogin","ssh","app_uuid","debug","alter","cartridge","cart_type","action","app_name","api"]}"


Even if after set user to vip, it still failed with the same error.for even if I'm vip, my gear size is still small
rhc-admin-ctl-user  -l xtian+t00@redhat.com --setvip true

User xtian+t00@redhat.com:
      consumed gears: 4
           max gears: 20
          vip status: true
          gear sizes: small


It will be successful after add medium gear size to the user like below
rhc-admin-ctl-user  -l xtian+t00@redhat.com --addgearsize medium

User xtian+t00@redhat.com:
      consumed gears: 4
           max gears: 20
          vip status: true
          gear sizes: small, medium


The newkly added jenkins client will not be affected since bug 828762 has changed all default size to small.

Version-Release number of selected component (if applicable):
devenv-stage_217

How reproducible:
Always

Steps to Reproduce:
1.Launch an devenv-stage_217
2.create an jboss app with jenkins enabled
3.git push to build
4.update it and migrate it
5.git push to build
  
Actual results:
Step 3 and Step 5 all failed, not sure if some changes already pulled in devenv-stage_217

Expected results:
Step3 and Step 5 should be sucessful

Additional info:
Comment 1 Xiaoli Tian 2012-06-15 09:04:16 EDT
Jbosseap6 are still using medium profile, so if user who do not have medium gear size will fail to build it with jenkins.
Comment 2 Rob Millner 2012-06-15 13:54:52 EDT
There's a number of new jboss/jenkins bugs this morning; we may have to revert back to medium gear sized being the default.
Comment 3 Rob Millner 2012-06-15 15:24:24 EDT
It looks like the real issue is that the "VIP" user status was replaced by a specific list of allowed gear sizes and it no longer works.

Changing the title and moving the bug.
Comment 4 Abhishek Gupta 2012-06-15 18:29:40 EDT
This bug was introduced when we introduced "capabilities". Since new users are now being created with "small" as the capabilities.gear_sizes, we needed this fix.
Comment 5 Meng Bo 2012-06-18 05:47:02 EDT
Verified on latest devenv_1850, issue has been fixed.

User bmeng+1@redhat.com:
      consumed gears: 25
           max gears: 100
          vip status: true
          gear sizes: small

User can create medium size gear after enable VIP flag.

Note You need to log in before you can comment on or make changes to this bug.