Bug 832497 - powertop crashes on launch due to /sys differences for BAT0
powertop crashes on launch due to /sys differences for BAT0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
: 835682 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 10:43 EDT by Alex Chernyakhovsky
Modified: 2012-07-14 18:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-14 17:50:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Chernyakhovsky 2012-06-15 10:43:11 EDT
Description of problem:
powertop crashes with the following message:
terminate called after throwing an instance of 'std::ios_base::failure'
what():  basic_filebuf::underflow error reading the file
Aborted (core dumped)

strace shows
open("/sys/class/power_supply/BAT0/power_now", O_RDONLY) = -1 ENOENT (No such file or directory)                                           open("/sys/class/power_supply/BAT0/energy_now", O_RDONLY) = -1 ENOENT (No such file or directory)

right before the crash, neither of these exist in /sys on my system, but instead there are charge_now, current_now, voltage_now.

Version-Release number of selected component (if applicable):
powertop-2.0-2.fc17.x86_64
kernel-3.4.0-1.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Run powertop on a laptop
2.
3.
  
Actual results:
powertop crashes and dumps core

Expected results:
powertop launches

Additional info:
Comment 1 Lukas Vrabec 2012-06-19 10:50:20 EDT
I have the same problem but on my laptop powertop works fine when it's on AC power. So I think powertop crashes only when laptop is on battery power. I'm using the same version of powertop but my kernel is kernel-3.4.2-4.fc17.x86_64.
Comment 2 Jaroslav Škarvada 2012-07-03 09:18:40 EDT
Could you try the following experimental build?
http://koji.fedoraproject.org/koji/taskinfo?taskID=4216033

Please let me know whether it helps.
Comment 3 Lukas Vrabec 2012-07-03 14:50:16 EDT
So, I have tried it on my laptop and it works fine. Calibracion has also ended successfully and powertop is running without errors. thank you
Comment 4 Jaroslav Škarvada 2012-07-04 04:04:20 EDT
*** Bug 835682 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Škarvada 2012-07-04 04:12:22 EDT
Thanks for testing, pushing the update.
Comment 6 Fedora Update System 2012-07-04 04:29:05 EDT
powertop-2.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/powertop-2.0-3.fc17
Comment 7 Fedora Update System 2012-07-04 04:29:20 EDT
powertop-2.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/powertop-2.0-3.fc16
Comment 8 Fedora Update System 2012-07-05 19:34:22 EDT
Package powertop-2.0-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing powertop-2.0-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10273/powertop-2.0-3.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-07-14 17:50:12 EDT
powertop-2.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-07-14 18:00:15 EDT
powertop-2.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.