Bug 835682 - [abrt] powertop-2.0-2.fc18: std::__throw_ios_failure: Process /usr/sbin/powertop was killed by signal 6 (SIGABRT)
[abrt] powertop-2.0-2.fc18: std::__throw_ios_failure: Process /usr/sbin/power...
Status: CLOSED DUPLICATE of bug 832497
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
abrt_hash:2f40ae279f67b635d1ec8eb53fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 16:00 EDT by Derek Linz
Modified: 2012-07-04 04:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-04 04:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.82 KB, text/plain)
2012-06-26 16:00 EDT, Derek Linz
no flags Details
File: maps (16.99 KB, text/plain)
2012-06-26 16:00 EDT, Derek Linz
no flags Details
File: open_fds (6.58 KB, text/plain)
2012-06-26 16:00 EDT, Derek Linz
no flags Details

  None (edit)
Description Derek Linz 2012-06-26 16:00:42 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        powertop
comment:        Start powertop while on batteries, or remove AC power while it is running. Reeproducable every time.
crash_function: std::__throw_ios_failure
executable:     /usr/sbin/powertop
kernel:         3.3.4-5.fc17.x86_64
pid:            2705
pwd:            /home/dlinz
time:           Tue 26 Jun 2012 10:36:09 AM EDT
uid:            0
username:       root

backtrace:      Text file, 11081 bytes
maps:           Text file, 17394 bytes
open_fds:       Text file, 6741 bytes

build_ids:
:268b8ef7fa77d670f44755a9a321b3dad6c83192
:6cf054e6697bb2c7efb32a0234e3081f80cbe52a
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:a7a5d5797d325042d90b5eda742a5bc9592edc67
:e46989f04ad0aeb0e042f7ad6b24793ff2486f42
:6e480c53498b1cd1a3306a75da85d4e6828d09e6
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046
:6c50bd216e5ccd8e2f5dcfe863ff45015599323d
:21349b4446f7d956868cc9ca048180ece9c120bd
:2583bf68f2f1c27bb1d9964faa91971bd35e14d8
:3126fa91f2ebf1ebd407b3988de003d3716d02f6
:d08468070c9982d88068a4342814712bc18730fa
:db1b4087b2d3bbced5355c6a9eaf69e2f9ee0341
:dc180d4c4e245433416c83c6ad203eafdef956ee
:516204cfc31148538d56b21e2f1b945ed50127d4

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/dlinz/1

core_backtrace:
:6c50bd216e5ccd8e2f5dcfe863ff45015599323d 0x36c85 raise libc.so.6 -
:6c50bd216e5ccd8e2f5dcfe863ff45015599323d 0x38438 abort libc.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x60bed __gnu_cxx::__verbose_terminate_handler() libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5ecf6 - libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5ed23 std::terminate() libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5ef4e __cxa_throw libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0xb20fd std::__throw_ios_failure(char libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0xb41ec std::basic_filebuf<char, libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x7e4b7 std::istream::sentry::sentry(std::istream&, libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x7f43b std::istream::operator>>(int&) libstdc++.so.6 -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x1b983 - [exe] -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x41de4 - [exe] -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x41f5f - [exe] -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x42129 - [exe] -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x3fd2d - [exe] -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x42c1a - [exe] -
:59c56b9e2b3fac1d26d6fd62eae233327c7b6046 0x69ed - [exe] -

dso_list:
:/usr/lib64/libncursesw.so.5.9 ncurses-libs-5.9-4.20120204.fc18.x86_64 (Fedora Project) 1340259738
:/usr/lib64/libz.so.1.2.7 zlib-1.2.7-3.fc18.x86_64 (Fedora Project) 1340259719
:/usr/lib64/libstdc++.so.6.0.17 libstdc++-4.7.0-5.fc17.x86_64 (Fedora Project) 1340225496
:/usr/lib/locale/locale-archive glibc-common-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506228
:/usr/lib64/libpthread-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/lib64/libgcc_s-4.7.0-20120507.so.1 libgcc-4.7.0-5.fc17.x86_64 (Fedora Project) 1340225312
:/usr/lib64/ld-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/lib64/libresolv-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/lib64/libnl.so.1.1 libnl-1.1-15.fc17.x86_64 (Fedora Project) 1340225623
:/usr/lib64/libnss_files-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/sbin/powertop powertop-2.0-2.fc18.x86_64 (Fedora Project) 1340332488
:/usr/lib64/libtinfo.so.5.9 ncurses-libs-5.9-4.20120204.fc18.x86_64 (Fedora Project) 1340259738
:/usr/lib64/libm-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/lib64/libc-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/lib64/libdl-2.15.90.so glibc-2.15.90-16.fc18.x86_64 (Fedora Project) 1340506225
:/usr/lib64/libpci.so.3.1.9 pciutils-libs-3.1.9-1.fc17.x86_64 (Fedora Project) 1340225762

environ:
:HOSTNAME=eurocom
:TERM=xterm
:HISTSIZE=10000
:QTDIR=/usr/lib64/qt-3.3
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
:MAIL=/var/spool/mail/dlinz
:LANG=en_US.UTF-8
:LANGUAGE=
:DISPLAY=:0
:XAUTHORITY=/tmp/kde-dlinz/xauth-1000-_0
:SHELL=/bin/bash
:LOGNAME=root
:USER=root
:USERNAME=root
:PATH=/sbin:/bin:/usr/sbin:/usr/bin
:HOME=/root
:SUDO_COMMAND=/sbin/powertop
:SUDO_USER=dlinz
:SUDO_UID=1000
:SUDO_GID=1000

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 unlimited            processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       127425               127425               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

smolt_data:
:
:
:General
:=================================
:UUID: 7b0dcdf7-d13a-4c10-bab3-672d2616f51b
:OS: Fedora release 18 (Rawhide)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5387.69
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-3820QM CPU @ 2.70GHz
:CPU Stepping: 9
:CPU Family: 6
:CPU Model Num: 58
:Number of CPUs: 8
:CPU Speed: 2701
:System Memory: 15947
:System Swap: 16999
:Vendor: EUROCOM
:System: EUROCOM Racer2.0 Not Applicable
:Form factor: Notebook
:Kernel: 3.3.4-5.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33128:5464:20741) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:7767:5464:20741) pci, None, PCI/ISA, Panther Point LPC Controller
:(5772:48:6742:8193) pci, ath9k, NETWORK, AR9300 Wireless LAN adaptor
:(32902:358:5464:20741) pci, i915, VIDEO, N/A
:(32902:7729:5464:20741) pci, xhci_hcd, USB, Panther Point USB xHCI Host Controller
:(32902:7696:5464:20741) pci, pcieport, PCI/PCI, Panther Point PCI Express Root Port 1
:(32902:7698:5464:20741) pci, pcieport, PCI/PCI, Panther Point PCI Express Root Port 2
:(4318:4052:5464:20741) pci, None, VIDEO, N/A
:(32902:7712:5464:20741) pci, snd_hda_intel, MULTIMEDIA, Panther Point High Definition Audio Controller
:(32902:7700:5464:20741) pci, pcieport, PCI/PCI, Panther Point PCI Express Root Port 3
:(32902:7714:5464:20741) pci, None, SERIAL, Panther Point SMBus Controller
:(6523:9088:5464:20741) pci, firewire_ohci, FIREWIRE, IEEE 1394 Host Controller
:(4332:21129:5464:20741) pci, None, MISC, N/A
:(32902:7702:5464:20741) pci, pcieport, PCI/PCI, Panther Point PCI Express Root Port 4
:(32902:7725:5464:20741) pci, ehci_hcd, USB, Panther Point USB Enhanced Host Controller #2
:(32902:7718:5464:20741) pci, ehci_hcd, USB, Panther Point USB Enhanced Host Controller #1
:(32902:340:5464:20741) pci, agpgart-intel, HOST/PCI, Ivy Bridge DRAM Controller
:(32902:7738:5464:20741) pci, None, SIMPLE, Panther Point MEI Controller #1
:(32902:10282:5464:20741) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:337:5464:20741) pci, pcieport, PCI/PCI, Ivy Bridge PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 54061930 27136013 24429645 13533184 13109091 13109091
:/dev/sda1 /boot ext4 1024 1024 508745 397479 371879 128016 127664 127664
:/dev/sdb1 WITHHELD fuseblk 4096 4096 78142549 676825 676825 2805604 2750082 2750082
:
Comment 1 Derek Linz 2012-06-26 16:00:46 EDT
Created attachment 594583 [details]
File: backtrace
Comment 2 Derek Linz 2012-06-26 16:00:50 EDT
Created attachment 594584 [details]
File: maps
Comment 3 Derek Linz 2012-06-26 16:00:52 EDT
Created attachment 594585 [details]
File: open_fds
Comment 4 Jaroslav Škarvada 2012-07-04 04:04:20 EDT
Probably dupe of bug 832497. Feel free to reopen if not.

*** This bug has been marked as a duplicate of bug 832497 ***

Note You need to log in before you can comment on or make changes to this bug.