Bug 832517 - 3.1: sshd daemon is not starting correctly after complete the installation of oVirt Node
3.1: sshd daemon is not starting correctly after complete the installation of...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.1 RC
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On: 837443
Blocks: 822145
  Show dependency treegraph
 
Reported: 2012-06-15 11:46 EDT by Douglas Schilling Landgraf
Modified: 2016-04-26 10:17 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 07:48:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Schilling Landgraf 2012-06-15 11:46:00 EDT
Description of problem:

sshd daemon is not starting correctly after complete the installation of oVirt Node.

Here the output of systemctl:

systemctl status sshd.service
      Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled)
      Active: failed (Result: exit-code) since Fri, 15 Jun 2012 14:21:23 +0000; 1h 12min ago
      CGroup: name=systemd:/system/sshd.service

Jun 15 14:21:23 localhost.localdomain sshd-keygen[1000]: Generating SSH2 RSA ...
Comment 1 Fabian Deutsch 2012-06-21 12:34:10 EDT
sshd was started before the persisted files were bind-mounted, the following patch starts sshd.service after ovirt-early.service:

http://gerrit.ovirt.org/5595

Tested with
https://gitorious.org/ovirt/ovirt-node-igor-testsuites/blobs/51fa0a8bbea705a4d314bc64691b2094a85b8256/basic.suite
https://gitorious.org/ovirt/ovirt-node-igor-testsuites/blobs/51fa0a8bbea705a4d314bc64691b2094a85b8256/tcs/services_are_running.sh

Note You need to log in before you can comment on or make changes to this bug.