Bug 832562 - Cannot install Origin live cd to hard disk because of anaconda traceback
Cannot install Origin live cd to hard disk because of anaconda traceback
Status: CLOSED DUPLICATE of bug 834392
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 14:18 EDT by John Poelstra
Modified: 2015-05-14 21:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 11:09:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2012-06-15 14:18:05 EDT
Description of problem:

Cannot install Origin live cd to hard disk because of anaconda traceback

Version-Release number of selected component (if applicable):
Current live cd downloaded from openshift.redhat.com (2012-06-07)


How reproducible:
100%


Steps to Reproduce:
1. run virt-manager
2. create virt machine with 12G disk, not allocated
3. boot livecd
4. select Applications --> System Tools --> Install to Hard Disk
5. accept all defaults
6. boom!


  
Actual results:
anaconda traceback

from anaconda.log....

12:12:41,381 INFO anaconda: /usr/sbin/anaconda 16.25
16:12:42,316 INFO loader: 2621440 kB (2560 MB) are available
12:12:42,316 INFO anaconda: anaconda called with cmdline = ['/usr/sbin/anaconda', '--liveinst', '--method=livecd:///dev/mapper/live-osimg-min', '--lang', 'en_US.UTF-8']
12:12:42,317 INFO anaconda: Default encoding = ascii 
12:12:42,345 INFO anaconda: Display mode = g
16:12:42,348 INFO loader: 2621440 kB (2560 MB) are available
12:12:42,349 INFO anaconda.stdout: Starting graphical installation.
12:12:43,521 INFO anaconda: using only installclass _Fedora
12:12:43,565 INFO anaconda: Detected 2448M of memory
12:12:43,566 INFO anaconda: Swap attempt of 1024M to 4496M
12:12:45,201 INFO anaconda: set timezone: America/New_York, utc: 0
12:12:45,203 INFO anaconda: set timezone: America/New_York, utc: 0
12:12:45,330 INFO anaconda: dispatch: resetting to the first step.
12:12:45,331 INFO anaconda: dispatch: moving (1) to step sshd
12:12:45,331 DEBUG anaconda: dispatch: sshd is a direct step
12:12:45,332 INFO anaconda: sshd: not enabled, skipping.
12:12:45,333 INFO anaconda: created new libuser.conf at /tmp/libuser.5JLIAs with instPath="/mnt/sysimage"
12:12:45,334 INFO anaconda: dispatch: leaving (1) step sshd
12:12:45,334 INFO anaconda: dispatch: moving (1) to step keyboard
12:12:48,666 INFO anaconda: dispatch: leaving (1) step keyboard
12:12:48,668 INFO anaconda: dispatch: moving (1) to step filtertype
12:12:52,029 INFO anaconda: dispatch: leaving (1) step filtertype
12:12:52,030 INFO anaconda: dispatch: moving (1) to step filter
12:12:52,045 DEBUG anaconda: dispatch: the interface chose not to display step filter.
12:12:52,051 INFO anaconda: dispatch: leaving (1) step filter
12:12:52,051 INFO anaconda: dispatch: moving (1) to step storageinit
12:12:52,052 DEBUG anaconda: dispatch: storageinit is a direct step
12:12:52,141 INFO anaconda: ISCSID is /sbin/iscsid
12:12:52,160 INFO anaconda: no initiator set
12:12:52,383 INFO anaconda: No FCoE EDD info found: No FCoE boot disk information is found in EDD!
12:12:52,384 INFO anaconda: no /etc/zfcp.conf; not configuring zfcp
12:12:56,832 INFO anaconda: dispatch: leaving (1) step storageinit
12:12:56,833 INFO anaconda: dispatch: moving (1) to step network
12:12:56,947 CRIT anaconda: anaconda 16.25 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 175, in getActiveNetDevs
    nm = bus.get_object(isys.NM_SERVICE, isys.NM_MANAGER_PATH)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 101, in getDefaultHostname
    for dev in getActiveNetDevs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/network_gui.py", line 43, in getScreen
    self.hostname = network.getDefaultHostname(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1270, in display_step
    new_screen = self.currentWindow.getScreen(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1157, in display_step
    return self.icw.display_step(step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 377, in dispatch
    rc = self.anaconda.intf.display_step(self.step)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.go_forward()
DBusException: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
Comment 1 Mrunal Patel 2012-06-15 15:45:52 EDT
NetworkManager service needs to be turned on before starting the install.
1. su -
2. chkconfig NetworkManager on
3. service NetworkManager start
4. Start install

-- Mrunal
Comment 2 John Poelstra 2012-06-15 17:59:44 EDT
(In reply to comment #1)
> NetworkManager service needs to be turned on before starting the install.
> 1. su -
> 2. chkconfig NetworkManager on
> 3. service NetworkManager start
> 4. Start install
> 
> -- Mrunal

I would expect this to be enabled by default, not require the user to do so.  In the countless Fedora live installs I've done, this step has never been required, including Fedora 17.
Comment 3 Mrunal Patel 2012-06-15 18:20:29 EDT
Lowering severity since we have a workaround. Will look into a feasible solution
that doesn't require the use having to turn on NetworkManager.
Comment 4 John Poelstra 2012-06-17 10:55:12 EDT
(In reply to comment #3)
> Lowering severity since we have a workaround. Will look into a feasible
> solution
> that doesn't require the use having to turn on NetworkManager.

That's fair.  I understand now that the Origin framework depends on the 'network' service (which conflicts with NetworkManager) and this is why NetworkManager is turned off by default. 

And I also learned that this is documented in a few places too.  My bad for not reading the docs.  I had planned to read them after completing the install.  I am probably biased in my expectations by my long experience using Fedora spins/remixes.

For anyone else encountering this problem, read here first:
https://openshift.redhat.com/community/wiki/build-your-own-paas-from-the-openshift-origin-livecd-using-liveinst
Comment 5 Krishna Raman 2012-07-16 11:09:47 EDT

*** This bug has been marked as a duplicate of bug 834392 ***

Note You need to log in before you can comment on or make changes to this bug.