Bug 832613 - SELinux is preventing /usr/sbin/prelink from 'relabelfrom' accesses on the file undo.#prelink#.EVIDjl.
SELinux is preventing /usr/sbin/prelink from 'relabelfrom' accesses on the fi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4e76f60cfc6b5c636aec94bfd00...
:
: 1034146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 19:10 EDT by Kahlil Hodgson
Modified: 2013-11-25 07:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 04:24:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kahlil Hodgson 2012-06-15 19:10:27 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           Sat 16 Jun 2012 09:09:58 AM EST

description:
:SELinux is preventing /usr/sbin/prelink from 'relabelfrom' accesses on the file undo.#prelink#.EVIDjl.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that prelink should be allowed relabelfrom access on the undo.#prelink#.EVIDjl file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep prelink /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:mozilla_plugin_tmp_t:s0
:Target Objects                undo.#prelink#.EVIDjl [ file ]
:Source                        prelink
:Source Path                   /usr/sbin/prelink
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           prelink-0.4.6-5.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-1.fc17.x86_64 #1
:                              SMP Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 15 Jun 2012 06:15:30 PM EST
:Last Seen                     Fri 15 Jun 2012 06:15:30 PM EST
:Local ID                      1032d20b-b303-4efa-87bb-a450d4b10c9a
:
:Raw Audit Messages
:type=AVC msg=audit(1339748130.161:277): avc:  denied  { relabelfrom } for  pid=1308 comm="prelink" name="undo.#prelink#.EVIDjl" dev="dm-2" ino=1344 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:mozilla_plugin_tmp_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1339748130.161:277): arch=x86_64 syscall=setxattr success=no exit=EACCES a0=7fff59d2bf40 a1=509ee9 a2=19f9230 a3=1b items=0 ppid=1298 pid=1308 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=prelink exe=/usr/sbin/prelink subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: prelink,mozilla_plugin_t,mozilla_plugin_tmp_t,file,relabelfrom
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Belton 2012-06-18 23:43:22 EDT
I too have been getting this selinux error. Just want to add that I only started getting it when a ran a prelink -ua command a little over a month ago. Until I ran that, I never saw this message, now I see it everytime prelink runs.
Comment 2 Daniel Walsh 2012-06-19 10:01:51 EDT
Daniel. I would just remove this file.

find /tmp/ -context "*:mozilla_plugin_tmp_t:*"

Or simply

find /tmp/ -context "*:mozilla_plugin_tmp_t:*" -delete
Comment 3 Miroslav Grepl 2013-11-25 07:41:35 EST
*** Bug 1034146 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.