Bug 832794 - webadmin: failure to create local storage is not caught - dialog remains open with 'wait circle'
webadmin: failure to create local storage is not caught - dialog remains open...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Tomas Jelinek
Leonid Natapov
storage
: Regression
: 833339 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 09:14 EDT by Yaniv Kaul
Modified: 2016-02-10 12:05 EST (History)
14 users (show)

See Also:
Fixed In Version: SI10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-06-17 09:14:34 EDT
Description of problem:
I've tried to create a local storage based storage domain on a host. That seem to have failed (in backend), but UI kept open with no error to the user.

See bottom for log of backend, which looks like it completed the command (failed, but properly).



Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.1.0_0001-14.el6ev.noarch

How reproducible:


Steps to Reproduce:
1. Try to create a local storage on a host (which for some reason fails)
2.
3.
  
Actual results:


Expected results:


Additional info:
2012-06-17 16:09:27,934 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ValidateStorageServerConnectionVDSCommand] (ajp--0.0.0.0-8009-4) [4c00fdbe] START, ValidateStorageServerConnectionVDSCommand(vdsId = 892891e2-b87a-11e1-9ebc-001a4a16976a, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = LOCALFS, connectionList = [{ id: be21f7a6-cc8b-47d4-8295-107e6ed76988, connection: /storage };]), log id: 35cbf519
2012-06-17 16:09:27,951 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ValidateStorageServerConnectionVDSCommand] (ajp--0.0.0.0-8009-4) [4c00fdbe] FINISH, ValidateStorageServerConnectionVDSCommand, return: {be21f7a6-cc8b-47d4-8295-107e6ed76988=0}, log id: 35cbf519
2012-06-17 16:09:27,974 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp--0.0.0.0-8009-4) [4c00fdbe] Running command: AddStorageServerConnectionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2012-06-17 16:09:27,977 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp--0.0.0.0-8009-4) [4c00fdbe] START, ConnectStorageServerVDSCommand(vdsId = 892891e2-b87a-11e1-9ebc-001a4a16976a, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = LOCALFS, connectionList = [{ id: be21f7a6-cc8b-47d4-8295-107e6ed76988, connection: /storage };]), log id: 9976adf
2012-06-17 16:09:28,009 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp--0.0.0.0-8009-4) [4c00fdbe] FINISH, ConnectStorageServerVDSCommand, return: {be21f7a6-cc8b-47d4-8295-107e6ed76988=100}, log id: 9976adf
2012-06-17 16:09:28,012 ERROR [org.ovirt.engine.core.bll.storage.LOCALFSStorageHelper] (ajp--0.0.0.0-8009-4) [4c00fdbe] The connection with details /storage failed because of error code 100 and error message is: general exception
2012-06-17 16:09:28,161 INFO  [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp--0.0.0.0-8009-11) [6de45c34] Running command: AddLocalStorageDomainCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2012-06-17 16:09:28,193 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand] (ajp--0.0.0.0-8009-11) [6de45c34] START, CreateStorageDomainVDSCommand(vdsId = 892891e2-b87a-11e1-9ebc-001a4a16976a, storageDomain=org.ovirt.engine.core.common.businessentities.storage_domain_static@c565e91a, args=/storage), log id: 6828efa6
2012-06-17 16:09:28,864 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp--0.0.0.0-8009-11) [6de45c34] Failed in CreateStorageDomainVDS method
2012-06-17 16:09:28,865 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp--0.0.0.0-8009-11) [6de45c34] Error code StorageServerAccessPermissionError and error message VDSGenericException: VDSErrorException: Failed to CreateStorageDomainVDS, error = Permission settings on the specified path do not allow access to the storage. Verify permission settings on the specified storage path.: 'path = /rhev/data-center/mnt/_storage'
2012-06-17 16:09:28,869 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp--0.0.0.0-8009-11) [6de45c34] Command org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand return value 
 Class Name: org.ovirt.engine.core.vdsbroker.vdsbroker.StatusOnlyReturnForXmlRpc
mStatus                       Class Name: org.ovirt.engine.core.vdsbroker.vdsbroker.StatusForXmlRpc
mCode                         469
mMessage                      Permission settings on the specified path do not allow access to the storage. Verify permission settings on the specified storage path.: 'path = /rhev/data-center/mnt/_storage'


2012-06-17 16:09:28,871 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (ajp--0.0.0.0-8009-11) [6de45c34] Vds: gold-vdsc
2012-06-17 16:09:28,871 ERROR [org.ovirt.engine.core.vdsbroker.VDSCommandBase] (ajp--0.0.0.0-8009-11) [6de45c34] Command CreateStorageDomainVDS execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed to CreateStorageDomainVDS, error = Permission settings on the specified path do not allow access to the storage. Verify permission settings on the specified storage path.: 'path = /rhev/data-center/mnt/_storage'
2012-06-17 16:09:28,873 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateStorageDomainVDSCommand] (ajp--0.0.0.0-8009-11) [6de45c34] FINISH, CreateStorageDomainVDSCommand, log id: 6828efa6
2012-06-17 16:09:28,873 ERROR [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp--0.0.0.0-8009-11) [6de45c34] Command org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to CreateStorageDomainVDS, error = Permission settings on the specified path do not allow access to the storage. Verify permission settings on the specified storage path.: 'path = /rhev/data-center/mnt/_storage'
2012-06-17 16:09:28,900 INFO  [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp--0.0.0.0-8009-11) [6de45c34] Command [id=74521896-af9f-4c42-bfb0-9896ef1ebe71]: Compensating NEW_ENTITY_ID of org.ovirt.engine.core.common.businessentities.storage_domain_dynamic; snapshot: 0e1b644f-88b0-4c4f-a323-c580c32cafb0.
2012-06-17 16:09:28,906 INFO  [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp--0.0.0.0-8009-11) [6de45c34] Command [id=74521896-af9f-4c42-bfb0-9896ef1ebe71]: Compensating NEW_ENTITY_ID of org.ovirt.engine.core.common.businessentities.storage_domain_static; snapshot: 0e1b644f-88b0-4c4f-a323-c580c32cafb0.
2012-06-17 16:09:28,926 ERROR [org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand] (ajp--0.0.0.0-8009-11) [6de45c34] Transaction rolled-back for command: org.ovirt.engine.core.bll.storage.AddLocalStorageDomainCommand.
Comment 1 Yaniv Kaul 2012-06-17 11:33:34 EDT
I wonder if the following is the same or similar: Failure to move disk between storage, as there's low disk space - which is not even going to VDSM, also seems to get the GUI stuck:


2012-06-17 18:29:14,169 INFO  [org.ovirt.engine.core.bll.MoveOrCopyDiskCommand] (ajp--0.0.0.0-8009-11) Lock Acquired to object EngineLock [exclusiveLocks= key: 153c86d6-5d58-48b4-a714-4c0c74cb57a8 value: DISK
, sharedLocks= ]
2012-06-17 18:29:14,200 WARN  [org.ovirt.engine.core.bll.MoveOrCopyDiskCommand] (ajp--0.0.0.0-8009-11) CanDoAction of action MoveOrCopyDisk failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_DISK_SPACE_LOW
2012-06-17 18:29:14,201 INFO  [org.ovirt.engine.core.bll.MoveOrCopyDiskCommand] (ajp--0.0.0.0-8009-11) Lock freed to object EngineLock [exclusiveLocks= key: 153c86d6-5d58-48b4-a714-4c0c74cb57a8 value: DISK
, sharedLocks= ]


The failure is in a CanDoAction, but the dialog never closes.
Comment 2 Yaniv Kaul 2012-06-17 11:34:01 EDT
Setting as Regression. I don't recall many instances where WPF would get stuck on failures.
Comment 4 Tomas Jelinek 2012-06-21 10:44:24 EDT
in gerrit: http://gerrit.ovirt.org/#/c/5594/
Comment 5 Leonid Natapov 2012-06-25 06:49:20 EDT
Tomas,is you fix also fixes the problem when moving disks between domains and one of domains has low disk space. As described in Yaniv Kaul's comment from 17/6
Comment 7 Tomas Jelinek 2012-07-03 07:49:56 EDT
I went through the above cases and the problem reproduced for me also for the moving of the disk, which I have fixed here: http://gerrit.ovirt.org/#/c/5893/

For other cases the problem did not reproduce for me on git: 0ec7ac2541783b4bf7353a0303c8a5938ed4ed13
Comment 8 Asaf Shakarchi 2012-07-04 12:58:59 EDT
*** Bug 833339 has been marked as a duplicate of this bug. ***
Comment 9 Asaf Shakarchi 2012-07-04 13:02:51 EDT
Patch was verified and merged [6da41530d0ad4523d7e1e],
Tomas you can put this BZ in 'MODIFIED' status.
Comment 10 Tomas Jelinek 2012-07-09 03:01:38 EDT
Thank you Asaf, putting to MODIFIED
Comment 11 Leonid Natapov 2012-07-15 09:26:10 EDT
si10

Note You need to log in before you can comment on or make changes to this bug.