Bug 832867 - BUG: Bad rss-counter state mm:xxxxxxxx idx:1 val:-2 output in console
BUG: Bad rss-counter state mm:xxxxxxxx idx:1 val:-2 output in console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 832673 837409 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 01:03 EDT by Mikhail
Modified: 2012-07-09 08:55 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 17:59:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (999.28 KB, image/jpeg)
2012-06-18 01:06 EDT, Mikhail
no flags Details
screenshot 2 (1.19 MB, image/jpeg)
2012-06-18 01:07 EDT, Mikhail
no flags Details
screenshot 3 (1.21 MB, image/jpeg)
2012-06-18 01:08 EDT, Mikhail
no flags Details
screenshot 4 (689.51 KB, image/jpeg)
2012-06-18 01:09 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-06-18 01:03:38 EDT
Description of problem:

BUG: Bag rss=counter state mm:xxxxxxxx idx:1 val:-2
BUG: Bag rss=counter state mm:xxxxxxxx idx:2 val:2
etc...

output anytime in console
Comment 1 Mikhail 2012-06-18 01:06:56 EDT
Created attachment 592512 [details]
screenshot 1
Comment 2 Mikhail 2012-06-18 01:07:40 EDT
Created attachment 592513 [details]
screenshot 2
Comment 3 Mikhail 2012-06-18 01:08:36 EDT
Created attachment 592514 [details]
screenshot 3
Comment 4 Mikhail 2012-06-18 01:09:18 EDT
Created attachment 592515 [details]
screenshot 4
Comment 5 Dave Jones 2012-06-18 11:28:02 EDT
are you using any 3rd party modules ?

bug 832673 got reported around the same time as this bug, which is unusual.
Comment 6 Mikhail 2012-06-18 12:32:08 EDT
> are you using any 3rd party modules ?

No I am not using proprietary drivers.
I have two desktop computers and two netbooks with different hardware and It happens on every computer.
Comment 7 Alexander Lomtev 2012-06-18 19:31:50 EDT
*** Bug 832673 has been marked as a duplicate of this bug. ***
Comment 8 Alexander Lomtev 2012-06-18 19:37:29 EDT
The error came to me again.
Comment 9 Bojan Smojver 2012-06-18 20:07:35 EDT
I had a kernel hang on my on reboot recently. These were some the last messages in the log, before rsyslog shut down (I do not have access to console on this machine). Just FYI.

Anyone had a similar experience with this bug?
Comment 10 Bojan Smojver 2012-06-18 23:25:49 EDT
(In reply to comment #9)
> I had a kernel hang on my on reboot recently. These were some the last
> messages in the log, before rsyslog shut down (I do not have access to
> console on this machine). Just FYI.
> 
> Anyone had a similar experience with this bug?

Actually, probably got hit by bug #830862 there.
Comment 11 Bojan Smojver 2012-06-18 23:26:24 EDT
Patches for this:

http://comments.gmane.org/gmane.linux.kernel/1306252
Comment 12 ramindeh 2012-06-20 15:31:04 EDT
I also have this. The messages show up between the shutdown messages, I've only noticed this since upgrading to FC17. There appear to be no other problems.

`uname -a`
----------
Linux laptop3 3.4.2-4.fc17.x86_64 #1 SMP Thu Jun 14 22:22:05 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Machine is a MSI GT-725 laptop - Intel Core2-Duo P9500, 4GB RAM, ATI M98L HD4850


Grepped from /var/log/messages:
-------------------------------

Jun 17 10:58:32 localhost kernel: [54412.501047] BUG: Bad rss-counter state mm:ffff88010af9bb80 idx:1 val:-2
Jun 17 10:58:32 localhost kernel: [54412.501053] BUG: Bad rss-counter state mm:ffff88010af9bb80 idx:2 val:2
Jun 17 23:33:16 localhost kernel: [99690.365794] BUG: Bad rss-counter state mm:ffff880062514380 idx:1 val:-3
Jun 17 23:33:16 localhost kernel: [99690.365798] BUG: Bad rss-counter state mm:ffff880062514380 idx:2 val:3
Jun 18 00:05:59 localhost kernel: [101654.397401] BUG: Bad rss-counter state mm:ffff8800400e9c00 idx:1 val:-1
Jun 18 00:05:59 localhost kernel: [101654.397405] BUG: Bad rss-counter state mm:ffff8800400e9c00 idx:2 val:1
Jun 18 00:20:47 localhost kernel: [102542.751496] BUG: Bad rss-counter state mm:ffff880133a0f480 idx:1 val:-1
Jun 18 00:20:47 localhost kernel: [102542.751501] BUG: Bad rss-counter state mm:ffff880133a0f480 idx:2 val:1
Jun 19 10:48:50 localhost kernel: [128753.035096] BUG: Bad rss-counter state mm:ffff88012508c380 idx:1 val:-1
Jun 19 10:48:50 localhost kernel: [128753.035100] BUG: Bad rss-counter state mm:ffff88012508c380 idx:2 val:1
Jun 19 10:48:50 localhost kernel: [128753.037344] BUG: Bad rss-counter state mm:ffff8801350b7800 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128753.037347] BUG: Bad rss-counter state mm:ffff8801350b7800 idx:2 val:1
Jun 19 10:48:51 localhost kernel: [128753.248371] BUG: Bad rss-counter state mm:ffff88010294f800 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128753.248375] BUG: Bad rss-counter state mm:ffff88010294f800 idx:2 val:1
Jun 19 10:48:51 localhost kernel: [128753.298973] BUG: Bad rss-counter state mm:ffff880133a0d500 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128753.298976] BUG: Bad rss-counter state mm:ffff880133a0d500 idx:2 val:1
Jun 19 10:48:51 localhost kernel: [128753.432732] BUG: Bad rss-counter state mm:ffff88012508fb80 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128753.432736] BUG: Bad rss-counter state mm:ffff88012508fb80 idx:2 val:1
Jun 19 10:48:51 localhost kernel: [128753.445088] BUG: Bad rss-counter state mm:ffff88012508dc00 idx:1 val:-2
Jun 19 10:48:51 localhost kernel: [128753.445091] BUG: Bad rss-counter state mm:ffff88012508dc00 idx:2 val:2
Jun 19 10:48:51 localhost kernel: [128753.468670] BUG: Bad rss-counter state mm:ffff8801350b7100 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128753.468674] BUG: Bad rss-counter state mm:ffff8801350b7100 idx:2 val:1
Jun 19 10:48:51 localhost kernel: [128753.967180] BUG: Bad rss-counter state mm:ffff880134f49180 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128753.967185] BUG: Bad rss-counter state mm:ffff880134f49180 idx:2 val:1
Jun 19 10:48:51 localhost kernel: [128754.017252] BUG: Bad rss-counter state mm:ffff880134d29500 idx:1 val:-1
Jun 19 10:48:51 localhost kernel: [128754.017254] BUG: Bad rss-counter state mm:ffff880134d29500 idx:2 val:1
Jun 19 22:08:12 localhost kernel: [32506.663165] BUG: Bad rss-counter state mm:ffff880134605880 idx:1 val:-1
Jun 19 22:08:12 localhost kernel: [32506.663171] BUG: Bad rss-counter state mm:ffff880134605880 idx:2 val:1
Jun 20 00:24:04 localhost kernel: [40659.475677] BUG: Bad rss-counter state mm:ffff880134606680 idx:1 val:-1
Jun 20 00:24:04 localhost kernel: [40659.475682] BUG: Bad rss-counter state mm:ffff880134606680 idx:2 val:1
Jun 20 00:24:04 localhost kernel: [40659.566760] BUG: Bad rss-counter state mm:ffff880137839880 idx:1 val:-1
Jun 20 00:24:04 localhost kernel: [40659.566765] BUG: Bad rss-counter state mm:ffff880137839880 idx:2 val:1
Jun 20 00:24:04 localhost kernel: [40659.594861] BUG: Bad rss-counter state mm:ffff88007572fb80 idx:1 val:-1
Jun 20 00:24:04 localhost kernel: [40659.594865] BUG: Bad rss-counter state mm:ffff88007572fb80 idx:2 val:1
Jun 20 00:24:04 localhost kernel: [40659.600992] BUG: Bad rss-counter state mm:ffff880134604000 idx:1 val:-1
Jun 20 00:24:04 localhost kernel: [40659.600996] BUG: Bad rss-counter state mm:ffff880134604000 idx:2 val:1
Jun 20 00:24:08 localhost kernel: [40663.074107] BUG: Bad rss-counter state mm:ffff88005e375180 idx:1 val:-1
Jun 20 00:24:08 localhost kernel: [40663.074112] BUG: Bad rss-counter state mm:ffff88005e375180 idx:2 val:1
Jun 20 00:25:40 localhost kernel: [40754.616024] BUG: Bad rss-counter state mm:ffff880115771f80 idx:1 val:-1
Jun 20 00:25:40 localhost kernel: [40754.616029] BUG: Bad rss-counter state mm:ffff880115771f80 idx:2 val:1
Jun 20 20:51:07 localhost kernel: [80937.306360] BUG: Bad rss-counter state mm:ffff88013537e300 idx:1 val:-1
Jun 20 20:51:07 localhost kernel: [80937.306363] BUG: Bad rss-counter state mm:ffff88013537e300 idx:2 val:1
Jun 20 20:51:07 localhost kernel: [80937.382645] BUG: Bad rss-counter state mm:ffff88013974fb80 idx:1 val:-1
Jun 20 20:51:07 localhost kernel: [80937.382650] BUG: Bad rss-counter state mm:ffff88013974fb80 idx:2 val:1
Jun 20 20:51:07 localhost kernel: [80937.402560] BUG: Bad rss-counter state mm:ffff88013510ca80 idx:1 val:-1
Jun 20 20:51:07 localhost kernel: [80937.402565] BUG: Bad rss-counter state mm:ffff88013510ca80 idx:2 val:1
Jun 20 20:51:07 localhost kernel: [80937.435684] BUG: Bad rss-counter state mm:ffff88013598ad80 idx:1 val:-1
Jun 20 20:51:07 localhost kernel: [80937.435688] BUG: Bad rss-counter state mm:ffff88013598ad80 idx:2 val:1
Jun 20 20:51:08 localhost kernel: [80938.372488] BUG: Bad rss-counter state mm:ffff88013510f800 idx:1 val:-1
Jun 20 20:51:08 localhost kernel: [80938.372494] BUG: Bad rss-counter state mm:ffff88013510f800 idx:2 val:1
Jun 20 20:51:08 localhost kernel: [80938.431164] BUG: Bad rss-counter state mm:ffff880135988380 idx:1 val:-1
Jun 20 20:51:08 localhost kernel: [80938.431168] BUG: Bad rss-counter state mm:ffff880135988380 idx:2 val:1
Comment 13 Otso Helenius 2012-06-23 13:06:44 EDT
I'm having similar problems on my system. After the rss-counter messages, I get soft lockups, the system freezes and I have to power it off.

BUG: Bad rss-counter state mm:ffff88012f201f80 idx:1 val:-1
BUG: Bad rss-counter state mm:ffff88012f201f80 idx:2 val:1
BUG: Bad rss-counter state mm:ffff88012d39d880 idx:1 val:-2
BUG: Bad rss-counter state mm:ffff88012d39d880 idx:2 val:2
BUG: soft lockup - CPU#3 stuck for 22s! [systemd:1]
Modules linked in: fuse lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_conexant arc4 binfmt_misc coretemp microcode uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core snd_hda_intel snd_hda_codec videodev snd_hwdep media snd_pcm iwlwifi intel_ips i2c_i801 iTCO_wdt iTCO_vendor_support btusb bluetooth mac80211 snd_page_alloc cfg80211 snd_timer e1000e thinkpad_acpi snd soundcore rfkill uinput crc32c_intel ghash_clmulni_intel wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
CPU 3 
Modules linked in: fuse lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_conexant arc4 binfmt_misc coretemp microcode uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core snd_hda_intel snd_hda_codec videodev snd_hwdep media snd_pcm iwlwifi intel_ips i2c_i801 iTCO_wdt iTCO_vendor_support btusb bluetooth mac80211 snd_page_alloc cfg80211 snd_timer e1000e thinkpad_acpi snd soundcore rfkill uinput crc32c_intel ghash_clmulni_intel wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
Pid: 1, comm: systemd Tainted: G      D      3.4.2-4.fc17.x86_64 #1 LENOVO 309395G/309395G
RIP: 0010:[<ffffffff810565f2>]  [<ffffffff810565f2>] panic_smp_self_stop+0x12/0x20
RSP: 0018:ffff880131e5bc48  EFLAGS: 00000246
RAX: 0000000000000000 RBX: 000000018040003e RCX: ffff880131e5bd18
RDX: 0000000000000100 RSI: 000000000000008b RDI: ffffffff81e29788
RBP: ffff880131e5bc48 R08: 0000000000000001 R09: 0000000000000001
R10: 000000002d512001 R11: ffffffff810c0a9e R12: ffffffff8111499e
R13: ffff880131e5bbb8 R14: ffff88012d512440 R15: 0000000000000000
FS:  00007f492a963840(0000) GS:ffff880137d80000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00007fc3eb792096 CR3: 0000000001c0b000 CR4: 00000000000007e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process systemd (pid: 1, threadinfo ffff880131e5a000, task ffff880131e60000)
Stack:
 ffff880131e5bcc8 ffffffff815e65cf ffff880131e5bc88 ffffffff81361c07
 ffff880131e60000 ffff880131e60000 0000000000000009 000000000000008b
 ffff880131e60000 ffff880131e5bd18 0000000000000001 0000000000000001
Call Trace:
 [<ffffffff815e65cf>] panic+0x40/0x1c6
 [<ffffffff81361c07>] ? get_current_tty+0x67/0x90
 [<ffffffff8105b48b>] do_exit+0x86b/0x8a0
 [<ffffffff8105b80f>] do_group_exit+0x3f/0xa0
 [<ffffffff8106a595>] get_signal_to_deliver+0x1a5/0x5c0
 [<ffffffff810132f8>] do_signal+0x68/0x610
 [<ffffffff815f4600>] ? do_page_fault+0x430/0x4b0
 [<ffffffff8108ddd3>] ? pick_next_task_fair+0x63/0x180
 [<ffffffff81013925>] do_notify_resume+0x65/0x80
 [<ffffffff815f0d6c>] retint_signal+0x48/0x8c
Code: a1 59 00 8b 05 10 36 dd 00 85 c0 75 d4 e9 56 ff ff ff 0f 1f 80 00 00 00 00 55 48 89 e5 66 66 66 66 90 0f 1f 80 00 00 00 00 f3 90 <eb> fc 66 66 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 66 66 66 

I'm running the kernel provided by Fedora 17 x86_64 repo without any proprietary or custom drivers.
Comment 14 markzzzsmith 2012-06-23 19:35:03 EDT
I'm seeing the same thing, no proprietary modules either. Running x86_64 Fedora 17.

Compared to my past use, I've spent the last week or so installing and setting up Windows 7 inside Qemu-KVM, so maybe that could be related. Yesterday I spent quite a lot of time trying to get USB passthrough working with a Garman GPS, including playing with the bind/unbind options of usb-storage and usbfs.

The other thing that could be a symptom is that I've been having some trouble with suspend recently. For example, last night I suspended my machine successfully. This morning, it woke up successfully (there are no errors in /var/log/pm-suspend), to the point where I was going to type the password into the screen saver. However, within seconds the machine just stopped, and then rebooted itself and performed a full POST, boot loader etc. I don't think it is a hardware error as the hardware is reliable once Fedora is operating. It hasn't happened often enough to spot a pattern yet, however I don't think it is happening when I hibernate the machine.
Comment 15 markzzzsmith 2012-06-23 19:38:42 EDT
I should add, I keep my machine fairly well updated, looking at the kernel logs, this message started showing up for me on June 19:

Jun 19 07:20:29 opy kernel: [53089.505080] BUG: Bad rss-counter state mm:ffff880227c4bf00 idx:1 val:-1

and it changed slightly on June 23 (i.e. Not tainted text):

Jun 23 12:45:45 opy kernel: [16127.308795] BUG: Bad rss-counter state mm:ffff880227d8b800 idx:1 val:-2 (Not tainted)

Do those dates roughly coincide with certain kernel release dates?
Comment 16 Dave Jones 2012-06-24 19:36:10 EDT
The patches Bojan mentioned in comment 11 were superseded by others that should be on their way to -stable. We should get them in the next update. (If they don't make -stable, we'll add them).
Comment 17 collura 2012-06-25 01:02:37 EDT
not sure if related to kernel updates for me as have been lots of kernel activity and lost track.

dont know if related but happened to notice a while ago when i was checking log forsomething else that all of a sudden getting the 'BUG: Bad rss-counter state' error. found my root partition was short on disk space and that when i cleared some up the error when away.

maybe was unrelated to disk space though because same system getting error again but disk space about same as when error percipitously dissappeared when freed space last time?  

i had been downloading install images at the time which chewed up a bunch of disk space and when i cleared some of the images away the error stopped. havent retried since then.

currently:
  kernel-3.4.3.-1.fc17.x86_64

  Filesystem     1K-blocks     Used Available Use% Mounted on
  rootfs          22933372 18927592   3776148  84% /
    (tight but expect should be basically useable)
Comment 18 Fedora Update System 2012-06-26 20:08:35 EDT
kernel-3.4.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.4.4-3.fc17
Comment 19 Fedora Update System 2012-06-26 20:11:19 EDT
kernel-3.4.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.4-3.fc16
Comment 20 Fedora Update System 2012-06-27 23:27:50 EDT
Package kernel-3.4.4-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.4.4-3.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9988/kernel-3.4.4-3.fc17
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-06-30 17:59:25 EDT
kernel-3.4.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Josh Boyer 2012-07-03 15:37:09 EDT
*** Bug 837409 has been marked as a duplicate of this bug. ***
Comment 23 Fedora Update System 2012-07-05 19:50:23 EDT
kernel-3.4.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.4-4.fc16
Comment 24 Fedora Update System 2012-07-08 16:51:35 EDT
kernel-3.4.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.