Bug 833022 - CLI: product list shows empty list
CLI: product list shows empty list
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
: Regression
Depends On:
Blocks: 827494 829759
  Show dependency treegraph
 
Reported: 2012-06-18 08:04 EDT by Hayk Hovsepyan
Modified: 2014-09-18 11:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A code regression caused a class instance typo, which stopped the System Engine CLI from listing products. This fix corrects the typo. System Engine CLI now lists products correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 03:25:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2012-06-18 08:04:53 EDT
Description of problem:

"product list" CLI command does not return any product when products exists.
But on WebUI all products are shown.


Version-Release number of selected component (if applicable):
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
pulp-selinux-server-1.0.4-1.el6.noarch
katello-glue-candlepin-0.1.317-1.el6_2.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-glue-pulp-0.1.317-1.el6_2.noarch
katello-configure-0.1.109-1.el6_3.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-0.1.111-1.el6_2.noarch
katello-cli-0.1.111-1.el6_2.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
python-qpid-0.14-7.el6_2.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
pulp-common-1.0.4-1.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
candlepin-tomcat6-0.6.5-1.el6_2.noarch
katello-glue-foreman-0.1.317-1.el6_2.noarch
katello-0.1.317-1.el6_2.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-0.17-1.el6.noarch
grinder-0.0.143-1pulp_1.0.el6_3.noarch
katello-certs-tools-1.0.7-1.el6_3.noarch
candlepin-0.6.5-1.el6_2.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
pulp-1.0.4-1.el6.noarch
katello-common-0.1.317-1.el6_2.noarch
katello-selinux-0.1.10-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Create custom provider.
2. Create new products for that provider.
3. Execute "product list" command for that provider, and you will see that just created products are not listed, and product list is empty.
  
Actual results:
No any product is shown in products list in CLI command "product list".

Expected results:
Products should be shown in list.

Additional info:
The same problem is for RedHat Content Provider, when manifest is imported, products are not shown by CLI but shows ok by WebUI.
There was a bug 827494, which said that products are not shown correctly by CLI after importing manifest. So current bug may be is occurred after fixing that bug.
Comment 1 Garik Khachikyan 2012-06-18 08:07:23 EDT
it's a regression happened on 1.0.z puddle-only.
Comment 2 Lukas Zapletal 2012-06-18 10:08:25 EDT
I have introduced this when fixing two other mistakes cherry-picked in. Will fix. CFSE repo only.
Comment 5 Lukas Zapletal 2012-06-18 10:22:25 EDT
@Hayk - could you confirm me if this change fixes the issue:

File: /usr/lib/python2.6/site-packages/katello/client/core/product.py
Line: 175 (+-)

-        self.printer.printItem(prods)
+        self.printer.printItems(prods)

Thanks!
Comment 6 Lukas Zapletal 2012-06-18 10:47:58 EDT
commit ef1df07f49497db9dc9adc6c5eac6e8586a3764f
Refs: SYSTEM-ENGINE-1.0.1, <origin/SYSTEM-ENGINE-1.0.1>, katello-0.1.317-1-1-gef1df07
Author:     Lukas Zapletal <lzap+git@redhat.com>
AuthorDate: Mon Jun 18 16:46:02 2012 +0200
Commit:     Lukas Zapletal <lzap+git@redhat.com>
CommitDate: Mon Jun 18 16:46:02 2012 +0200
Comment 10 Dan Macpherson 2012-06-24 12:25:03 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A typo in a class instance stopped the System Engine CLI from listing products. This fix corrects the typo. System Engine CLI now lists products correctly.
Comment 11 Dan Macpherson 2012-06-24 12:27:20 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-A typo in a class instance stopped the System Engine CLI from listing products. This fix corrects the typo. System Engine CLI now lists products correctly.+A code regression caused a class instance typo, which stopped the System Engine CLI from listing products. This fix corrects the typo. System Engine CLI now lists products correctly.
Comment 14 errata-xmlrpc 2012-07-10 03:25:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html

Note You need to log in before you can comment on or make changes to this bug.