Bug 833097 - SELinux is preventing /usr/libexec/postfix/local from 'read' accesses on the lnk_file /var/tmp.
SELinux is preventing /usr/libexec/postfix/local from 'read' accesses on the ...
Status: CLOSED DUPLICATE of bug 833096
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e5ebc96583731805628d7c7ff3a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 11:03 EDT by Lester Petrie
Modified: 2012-06-18 11:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 11:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lester Petrie 2012-06-18 11:03:04 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           Mon 18 Jun 2012 11:02:10 AM EDT

description:
:SELinux is preventing /usr/libexec/postfix/local from 'read' accesses on the lnk_file /var/tmp.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that local should be allowed read access on the tmp lnk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep local /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:postfix_local_t:s0
:Target Context                system_u:object_r:tmp_t:s0
:Target Objects                /var/tmp [ lnk_file ]
:Source                        local
:Source Path                   /usr/libexec/postfix/local
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           postfix-2.9.2-2.fc17.x86_64
:Target RPM Packages           filesystem-3-2.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-1.fc17.x86_64 #1 SMP
:                              Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Mon 18 Jun 2012 10:45:19 AM EDT
:Last Seen                     Mon 18 Jun 2012 10:50:44 AM EDT
:Local ID                      6bb1e890-89fe-4e1b-adc6-427ca042f85d
:
:Raw Audit Messages
:type=AVC msg=audit(1340031044.555:196): avc:  denied  { read } for  pid=5619 comm="local" name="tmp" dev="sdd5" ino=130860 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:tmp_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1340031044.555:196): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fb77496b4cb a1=7fffc1a39fc0 a2=7fffc1a39fc0 a3=7fffc1a39d50 items=0 ppid=1289 pid=5619 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=local exe=/usr/libexec/postfix/local subj=system_u:system_r:postfix_local_t:s0 key=(null)
:
:Hash: local,postfix_local_t,tmp_t,lnk_file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-18 11:11:35 EDT

*** This bug has been marked as a duplicate of bug 833096 ***

Note You need to log in before you can comment on or make changes to this bug.