Bug 833253 - WARNING: at drivers/gpu/drm/i915/i915_drv.c:398 gen6_gt_check_fifodbg+0x41/0x60 [i915]()
WARNING: at drivers/gpu/drm/i915/i915_drv.c:398 gen6_gt_check_fifodbg+0x41/0x...
Status: CLOSED DUPLICATE of bug 834773
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-06-18 23:20 EDT by Satish Balay
Modified: 2012-08-16 08:32 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-16 08:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg.log (247.49 KB, text/x-log)
2012-06-18 23:20 EDT, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2012-06-18 23:20:36 EDT
Created attachment 592815 [details]

Description of problem:

The gnome display froze after a few hours of usage of 3.4.3-1.fc16.x86_64 [with a few suspend resume cycles] on a thinkpad T420s laptop. It was not responding to the keyboard or mouse events [even Alt-ctl-F2 etc.]. The mouse would move - arround the display but the mouse clicks were ignored. But network was working [I could ssh in and reboot remotely]

Version-Release number of selected component (if applicable):


How reproducible:

Happened once. [Never saw this with earlier kernels]

Steps to Reproduce:
1. Upgraded to kernel-3.4.3-1.fc16.x86_64 [from koji]
2. after a few hours of on and off use [with suspends] - the laptop became unuseable.

Additional info:

dmesg [captured remotely - before reoobt] had bunch of messages of the following type:


[10107.113637] thinkpad_acpi: unknown possible thermal alarm or keyboard event received
[10107.113647] thinkpad_acpi: unhandled HKEY event 0x6040
[10107.113652] thinkpad_acpi: please report the conditions when this event happened to ibm-acpi-devel@lists.sourceforge.net
[10107.114424] thinkpad_acpi: EC reports that Thermal Table has changed
[10848.916054] ------------[ cut here ]------------
[10848.916107] WARNING: at drivers/gpu/drm/i915/i915_drv.c:398 gen6_gt_check_fifodbg+0x41/0x60 [i915]()
[10848.916112] Hardware name: 417152U
[10848.916116] MMIO read or write has been dropped 3
[10848.916119] Modules linked in: tpm_tis tpm tpm_bios joydev tcp_lp fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio lockd ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant arc4 snd_hda_intel snd_hda_codec iwlwifi snd_hwdep vhost_net macvtap macvlan tun e1000e snd_seq snd_seq_device kvm_intel kvm snd_pcm thinkpad_acpi mac80211 snd_timer i2c_i801 coretemp cfg80211 uinput iTCO_wdt snd iTCO_vendor_support snd_page_alloc soundcore rfkill sunrpc microcode crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: tpm_bios]
[10848.916245] Pid: 1137, comm: Xorg Not tainted 3.4.3-1.fc16.x86_64 #1
[10848.916249] Call Trace:
[10848.916267]  [<ffffffff810579df>] warn_slowpath_common+0x7f/0xc0
[10848.916277]  [<ffffffff81057ad6>] warn_slowpath_fmt+0x46/0x50
[10848.916302]  [<ffffffffa00772d1>] gen6_gt_check_fifodbg+0x41/0x60 [i915]
[10848.916324]  [<ffffffffa007782a>] __gen6_gt_force_wake_put+0x1a/0x20 [i915]
[10848.916347]  [<ffffffffa0077897>] gen6_gt_force_wake_put+0x47/0x60 [i915]
[10848.916383]  [<ffffffffa00b5e29>] gen6_ring_put_irq+0x79/0x90 [i915]
[10848.916412]  [<ffffffffa00b5e58>] blt_ring_put_irq+0x18/0x20 [i915]
[10848.916439]  [<ffffffffa0088cba>] i915_wait_request+0x18a/0x4e0 [i915]
[10848.916450]  [<ffffffff81079c00>] ? remove_wait_queue+0x50/0x50
[10848.916475]  [<ffffffffa0089047>] i915_gem_object_wait_rendering+0x37/0x40 [i915]
[10848.916501]  [<ffffffffa008fc7a>] i915_gem_do_execbuffer+0xaca/0x1610 [i915]
[10848.916527]  [<ffffffffa0090cbe>] i915_gem_execbuffer2+0xae/0x290 [i915]
[10848.916552]  [<ffffffffa00213cc>] drm_ioctl+0x47c/0x540 [drm]
[10848.916579]  [<ffffffffa0090c10>] ? i915_gem_execbuffer+0x450/0x450 [i915]
[10848.916589]  [<ffffffff810143f4>] ? do_signal+0x194/0x5d0
[10848.916598]  [<ffffffff811910a8>] do_vfs_ioctl+0x98/0x550
[10848.916606]  [<ffffffff811915f1>] sys_ioctl+0x91/0xa0
[10848.916615]  [<ffffffff81600647>] ? int_check_syscall_exit_work+0x34/0x3d
[10848.916622]  [<ffffffff816003a9>] system_call_fastpath+0x16/0x1b
[10848.916627] ---[ end trace 7cf342a2b40f6426 ]---
[10848.917245] ------------[ cut here ]------------
Comment 1 Satish Balay 2012-06-18 23:43:25 EDT
I'm not sure if the following 'ERROR' lines from the log are significant or not.

The first ERROR message is well before the first stack trace in the log. And then in the middle of the multiple stack traces there is the 'GPU hung' message. [Hence my gnome session was completely frozen?]

[  736.184055] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... blt ring idle [waiting on 270419, at 270419], missed IRQ?
[10856.637469] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[10856.649550] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 0001f001 head 00000000 tail 00000000 start 00000000

And I don't see any 'drm:i915_hangcheck_ring_idle' messages in logs with older kernels.

I'm now rebooted again into kernel-3.4.3-1.fc16 - and again see:
[ 1331.251282] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... blt ring idle [waiting on 259969, at 259969], missed IRQ?
Comment 2 Satish Balay 2012-06-18 23:58:54 EDT
The following bugzilla rentry looks related [same message - but slightly different stack trace]

Comment 3 andri yanto 2012-08-16 08:32:33 EDT

Fedora Bugzappers volunteer triage team

*** This bug has been marked as a duplicate of bug 834773 ***

Note You need to log in before you can comment on or make changes to this bug.