Bug 833417 - [Storage] Force Remove of DataCenter doesn't remove templates from the system.
[Storage] Force Remove of DataCenter doesn't remove templates from the system.
Status: CLOSED DUPLICATE of bug 818091
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Tal Nisan
Haim
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 08:44 EDT by Leonid Natapov
Modified: 2016-02-10 11:43 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 09:49:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (63.17 KB, application/octet-stream)
2012-06-19 08:44 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2012-06-19 08:44:42 EDT
Created attachment 592933 [details]
engine log

[Storage] Force Remove of DataCenter doesn't remove templates from the system.
When force removing datacenter all storage domains in this DC,VMs,Disks and templates must be removed from the setup. Templates are not being removed and it's impossible to remove it after. No particular messages in the engine.log when force removeing DC. Null Pointer exception when trying to remove template after DC was removed. 
log attached.

2012-06-19 15:38:57,122 ERROR [org.ovirt.engine.core.bll.RemoveVmTemplateCommand] (pool-3-thread-44) [7d41fc5c] Command org.ovirt.engine.core.bll.RemoveVmTemplateCommand throw exception: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.RemoveVmTemplateCommand.executeCommand(RemoveVmTemplateCommand.java:178) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.ExecuteWithoutTransaction(CommandBase.java:757) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:849) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1149) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:168) [engine-utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:107) [engine-utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.Execute(CommandBase.java:864) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.ExecuteAction(CommandBase.java:269) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.executeValidatedCommands(MultipleActionsRunner.java:182) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.RunCommands(MultipleActionsRunner.java:162) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner$1.run(MultipleActionsRunner.java:84) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:64) [engine-utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.6.0_24]
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.6.0_24]
        at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.6.0_24]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_24]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_24]
        at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_24]
Comment 2 Tal Nisan 2012-06-24 09:49:20 EDT

*** This bug has been marked as a duplicate of bug 818091 ***

Note You need to log in before you can comment on or make changes to this bug.