Bug 818091 - [ovirt] [engine-core] force remove pool using wrong query and doesn't remove templates attached
[ovirt] [engine-core] force remove pool using wrong query and doesn't remove ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Tal Nisan
Leonid Natapov
storage
:
: 806886 814204 833417 (view as bug list)
Depends On: 806886
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 04:14 EDT by Dafna Ron
Modified: 2016-02-10 11:32 EST (History)
15 users (show)

See Also:
Fixed In Version: SI8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 806886
Environment:
Last Closed: 2012-12-04 15:02:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-05-02 04:14:27 EDT
cloning this to downstream since cleaning of templates in case of DC force remove or domain destroy is important enough. 

+++ This bug was initially created as a clone of Bug #806886 +++

Created attachment 572748 [details]
engine log.

Description of problem:

- pool with 1 domain
- 2 templates
- host
- domain is in problematic state 

Force remove data-base: templates remain, all other objects are deleted 

try remove cluster: 2012-03-26 13:46:09,838 WARN  [org.ovirt.engine.core.bll.RemoveVdsGroupCommand] (http--0.0.0.0-8080-2) CanDoAction of action RemoveVdsGroup failed. Reasons:VAR__TYPE__CLUSTER,VAR__ACTION__REMOVE,VMT_CANNOT_REMOVE_VDS_GROUP_VMTS_DETECTED
,VDS_GROUP_CANNOT_REMOVE_HAS_VM_POOLS

--- Additional comment from dron@redhat.com on 2012-05-01 04:45:34 EDT ---

destroy of domain will also not remove the templates under the domain. 
we can however remove them manually after the destroy.
Comment 1 mkublin 2012-06-10 09:15:18 EDT
*** Bug 806886 has been marked as a duplicate of this bug. ***
Comment 2 Tal Nisan 2012-06-20 10:06:49 EDT
http://gerrit.ovirt.org/5407
Comment 3 Tal Nisan 2012-06-24 09:49:20 EDT
*** Bug 833417 has been marked as a duplicate of this bug. ***
Comment 4 Haim 2012-06-25 11:07:16 EDT
tried to verify on SI7 - force-remove data-center doesn't remove template for data-center type local-fs. 


StatusCommand] (QuartzScheduler_Worker-42) [7ca2c556] Running command: SetStoragePoolStatusCommand internal: true. Entities affected :  ID: 98d1c31c-5d40-4556-
oolCommand] (ajp-/0.0.0.0:8009-8) [7afa3620] Running command: RemoveStoragePoolCommand internal: false. Entities affected :  ID: 98d1c31c-5d40-4556-8e4d-9874bf
QuartzScheduler_Worker-42) [7ca2c556] Checking autorecoverable hosts
QuartzScheduler_Worker-42) [7ca2c556] Autorecovering 0 hosts
QuartzScheduler_Worker-42) [7ca2c556] Checking autorecoverable hosts done
QuartzScheduler_Worker-42) [7ca2c556] Checking autorecoverable storage domains
QuartzScheduler_Worker-42) [7ca2c556] Autorecovering 0 storage domains
QuartzScheduler_Worker-42) [7ca2c556] Checking autorecoverable storage domains done
~
Comment 5 Haim 2012-06-25 11:09:44 EDT
*** Bug 814204 has been marked as a duplicate of this bug. ***
Comment 6 vvyazmin@redhat.com 2012-07-10 09:53:02 EDT
Verified on RHEVM 3.1 - SI9.1 

RHEV-M: rhevm-3.1.0-5.el6ev.noarch
VDSM: vdsm-4.9.6-17.0.el6.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMV & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.