Bug 833461 - [ALL LANG] Subscription manager GUI : Alert message not translated
[ALL LANG] Subscription manager GUI : Alert message not translated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-19 10:00 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:55:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Alert message not translated (60.45 KB, image/png)
2012-06-19 10:01 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2012-06-19 10:00:50 EDT
Description of problem:
When the subscription-manager is unregistered, the alert message prompting the user to subscribe is not localised

Version-Release number of selected component (if applicable):
RHEL 5.9

# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.4-1.git.0.0fe81f8.el5
subscription-manager-1.0.4-1.git.0.0fe81f8.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.0.0fe81f8.el5
subscription-manager-firstboot-1.0.4-1.git.0.0fe81f8.el5

How reproducible:
100%

Steps to Reproduce:
1. LANG=es_ES.UTF8 subscription-manager-gui  (any language option)
2. Click on "Unregister"
3. Click "OK"
  
Actual results:
The Alert message is untranslated

Expected results:
The Alert message is to be untranslated

Additional info:
Scrrenshot attached
Comment 1 Sharath Dwaral 2012-06-19 10:01:21 EDT
Created attachment 592969 [details]
Alert message not translated
Comment 3 RHEL Product and Program Management 2012-06-19 16:28:30 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Bryan Kearney 2012-08-13 10:03:31 EDT
Tested this in 1.0.13 test version and can not reproduce. Please retest with 1.0.14.
Comment 6 John Sefler 2012-08-24 11:24:59 EDT
Verifying Version...

[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.14-1.el5

[root@jsefler-rhel59 ~]# for f in `rpm -ql subscription-manager | grep rhsm.mo`; do echo ""; echo "$f"; msgunfmt $f | grep "You must register this system before subscribing." -A1; done;

/usr/share/locale/as/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "আপুনি এই চিস্টেমক স্বাক্ষৰ কৰাৰ আগত ৰেজিস্টাৰ কৰিব লাগিব।"

/usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "সাবস্ক্রাইব করার পূর্বে নিবন্ধন করা আবশ্যক।"

/usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "Sie müssen dieses System vor dem Subskribieren registrieren."

/usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "Deber registrar este sistema antes de la suscripción."

/usr/share/locale/fr/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "Vous devez enregistrer ce système avant de procéder à l'abonnement."

/usr/share/locale/gu/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "ઉમેદવારી કરતા પહેલાં આ સિસ્ટમને તમારે રજીસ્ટર કરવી જ જોઇએ."

/usr/share/locale/hi/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "आपको इस तंत्र को सदस्यता लेने के पहले पंजीकृत किया जाना चाहिए"

/usr/share/locale/it/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "Registrare questo sistema prima di eseguire una sottoscrizione."

/usr/share/locale/ja/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "サブスクライブする前にこのシステムを登録する必要があります。"

/usr/share/locale/kn/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "ಚಂದಾದಾರನಾಗುವ ಮೊದಲು ನೀವು ಈ ವ್ಯವಸ್ಥೆಯನ್ನು ನೋಂದಾಯಿಸಬೇಕು."

/usr/share/locale/ko/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "가입하기 전 이 시스템을 등록해야 합니다."

/usr/share/locale/ml/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "സബ്സ്ക്രൈബ് ചെയ്യുന്നതിനു് മുമ്പു് ഈ സിസ്റ്റം രജിസ്ടര്‍ ചെയ്യേണ്ടതുണ്ടു്."

/usr/share/locale/mr/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "सबस्क्रिप्शन करण्यापूर्वी या प्रणालीची नोंदणी करणे आवश्यक आहे."

/usr/share/locale/or/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "ସଦସ୍ୟତା ଗ୍ରହଣ କରିବା ପୂର୍ବରୁ ଆପଣଙ୍କୁ ଏହି ତନ୍ତ୍ରକୁ ପଞ୍ଜିକରଣ କରିବାକୁ ହେବ।"

/usr/share/locale/pa/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "ਤੁਹਾਨੂੰ ਮੈਂਬਰੀ ਤੋਂ ਪਹਿਲਾਂ ਇਹ ਸਿਸਟਮ ਰਜਿਸਟਰ ਕਰਨਾ ਪਵੇਗਾ।"

/usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "Você precisa registrar este sistema antes de subscrever."

/usr/share/locale/ru/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "Прежде чем выбрать подписки, необходимо зарегистрировать систему."

/usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "சந்தா பெறும் முன்பு நீங்கள் இந்தக் கணினியைப் பதிவுசெய்ய வேண்டும்."

/usr/share/locale/te/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "సబ్‌స్క్రైబ్ చేయుటకు ముందుగా మీరు యీ వ్యవస్థను నమోదుచేయాలి."

/usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "订阅前您必须注册这个系统。"

/usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo
msgid "You must register this system before subscribing."
msgstr "您進行訂閱前,必須註冊此系統。"


^^^ VERIFIED All the language files have a translation for this string.  However it appears that this string has been replaced with a new one; see Bug 851642
Comment 8 errata-xmlrpc 2013-01-07 22:55:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.