Bug 833539 - Can't list what os release to use
Can't list what os release to use
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-rhsm (Show other bugs)
5.9
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Chris Duryee
Entitlement Bugs
:
Depends On: 822057
Blocks: 826592 771748 832118
  Show dependency treegraph
 
Reported: 2012-06-19 13:24 EDT by Alex Wood
Modified: 2013-01-08 02:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation necessary.
Story Points: ---
Clone Of: 822057
Environment:
Last Closed: 2013-01-08 02:17:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 RHEL Product and Program Management 2012-06-19 13:28:31 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 RHEL Product and Program Management 2012-06-19 16:48:31 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Sharath Dwaral 2012-06-25 11:30:58 EDT
Version:

RHEL 5.9

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

Actual Result: 

1. Connecting to SAM 

# subscription-manager register --force --org=ACME_Corporation --env=DEV
Username: admin
Password: 
The system has been registered with id: 4b7f159e-b131-416c-a00b-19617fb053a0 

2. Searching for Entitlements

# subscription-manager list
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.8
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

3. Checking for availability

# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

Subscription Name:    	Red Hat Enterprise Linux Server, Self-support (1-2 sockets)
                        (Up to 1 guest)
Pool Id:              	000000003810b362013823baaea80258
Quantity:             	2
Service Level:        	SELF-SUPPORT
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	04/29/2013
Machine Type:         	physical

4. Subscribing the availabe entitlement

# subscription-manager subscribe --pool=000000003810b362013823baaea80258
Successfully consumed a subscription for: Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)

# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Product Subscriptions
+-------------------------------------------+

Subscription Name:    	Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)
Provides:             	Red Hat Enterprise Linux Server
Contract:             	3019942
Account:              	1580789
Serial Number:        	5629653108486315506
Active:               	True
Quantity Used:        	1
Service Level:        	SELF-SUPPORT
Service Type:         	L1-L3
Starts:               	04/30/2012
Ends:                 	04/29/2013

# subscription-manager release --list
Network error, unable to connect to server.
Please see /var/log/rhsm/rhsm.log for more information.


Expected Result:
Should display release list

Additional Info: /var/log/rhsm/rhsm.log

2012-06-25 11:22:19,697 [INFO]  @release.py:138 - No matching products with RHEL product tags found
2012-06-25 11:22:19,698 [INFO]  @release.py:138 - No matching products with RHEL product tags found
2012-06-25 11:22:19,698 [DEBUG]  @connection.py:198 - Loading CA certificate: '/etc/pki/entitlement/5629653108486315506.pem'
2012-06-25 11:22:19,745 [ERROR]  @managercli.py:113 - exception caught in subscription-manager
2012-06-25 11:22:19,746 [ERROR]  @managercli.py:114 - (-2, 'Name or service not known')
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager", line 78, in ?
    sys.exit(abs(main() or 0))
  File "/usr/sbin/subscription-manager", line 69, in main
    return managercli.CLI().main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1949, in main
    return cmd.main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 399, in main
    return_code = self._do_command()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1161, in _do_command
    releases = self.release_backend.get_releases()
  File "/usr/share/rhsm/subscription_manager/release.py", line 98, in get_releases
    data = self.content_connection.get_versions(listing_path)
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 216, in get_versions
    results = self._request("GET", handler, body="")
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 184, in _request
    conn.request("GET", handler, body="", headers={"Host": "%s:%s" % (self.host, self.ssl_port), "Content-Length": "0"})
  File "/usr/lib64/python2.4/httplib.py", line 810, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.4/httplib.py", line 833, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.4/httplib.py", line 804, in endheaders
    self._send_output()
  File "/usr/lib64/python2.4/httplib.py", line 685, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.4/httplib.py", line 652, in send
    self.connect()
  File "/usr/lib64/python2.4/site-packages/M2Crypto/httpslib.py", line 47, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 170, in connect
    self.socket.connect(addr)
  File "<string>", line 1, in connect
gaierror: (-2, 'Name or service not known')
Comment 6 Bryan Kearney 2012-08-16 11:42:54 EDT
Here is the deal. Subscirption Manager in 5.9 will error gracefully against SAM. Until SAM fixes https://bugzilla.redhat.com/show_bug.cgi?id=834013 then this feature will be disabled in RHSM. I am going to mark this as modified, and ask QE to please verify that RHSM behaves nicely against SAM 1.1. When SAM 1.2 comes out, or CFSE 1.1, the bug will be resolved and this feature will work again.
Comment 7 John Sefler 2012-10-17 16:44:03 EDT
Moving to VERIFIED based on https://bugzilla.redhat.com/show_bug.cgi?id=832118#c10 which was tested using python-rhsm-1.0.10-1.el5
Comment 9 errata-xmlrpc 2013-01-08 02:17:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0039.html

Note You need to log in before you can comment on or make changes to this bug.