Bug 832118 - Can't list what os release to use
Can't list what os release to use
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On: 822057 833539
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-14 10:48 EDT by Alex Wood
Modified: 2013-01-07 22:55 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: 822057
Environment:
Last Closed: 2013-01-07 22:55:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Sharath Dwaral 2012-06-25 11:31:57 EDT
Waiting on Bug 833539.
Comment 3 Bryan Kearney 2012-08-16 11:43:22 EDT
Here is the deal. Subscirption Manager in 5.9 will error gracefully against SAM. Until SAM fixes https://bugzilla.redhat.com/show_bug.cgi?id=834013 then this feature will be disabled in RHSM. I am going to mark this as modified, and ask QE to please verify that RHSM behaves nicely against SAM 1.1. When SAM 1.2 comes out, or CFSE 1.1, the bug will be resolved and this feature will work again.
Comment 5 spandey 2012-08-27 03:16:11 EDT
subscription-manager rpm 
subscription-manager-1.0.14-1.git.24.812ba3e.el5
subscription-manager-firstboot-1.0.14-1.git.24.812ba3e.el5
subscription-manager-migration-data-1.11.2.3-1.git.4.8bd27be.el5
subscription-manager-migration-1.0.14-1.git.24.812ba3e.el5
subscription-manager-gui-1.0.14-1.git.24.812ba3e.el5


got following message 

[root@localhost ~]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@localhost ~]# subscription-manager release --list
Error: The 'release' command is not supported by the server.
Comment 6 John Sefler 2012-10-15 12:58:58 EDT
Verifying against...
CloudForms System Engine Version: 1.1.12-14.el6cf 
[root@jsefler-rhel59 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.0.22-1.el5
python-rhsm-1.0.10-1.el5

[root@jsefler-rhel59 ~]# subscription-manager register --username admin --serverurl=se-rhelbox.usersys.redhat.com/cfse/api --org Test_Org --env Test_Env
Password: 
The system has been registered with id: 7ddc4847-e5b7-4deb-920a-69994fe0d069 
[root@jsefler-rhel59 ~]# subscription-manager release --list
No release versions available, please check subscriptions.
[root@jsefler-rhel59 ~]# 

^^ That message is good sign.  We also need to test against a cfse that has real RHEL content imported.
Comment 9 John Sefler 2012-10-17 15:19:11 EDT
Attempting to verify against a cfse server that has a RHEL subscription available with RHEL 5 content sync'ed...
CloudForms System Engine Version: 1.1.12-14.el6cf 
[root@jsefler-rhel59 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.0.22-1.el5
python-rhsm-1.0.10-1.el5


Installing compatible server CA certs and rhsm.conf updates....
[root@jsefler-rhel59 ~]# rpm -ivh http://se-rhelbox.usersys.redhat.com/pub/candlepin-cert-consumer-se-rhelbox.usersys.redhat.com-1.0-1.noarch.rpm
Retrieving http://se-rhelbox.usersys.redhat.com/pub/candlepin-cert-consumer-se-rhelbox.usersys.redhat.com-1.0-1.noarch.rpm
Preparing...                ########################################### [100%]
   1:candlepin-cert-consumer########################################### [100%]

Registering to the cfse org that contains the RHEL subscription with RHEL5 content...
[root@jsefler-rhel59 ~]# subscription-manager register --username admin --serverurl=se-rhelbox.usersys.redhat.com/cfse/api --org Test_Org_1349760599 --env Dev --autosubscribe
Password: 
The system has been registered with id: 6d656024-d35a-413d-848d-ccd1a6bb584e 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@jsefler-rhel59 ~]# ls /etc/pki/entitlement/
3790292612061835462-key.pem  3790292612061835462.pem

[root@jsefler-rhel59 ~]# yum repolist
Loaded plugins: product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
rhel-5-server-rpms                                           | 3.7 kB     00:00     
repo id                     repo name                                         status
rhel-5-server-rpms          Red Hat Enterprise Linux 5 Server (RPMs)          14,132
repolist: 14,132
[root@jsefler-rhel59 ~]# 

[root@jsefler-rhel59 ~]# subscription-manager release --list
No release versions available, please check subscriptions.

^^^^ BANG! Did not expect that.  Expected the contents from a "listing" file from pulp.

[root@jsefler-rhel59 ~]# grep baseurl /etc/yum.repos.d/redhat.repo 
baseurl = https://se-rhelbox.usersys.redhat.com/pulp/repos/Test_Org_1349760599/Dev//content/dist/rhel/server/5/$releasever/$basearch/os

[root@jsefler-rhel59 ~]# curl --stderr /dev/null --insecure --tlsv1 --cert /etc/pki/entitlement/3790292612061835462.pem --key /etc/pki/entitlement/3790292612061835462-key.pem https://se-rhelbox.usersys.redhat.com/pulp/repos/Test_Org_1349760599/Dev//content/dist/rhel/server/5/listing
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /pulp/repos/Test_Org_1349760599/Dev//content/dist/rhel/server/5/listing
on this server.</p>
<hr>
<address>Apache/2.2.15 (Red Hat) Server at se-rhelbox.usersys.redhat.com Port 443</address>
</body></html>
[root@jsefler-rhel59 ~]# 

^^^ BANG! Did not expect that.  Expected to see the contents of the "listing" file for rhel/server/5.
Comment 10 John Sefler 2012-10-17 16:36:09 EDT
In the context of subscription-manager, we (tomckay and jsefler) decided to move this bug to VERIFIED because, as stated in comment 3, "Subscirption Manager in 5.9 will error gracefully...". As demonstrated in comment 9 it does error gracefully by stating "No release versions available, please check subscriptions."

Please follow up with bug 867602 for a solution to the empty release list.
Comment 12 errata-xmlrpc 2013-01-07 22:55:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.