Bug 833659 - qxl driver in virtio-win-1.5.2 is not digital signed
qxl driver in virtio-win-1.5.2 is not digital signed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jay Greguske
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 838655
  Show dependency treegraph
 
Reported: 2012-06-20 00:46 EDT by Mike Cao
Modified: 2013-02-21 05:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:39:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-06-20 00:46:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-1.5.2-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.install win7 32 bit guests w/ -spice port=5910,disable-ticketing -vga qxl
2.install qxl driver in virtio-win-1.5.2.vfd

  
Actual results:
The driver is not digital signed 

Expected results:
The driver *must* digital signed 

Additional info:
Tried w/ virtio-win-1.5.1 ,seems did not hit this issue ,I think Bug 823482 cause regression
Comment 4 Jay Greguske 2012-06-20 09:58:32 EDT
Can you confirm whether the driver is signed or merely not matching the signature in the .cat file? My fear is that adding CRLF characters to the .inf file caused the signaures to no longer match for QXL.
Comment 5 Mike Cao 2012-06-20 10:51:28 EDT
(In reply to comment #4)
> Can you confirm whether the driver is signed or merely not matching the
> signature in the .cat file? My fear is that adding CRLF characters to the
> .inf file caused the signaures to no longer match for QXL.

I did not get it .Do you mean I need to use signtool.exe to check whether sys is matching the .cat file ?

I just try to install qxl driver in device manager ,it prompts the driver is not digital signed .and after installation ,the manufacturer is redhat inc .
Comment 7 Grant Williamson 2012-06-26 03:30:03 EDT
Actually performing a "dos2unix qxl.inf" it will then load.
Comment 8 Jay Greguske 2012-06-26 08:45:59 EDT
Ok, I can put together another build that has that. We'll have to be careful in the future that what we submit to Microsoft has the correct CRLF terminators.

Before proceeding though I'd like an answer to this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=802248

It proposes removing QXL drivers from virtio-win entirely.
Comment 9 Alon Levy 2012-06-28 02:45:45 EDT
(In reply to comment #8)
> Ok, I can put together another build that has that. We'll have to be careful
> in the future that what we submit to Microsoft has the correct CRLF
> terminators.

Ok. We should also not use autocrlf in the git repository to which the signed files are commited. Signed files cannot be changed, as this bug demonstrates.
Comment 19 Mike Cao 2012-07-12 22:16:10 EDT
According to comment #18 ,move status to verified .
Comment 20 errata-xmlrpc 2013-02-21 05:39:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.