Bug 833663 - Kernel Panic - not syncing: Fatal exception in interrupt
Kernel Panic - not syncing: Fatal exception in interrupt
Status: CLOSED DUPLICATE of bug 835785
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 01:20 EDT by dtc-rhbug
Modified: 2012-07-01 05:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-01 05:56:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen capture of kernel panic output. (81.06 KB, image/jpeg)
2012-06-20 01:20 EDT, dtc-rhbug
no flags Details
Another screenshot from this kernel panic (2.83 MB, image/jpeg)
2012-06-22 11:02 EDT, Fabian.Schmidt.85
no flags Details

  None (edit)
Description dtc-rhbug 2012-06-20 01:20:16 EDT
Created attachment 593128 [details]
Screen capture of kernel panic output.

Description of problem:

Getting a few panics a day with the 3.4 kernels. Often the screen just locks up and there is no record of the oops.  Mostly the keyboard blinks.  Got luckly and caught the attached console dump, see attachment. Kernel Panic - not syncing: Fatal exception in interrupt

Version-Release number of selected component (if applicable):
kernel-3.4.2-4.fc17.x86_64

How reproducible:

These do not appear to correlate with any specific activity.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fabian.Schmidt.85 2012-06-22 03:55:30 EDT
I am researching this bug for 2 days now and it seems like it has something to do with the wireless driver ath9k. Although from your screenshot I cannot tell that it is related I have no kernel panics when the wireless is not switched on. Furthermore on my laptop the screen stays on after the panic occurs so i could study the output a bit more. Thats why I think it might have something to do with the ath9k. I hope this helps anybody to pinpoint the real issue behind that. I might add a screenshot later on when i am home and can reproduce the error.
Comment 2 dtc-rhbug 2012-06-22 05:30:20 EDT
(In reply to comment #1)
> I am researching this bug for 2 days now and it seems like it has something
> to do with the wireless driver ath9k. Although from your screenshot I cannot
> tell that it is related I have no kernel panics when the wireless is not
> switched on. Furthermore on my laptop the screen stays on after the panic
> occurs so i could study the output a bit more. Thats why I think it might
> have something to do with the ath9k. I hope this helps anybody to pinpoint
> the real issue behind that. I might add a screenshot later on when i am home
> and can reproduce the error.

The backtrace has a number of IPV6 related functions and after disabling IPV6 on the Ethernet and an IVP6 tunnel there has not yet been a panic. Do you see any IPV6 functions in the backtraces you have been studying?

Here's a transcript of the backtrace in case it helps:
udpv6_sendmsg
inet_sendmsg
selinux_socket_sendmsg
sock_sendmsg
ipv6_get_saddr_eval
ipv6_dev_get_saddr
ip6_route_get_saddr
verify_iovec
__sys_sendmsg
sk_setup_caps
ip6_datagram_connect
do_futex
__dequeue_entity
__switch_to
sys_sendmsg
system_call_fast_path
Comment 3 Fabian.Schmidt.85 2012-06-22 11:02:25 EDT
Created attachment 593775 [details]
Another screenshot from this kernel panic

It seems not like an ipv6 problem on my side
Comment 4 Stanislaw Gruszka 2012-07-01 05:56:02 EDT
This is ath9k related crash  ...

*** This bug has been marked as a duplicate of bug 835785 ***

Note You need to log in before you can comment on or make changes to this bug.