Bug 83369 - RHEL3/B1: GDM at 640x480
RHEL3/B1: GDM at 640x480
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gdm (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
: Triaged
: 102393 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-02-03 09:14 EST by Alan Cox
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-15 11:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-02-03 09:14:08 EST
Description of problem:

In the beta (but not in 8.0) gdm at 640x480 places the shutdown button and the
date in
the same place. This produces a nasty splat rather than the desired output. It
seems gdm
ought to either lose the date or change font size. Oddly 8.0 got it right

How reproducible:

100%. - SiS video card using 640x480 to test TV out. Sony monitor with all the
ident stuff
so that may have affected the font sizing if I understand it right.

Steps to Reproduce:
1. Set display resolution to 640x480
2. ctrl-alt-backspace, let X restart
3. Observe
    
Actual results:

Nasty mess in the bottom right

Expected results:

Either the date not being there or different font sizing
Comment 1 Havoc Pennington 2003-02-03 15:24:12 EST
There are just 4 buttons now instead of 3, so it doesn't fit.
We could shrink the font or something. I don't know if gdm supports
scaling the theme with resolution.
Comment 2 Bill Nottingham 2003-08-14 15:02:19 EDT
*** Bug 102393 has been marked as a duplicate of this bug. ***
Comment 3 Larry Troan 2003-08-14 17:21:04 EDT
Since Bug 102393 marked as a DUP of this bug, changing this Bug to
Product=RHEL3, version=B1 (was RHL8beta?)  

ISSUE TRACKER 26680 opened as sev 4.
Comment 4 Havoc Pennington 2003-08-14 17:44:24 EDT
In general I would not expect 640x480 to work; 800x600 is the 
"smallest reasonable resolution" that the UI is planned for.
We don't have the resources to address or test all 640x480 issues.

That said if this particular bug is easy to fix, there's no reason not to.
Just don't expect all "dialog is 500 pixels high" type of bugs to 
be addressed...
Comment 5 Alan Cox 2003-08-14 17:53:38 EDT
I run my mini-notebook at 640x480 and with a window manager that clamps sizes
properly (unrelated metacity bug) there is very little that is at all problematic
except gdm. 
Comment 6 Havoc Pennington 2003-08-14 21:51:47 EDT
George adds:

  upstream 2.4.1.6 version of GDM fixes this by making fonts smaller on smaller
  resolutions.  gdm is quite usable at 640x480 using the Bluecurve theme.  The
  only thing is that the welcome string gets put over the redhat logo, but we
  can really live with that I think (I'm not sure how gdm would solve this
  really anyway except by using a theme that looks more ok at that resolution).

I don't really want to upgrade to 2.4.1.6 in RHEL though, due to risk
of breaking something else. Maybe we could backport this patch if it's 
important. 
Comment 7 Larry Troan 2003-08-15 09:39:15 EDT
FROM ISSUE TRACKER
Event posted 08-15-2003 09:29am by brian.b with duration of 0.00       
redhat-config-xfree86-0.7.6-1
2.4.21-1.1931.2.349.2.2.entsmp

With all that was said above, what do we (HP) need to do and will this be fixed?
 I agree that 640x480 is a pretty low resolution...
Comment 8 Larry Troan 2003-08-15 09:43:02 EDT
Engineering is saying this has been berified to work down to 800x600 by using
bluecurve technology. 
* IF THIS IS A CRITICAL HP REQUIREMENT, they will look at 640x480 but may come
back and deem it too risky to put in....  
* IF NOT ABSOLUTELY NECESSARY, have tested 800x600. Howwever, 640x480 may work
but not a bug if it doesn't work... 
Comment 9 Larry Troan 2003-08-15 11:39:35 EDT
HP agrees that this is not critical and will go with option #2 above:
"640x480 may work but not a bug if it doesn't..."
---
Closing bug as WONTFIX. 
Comment 11 Havoc Pennington 2003-08-15 12:28:57 EDT
After discussion with George I'm building the new gdm now, so this 
may end up being fixed unless we find a reason to remove the newer gdm.

Of course Cambridge will have a newer gdm.

So this should get resolved.

Note You need to log in before you can comment on or make changes to this bug.