Bug 834036 - Inconsistency in sync status view via sync mgmt and Dashboard sync overview for very large repos
Inconsistency in sync status view via sync mgmt and Dashboard sync overview f...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 13:19 EDT by Kedar Bidarkar
Modified: 2014-03-18 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Status as 100% from Sync DashBoard (163.90 KB, image/png)
2012-06-20 13:21 EDT, Kedar Bidarkar
no flags Details
Status not as 'Sync Complete' under Sync Mgmt (134.23 KB, image/png)
2012-06-20 13:22 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Kedar Bidarkar 2012-06-20 13:19:26 EDT
Description of problem:

There is inconsistency between what sync status view is via 

Sync Management  and 
Dashboard Sync Overview.

Version-Release number of selected component (if applicable):
observed with 1.0.1

How reproducible:
Try syncing large repos and towards the end of the sync, we can observe this 
inconsistency issue.

Steps to Reproduce:
1. sync large repos like http://download.devel.redhat.com/released/F-15/GOLD/Everything/x86_64/os/
2.
3.

DashBoard Sync Overview shows, the sync has completed "100%", But

Sync Mgmt does not show, the status as "Sync Complete"

From the above 2 different states, I feel there is some inconsistency for the state of syncs for very large repos.

I will be attaching the screen-shots shortly.

Build : 2012-06-18.1/  
RAM : 2GB
SWAP : 2GB
REPO synced : Single repo F17 (27.1 GB)
  
Actual results:

Inconsistency in sync status

Expected results:


Additional info:
Comment 1 Kedar Bidarkar 2012-06-20 13:21:39 EDT
Created attachment 593280 [details]
Status as 100% from Sync DashBoard
Comment 2 Kedar Bidarkar 2012-06-20 13:22:27 EDT
Created attachment 593281 [details]
Status not as 'Sync Complete' under Sync Mgmt
Comment 3 Kedar Bidarkar 2012-06-20 13:26:05 EDT
The below comment is from Ivan Necas.
https://bugzilla.redhat.com/show_bug.cgi?id=828977#c11

The problem is the progress shows the ratio of downloaded/all packages. But it doesn't include the time required:

1. for calculating metadata
2. removing orphaned packages. 

Both actions take quite a lot of time (I know that calculating metadata for large repo can take 2+ hours. The important thing is that it finished at the end and doesn't get canceled (what this BZ is about). There are already some activities on the Pulp side to improve generating manifests: right now it's using createrepo utility, that doesn't provide the progress information. I don't thing this issues are worth z-stream.
Comment 5 Mike McCune 2013-08-16 14:11:58 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 6 Mike McCune 2014-03-18 13:38:35 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.