Bug 834175 - [whql][Netkvm] Job of "NDISTest6.5-[1 Machine]-StandardizedKeywords" failed on HCK for virtual NIC
[whql][Netkvm] Job of "NDISTest6.5-[1 Machine]-StandardizedKeywords" failed o...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
: 811155 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 02:32 EDT by dawu
Modified: 2014-07-11 02:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Windows certification 2012\Windows 8 certification requires to support all possible offload combination and offload parity between IPv4 and IPv6. Reason: Enforced by WHQL certification Result (if any): All offloads are turned on by default on Windows 2008 and up, IPv6 offloads are implemented.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:39:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
StandardizedKeywords.wtl (65.81 KB, application/octet-stream)
2012-06-21 02:32 EDT, dawu
no flags Details
StandardizedKeywords_34.txt (9.18 KB, text/plain)
2012-08-26 22:56 EDT, dawu
no flags Details

  None (edit)
Description dawu 2012-06-21 02:32:03 EDT
Created attachment 593361 [details]
StandardizedKeywords.wtl

Description of problem:
 Job 1068 of "NDISTest6.5-[1 Machine]-StandardizedKeywords" failed on HCK for virtual NIC.

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29

How reproducible:
always

Steps to Reproduce:

CLI:
* Test guest:
  /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win7-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:33:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:33:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:10:1a:16:33:03,bus=pci.0,addr=0x6 -boot c -uuid 613d8cd4-fb7c-4171-ad3d-aa6693bdfca7 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win7-64-nic1,server,nowait -mon chardev=111a,mode=readline -spice port=5931,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio

* Support guest:
   /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win7-64-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:05:33:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:10:1a:15:33:03,bus=pci.0,addr=0x6 -boot c -uuid fa0cfe20-4efd-4d6a-8c44-d814a022951d -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111b,path=/tmp/monitor-win7-64-nic2,server,nowait -mon chardev=111b,mode=readline -spice port=5932,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio

1. Run job 1068 of "NDISTest6.5-[1 Machine]-StandardizedKeywords".
  
Actual results:
Job failed,please refer to the HCK log file from attached of "StandardizedKeywords" for details.

Expected results:
Job should pass without any error.

Additional info:
Comment 3 Yan Vugenfirer 2012-07-15 11:09:02 EDT
The failure was caused by our lack of default support of RX checksum offload.
Comment 4 Mike Cao 2012-08-23 22:55:13 EDT
This issue still can reproduced on virtio-win-prewhql-33 .

Reassign this issue
Comment 5 Yan Vugenfirer 2012-08-26 07:20:10 EDT
Please attached the logs.
Comment 6 Yan Vugenfirer 2012-08-26 07:21:46 EDT
Did you use the Windows 8 binaries?
Comment 7 Mike Cao 2012-08-26 11:26:53 EDT
(In reply to comment #6)
> Did you use the Windows 8 binaries?

No. there is no win8 netkvm driver in build 34.
and we found this bug existed in win7 32/64 ,win2k8 32/64/R2 


Dawu ,pls attach the failed logs to this bug
Comment 8 dawu 2012-08-26 22:21:43 EDT
(In reply to comment #5)
> Please attached the logs.

Hi Yan, 

I have attached logs for build29 before,please refer to the attached  StandardizedKeywords.wtl.

For buidl 34, please refer to the attached "StandardizedKeywords_34.wtl" for details.

Best Regards,
Dawn
Comment 9 dawu 2012-08-26 22:22:36 EDT
Created attachment 607093 [details]
StandardizedKeywords_34.wtl
Comment 10 dawu 2012-08-26 22:56:17 EDT
Created attachment 607098 [details]
StandardizedKeywords_34.txt

Please refer to the log with txt format.

Best Regards,
Dawn
Comment 11 Yan Vugenfirer 2012-08-28 04:05:13 EDT
Hi Dawn,

Just to be sure - what guests are suffering from this issue? In command line I see Windows 7 64bit. What other guests have the same problem?


Best regards,
Yan.
Comment 12 dawu 2012-08-28 04:26:53 EDT
(In reply to comment #11)
> Hi Dawn,
> 
> Just to be sure - what guests are suffering from this issue? In command line
> I see Windows 7 64bit. What other guests have the same problem?
> 
> 
> Best regards,
> Yan.

yes,this issue happened on guests which have this job. (win7-32/64 win2k8-32/64 win2k8-R2)

Best Regards,
Dawn
Comment 13 Mike Cao 2012-09-03 02:37:50 EDT
*** Bug 811155 has been marked as a duplicate of this bug. ***
Comment 14 Yan Vugenfirer 2012-09-04 07:58:46 EDT
Fixed also on OSes prior to Windows 8.
Comment 15 Mike Cao 2012-10-12 04:07:21 EDT
dengmin

Pls run netkvm whql test on latest virtio-win prewhql build to verify this bug 


Thanks,
Mike
Comment 17 Min Deng 2012-10-18 00:50:58 EDT
  The job mentioned in the bug passed on all the platforms that have it.
  Verified it on build 39. 
  For steps ,please refer to comment 0
  Expected Results&Actual Results,
  The job passes successfully on each OS,so the issue has been fixed now,thanks.
Comment 18 Mike Cao 2012-10-18 00:57:47 EDT
Based on comment #9 ,move status to VERIFIED.
Comment 19 errata-xmlrpc 2013-02-21 05:39:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.