Bug 834283 - Using left ctrl - alt - del does not work with windows 7 kvm
Using left ctrl - alt - del does not work with windows 7 kvm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
x86_64 All
high Severity high
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 842354
Blocks: 782183 840699
  Show dependency treegraph
 
Reported: 2012-06-21 08:23 EDT by Grant Williamson
Modified: 2013-02-21 03:47 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When part of a key combination matched the grab sequence, the last key of the combination was sometimes not sent to the guest Consequence: Left Ctrl+Alt+Del key combination was not passed to guests Fix: make sure we send all keys to the SPICE server even if they are part of the grab sequence Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:47:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
right ctrl-alt-del works from windows 7 guest, locks screen directly. (41.58 KB, text/plain)
2012-06-21 08:23 EDT, Grant Williamson
no flags Details
left ctrl-alt-del does not work takes 20-50 attempts before windows 7 guest locks. (84.22 KB, text/plain)
2012-06-21 08:24 EDT, Grant Williamson
no flags Details
Updated left ctrl - alt - del with spice patch (56.83 KB, text/x-log)
2012-06-21 10:28 EDT, Grant Williamson
no flags Details

  None (edit)
Description Grant Williamson 2012-06-21 08:23:00 EDT
Description of problem:
Using remote-viewer or virt-viewer with a Windows 7 KVM, left ctrl - alt - del key combination does now work. 
After 20-50 attempts it does.

Right ctrl - alt - del key combination works.

Key combination
ctrl-alt-del

Version-Release number of selected component (if applicable):
spice-gtk-0.11-11.el6

How reproducible:
Run RHEL 6.3 x86_64 as Host/Client
Install Windows 7 KVM as Guest
Connect to Guest using remote-viewer or virt-viewer
Left Ctrl Alt Del does not work.
Right Ctrl Alt Del does work.

Connect to guest using "spicec", left ctrl - alt - del works.
Comment 1 Grant Williamson 2012-06-21 08:23:47 EDT
Created attachment 593436 [details]
right ctrl-alt-del works from windows 7 guest, locks screen directly.
Comment 2 Grant Williamson 2012-06-21 08:24:32 EDT
Created attachment 593437 [details]
left ctrl-alt-del does not work takes 20-50 attempts before windows 7 guest locks.
Comment 4 Marc-Andre Lureau 2012-06-21 09:26:49 EDT
Can you try with this patch?

http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=4e419a1223fa4a44c02e76fa4972db3d6518c839
Comment 5 Marc-Andre Lureau 2012-06-21 09:27:23 EDT
wrong pach, this one instead:

http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=a18782415967fbc036608ccbba6005819ad7f58c
Comment 6 Grant Williamson 2012-06-21 10:28:38 EDT
Created attachment 593457 [details]
Updated left ctrl - alt - del with spice patch
Comment 7 Grant Williamson 2012-06-25 04:15:53 EDT
Marc I applied.

4e419a1223fa4a44c02e76fa4972db3d6518c839.patch
a18782415967fbc036608ccbba6005819ad7f58c.patch
dd6c260291e213ef1db8fad77516b702964ef90d.patch

This seems to work.
Comment 9 Christophe Fergeau 2012-09-07 09:46:53 EDT
This bug will get fixed at the same time as rebase bug #842354 then
Comment 13 errata-xmlrpc 2013-02-21 03:47:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html

Note You need to log in before you can comment on or make changes to this bug.