Bug 834286 - [VDSM] [RHEV-H6.3] PXE autoinstall does not hand over DNS properly if manually set
[VDSM] [RHEV-H6.3] PXE autoinstall does not hand over DNS properly if manuall...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: Documentation (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tahlia Richardson
ecs-bugs
network
: Documentation
: 848832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 08:30 EDT by Martin Pavlik
Modified: 2016-04-26 10:36 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 916029 (view as bug list)
Environment:
Last Closed: 2013-02-26 22:46:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (57.59 KB, application/x-gzip)
2012-06-21 08:30 EDT, Martin Pavlik
no flags Details
video of rhevh autoinstall with manual ip and dns configured (18.59 MB, video/ogg)
2012-08-07 03:58 EDT, Martin Pavlik
no flags Details
ovirt.log (22.63 KB, application/x-compressed-tar)
2012-08-07 10:43 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-06-21 08:30:16 EDT
Created attachment 593438 [details]
logs

Description of problem:
If DNS is specified manually (dns=10.34.63.229:10.34.63.228) as parameter for PXE auto install /etc/reslov.conf is empty after installation is finished


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 6.3 (20120615.1.el6)
vdsm-4.9-113.1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. do autoinstall from PXE with following parameters
dns=10.34.63.229:10.34.63.228:10.34.32.1 

Actual results:
/etc/resolv.conf is empty

Expected results:
/etc/resolv.conf is filled with DNS specified in PXE 

Additional info:

vdsm.log,vdsm-reg,vdsm-config, resolv.conf and ifcfg files after install attached

full line from PXE:

LABEL rhevh-6.3-20120615.1.el6-DELL-VLAN172
        KERNEL images/RHEVH/rhevh-6.3-20120615.1.el6/vmlinuz0
        APPEND rootflags=loop initrd=images/RHEVH/rhevh-6.3-20120615.1.el6/initrd0.img root=live:/rhevh-6.3-20120615.1.el6.iso rootfstype=auto ro liveimg nomodeset check rootflags=ro crashkernel=512M-2G:64M,2G-:128M elevator=deadline processor.max_cstate=1 rd_NO_LVM rd_NO_LUKS rd_NO_MD rd_NO_DM console=tty0 console=ttyS1,115200n81 firstboot storage_init=/dev/sda storage_vol=::::: ssh_pwauth=1 management_server=mp-rhevm30.rhev.lab.eng.brq.redhat.com:443 adminpw=LMi16hIGAvm0A rhevm_admin_password=gPA37ATxRODnA ip=10.34.67.68 netmask=255.255.255.224 gateway=10.34.67.94 dns=10.34.63.229:10.34.63.228:10.34.32.1 vlan=172 hostname=mp-rhev.rhev.lab.eng.brq.redhat.com
Comment 2 Mike Burns 2012-06-21 20:20:00 EDT
This is likely a generic ovirt-node/rhev-hypervisor problem.  Moving to ovirt-node for investigation.
Comment 3 cshao 2012-06-25 23:13:41 EDT
Test version:
rhevh-6.3-20120621.0.el6_3

Test step:
Auto install RHEV-H with below parameters:
BOOTIF=eth0 storage_init=/dev/sda dns=10.66.11.102:10.66.11.91 firstboot

Test result:
1. Autoinstall does not hand over DNS properly.
2. /etc/reslov.conf isn't empty, it will be covered by dhclient.

# cat /etc/resolv.conf 
; generated by /sbin/dhclient-script
search nay.redhat.com redhat.com
nameserver 10.66.127.10
nameserver 10.64.255.10
nameserver 10.11.255.155
Comment 4 RHEL Product and Program Management 2012-07-10 04:34:14 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:51:25 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 cshao 2012-07-29 23:19:55 EDT
Reproduce this issue after add parameter "ip=no" to kernel command line.

Test version:
rhev-hypervisor6-6.3-20120710.0.el6_3

Test step:
Auto install RHEV-H with below parameters:
BOOTIF=eth0 ip=no storage_init=/dev/sda dns=10.66.11.102:10.66.11.91 firstboot

Test result:
1. Autoinstall doesn't hand over DNS properly.
2. /etc/reslov.conf is empty.
Comment 7 Joey Boggs 2012-08-06 14:03:35 EDT
Martin,

Based on your pxe line, networking won't autoconfigure unless you specify a BOOTIF=XXX line or add IPAPPEND=2 I believe to auto specify it.

Can you get the logging output of the autoinstall either via serial output or a screenshot? Try adding the BOOTIF arg as well to see if that clears the problem.

    print "Configuring Network"
    if OVIRT_VARS["OVIRT_BOOTIF"] != "":
        network_auto()
Comment 8 Martin Pavlik 2012-08-07 03:56:51 EDT
(In reply to comment #7)
> Martin,
> 
> Based on your pxe line, networking won't autoconfigure unless you specify a
> BOOTIF=XXX line or add IPAPPEND=2 I believe to auto specify it.
> 
> Can you get the logging output of the autoinstall either via serial output
> or a screenshot? Try adding the BOOTIF arg as well to see if that clears the
> problem.
> 
>     print "Configuring Network"
>     if OVIRT_VARS["OVIRT_BOOTIF"] != "":
>         network_auto()

oops, BOOTIF must have slipped from my copy & paste but it was there, now I tried again with following PXE line, video recording of console is attached


LABEL rhevh-6.3-20120710.0.el6_3-DELL-temporary for manual DNS input testing
        KERNEL images/RHEVH/rhevh-6.3-20120710.0.el6_3/vmlinuz0
        APPEND rootflags=loop initrd=images/RHEVH/rhevh-6.3-20120710.0.el6_3/initrd0.img root=live:/rhevh-6.3-20120710.0.el6_3.iso rootfstype=auto ro liveimg nomodeset check rootflags=ro crashkernel=512M-2G:64M,2G-:128M elevator=deadline processor.max_cstate=1 rd_NO_LVM rd_NO_LUKS rd_NO_MD rd_NO_DM console=tty0 console=ttyS1,115200n81 firstboot storage_init=/dev/sda storage_vol=::::: ssh_pwauth=1 adminpw=LMi16hIGAvm0A ntp=10.34.32.125 rhevm_admin_password=gPA37ATxRODnA management_server=mp-rhevm31.rhev.lab.eng.brq.redhat.com:443 ip=10.34.63.136 netmask=255.255.252.0 gateway=10.34.63.254 dns=10.34.63.229:10.34.63.228
IPAPPEND 2
Comment 9 Martin Pavlik 2012-08-07 03:58:48 EDT
Created attachment 602668 [details]
video of rhevh autoinstall with manual ip and dns configured
Comment 11 Martin Pavlik 2012-08-07 10:43:56 EDT
Created attachment 602774 [details]
ovirt.log
Comment 12 Martin Pavlik 2012-08-07 10:44:58 EDT
Addition for comment 11, host was installed again however used PXE line should be the same.
Comment 15 Mike Burns 2012-08-16 10:24:31 EDT
*** Bug 848832 has been marked as a duplicate of this bug. ***
Comment 22 Tahlia Richardson 2013-02-26 22:46:03 EST
Closed - fix made for RHEL 6.4 release.

(Comment 21 is being handled in Bug 916029).

Note You need to log in before you can comment on or make changes to this bug.